Thread: Deus Ex GOTY - Conversations cut short

Deus Ex GOTY - Conversations cut short

  1. #1

    Deus Ex GOTY - Conversations cut short

    Howdy folks,

    I am having difficulty with the conversations in DX GOTY being cut short by about a second or two... more if I am not standing completely still and giving no input to the game at the time of the conversation, be it a cut-scene or an infolink conversation.

    While I realize that Mouse1 input during a cut-scene will skip to the next segment of the conversation, even when I do nothing one character will start talking before the other has completely finished. It's much worse during gameplay with the infolink... I'll just be walking along while the character is speaking, and all of a sudden, they will just stop. The text window will either continue as normal, or just quickly jump to the end, so I can still get the content, but no sound. For a while I would simply go to the Conversations tab and go through what was said, but that got annoying, especially when I got to the end scene and could not go back to the Conversations tab because the game was now over.

    Any suggestions?

    BTW, while this may seem noobish of me, I must say that I just installed the "holy trinity of Deus Ex Goodness" (i.e. the Shifter mod, the High Definition Texture Pack, and the enhanced OpenGL and Direct3D8 rendering engines), and was very pleased with the results. Everything looks better, and the game runs smoother(faster?). I highly recommend it to all.

    It still didn't fix my sound problem, however.

  2. #2
    Join Date
    May 2009
    I was having this problem too under WindowsXP until I set the game to Windows98/WindowsME compatibility mode.

    Find the shortcut to the game and right-click on it and select Properties.

    In the Properties window click the Compatibility tab at the top.

    Then check the option "Run this program in compatibility mode for:" and select Windows 98 / Windows Me from the drop down list. Click OK and you're all set.

    Hope this helped!