Thread: I fixed the startup crash, lets hope it works for everyone

I fixed the startup crash, lets hope it works for everyone

  1. #1

    I fixed the startup crash, lets hope it works for everyone

    I just put my directx sound hardware acceleration all the way up and the game worked fine.

    start>run>dxdiag>sound 1> crank the hardware sound acceleration all the way up.
    worked for me, hope this helps.

  2. #2
    Join Date
    Apr 1998
    Location
    Blackfriars
    Posts
    3,885
    Vista users wont get that unfortunately as Vista removed DirectSound.

    However does raise an interesting point. The game uses OpenAL for audio rendering. Its installed automatically via the installer, however some people may uninstall it, or have an older version installed etc.. Try uninstalling openal from add/remove programs and download the latest version here

  3. #3
    Is there any way to disable OpenAL hardware acceleration?. I'm having crash to desktop problems with this game. I had those issues in Unreal Tournament 3 and got them fixed by disabling OpenAL. In UT3 only happens with X-Fi cards with X-RAM (like mine). I wonder if this problem could affect Kane & Lynch too.

  4. #4
    Originally Posted by Juanlo
    Is there any way to disable OpenAL hardware acceleration?. I'm having crash to desktop problems with this game. I had those issues in Unreal Tournament 3 and got them fixed by disabling OpenAL. In UT3 only happens with X-Fi cards with X-RAM (like mine). I wonder if this problem could affect Kane & Lynch too.
    U can switch to directsound in game in the audio options.

  5. #5
    Join Date
    Jan 1970
    Posts
    2,400
    Originally Posted by clownman64
    I just put my directx sound hardware acceleration all the way up and the game worked fine.

    start>run>dxdiag>sound 1> crank the hardware sound acceleration all the way up.
    worked for me, hope this helps.
    Cool, thanks for letting us know. Has this been working for others?

  6. #6

    Exclamation Another Fix

    Originally Posted by Keir
    Cool, thanks for letting us know. Has this been working for others?
    Yes. But on mine I had to turn the acceleration down to work. its seems the startup crashes are related to sound acceleration.

  7. #7
    Join Date
    Jan 1970
    Posts
    2,400
    Originally Posted by PDC_Emulator
    Yes. But on mine I had to turn the acceleration down to work. its seems the startup crashes are related to sound acceleration.
    Cool, thanks for letting me know

  8. #8
    It didn't work for me.
    I had the hardware accelerator originally turned all the way up, tried turning it down but still, the crashes preserved.

  9. #9
    Join Date
    Dec 2007
    Posts
    3

    Thumbs Down Still broken for me too

    Originally Posted by RoundInTriangles
    It didn't work for me.
    I had the hardware accelerator originally turned all the way up, tried turning it down but still, the crashes preserved.
    Same here, turned it up and down, this all started happening since I installed the updated X-Fi drivers for my sound-card. Maybe I should try rolling them back to standard, or turn down the cards acceleration.

  10. #10
    my crashes to. or at least it goes in slowmotion!
    using soundmax drivers for my soundcard.

    turned up and down the acc. at dxdiag

  11. #11
    Join Date
    Apr 1998
    Location
    Blackfriars
    Posts
    3,885
    Originally Posted by snubbeltramp
    my crashes to. or at least it goes in slowmotion!
    using soundmax drivers for my soundcard.

    turned up and down the acc. at dxdiag
    Purely for `diagnostic` purposes have you tried disabling your soundcard and see if that makes a difference. Am trying to remember if game works if it doesnt detect a sound device.

  12. #12
    Join Date
    Oct 2009
    Posts
    4
    ERROR:
    AppName: kaneandlynch.exe AppVer: 1.0.0.129 ModName: kaneandlynch.exe
    ModVer: 1.0.0.129 Offset: 00048024


    Any help???

  13. #13
    HI,

    I had the same problem, the game would crash as soon as you would stat it. I fixed it up by enabling DirectDraw Acceleration in my dirextx properties

  14. #14
    Join Date
    Aug 2010
    Posts
    1
    hi guys!

    i recently purchased k&l2 dog days....and i thought i'll replay k&l1 dead men just to freshen up on the story a bit...
    I already played this game back when it was released on WinXP, now I grabbed the disc from the shelf, installed it & it came up with this runtime error @ startup (i have XP SP3 now).

    I looked at the solutions everyone posted and basically tried every single one of them.....neither one worked. I deleted & reinstalled: DirectX, Visual C++ Runtime 2005, 2008 + SPs, Microsoft .NET (all versions + SPs), video drivers, sound drivers, mainboard drivers, openAL, EAX, Games for Windows Live & Redist....everything

    i have tried running it on every possible sound acceleration level in dx diag...no luck

    it's not working, but how? it did back then....same computer
    i also tried with the old XliveRedist that came with the game on the disk...same error

    thing is...didn't this game have a config window BEFORE you launched it?? it always ran at the first time you started the game & you could set your resolution & other stuff in it.....didn't came in for me...
    could there be command line parameter for it. like "-setup" or "-config"? (these are not it..)
    note 2: wasn't this the game that messed with your USB ports & you had to disable something in Hardware Device Magager to get it to work??

    when i start it, a loading bar comes in & then the crash...not even a video starts (shouldn't this be starting with the intro?) maybe it's the bink system that's faulty...

    or what about the main.ini file.......does someone know how to set the sound to software or resolution to 1024x768 in it? (maybe someone who got it running should share the config file, it's in: Docs&Settings\...username...\Local Settings\AppData\kaneandlynch)

    any help would be appreciated...

    ps: oh and another thing.....i don't know why, but i tried running this game in SandBoxie and looks like it did something with the file: "C:\Docs&Settings\..user..\LocalSettings\AppData\Microsoft\Xlive\Titles\..\config.bin" & also it messed something with IE cookies...dont know what this is, but might help

  15. #15

    runtime error

    hi can u let me know where can i enable Direct Draw Acceleration



    Originally Posted by bluedolphin
    HI,

    I had the same problem, the game would crash as soon as you would stat it. I fixed it up by enabling DirectDraw Acceleration in my dirextx properties

  16. #16
    Originally Posted by austin2012
    hi can u let me know where can i enable Direct Draw Acceleration
    Here!
    Originally Posted by clownman64
    I just put my directx sound hardware acceleration all the way up and the game worked fine.

    start>run>dxdiag>sound 1> crank the hardware sound acceleration all the way up.
    worked for me, hope this helps.
    i wish IOI can buy back Kane & Lynch !