Thread: Deus Ex: Invisible War locks up at menu screen.

Deus Ex: Invisible War locks up at menu screen.

  1. #1

    Unhappy Deus Ex: Invisible War locks up at menu screen.

    I bought and downloaded Deus Ex: Invisible War from Direct2Drive (an IGN service) tonight. Just now, I am trying to run the game, but seem to be out of luck. The game loads and tries to go to the menu screen, but hangs right there. The menu tries to load, but doesn't, and there's a bit of music that is continually looping. I cannot get out by doing either an ALT-F4 or a CONTROL-ALT-DELETE. Really annoying. I was really looking forward to play this game, never having gotten around to playing it when it came out...

    My system is an Intel Core 2 Extreme @ 2.8GHz, 4GB or RAM, ATI Mobility Radeon HD 2600XT and I'm running Windows XP Professional SP2. Any ideas what this problem might be? I've seen it mentioned elsewhere, but people experiencing it were running the game on a Radeon 9600 or 9700. Could it indeed be that the game doesn't like ATI and it's drivers? My system should be plenty, plenty fast, so that shouldn't be the problem.

    Really, any ideas? I haven't tried running it in compatibility mode yet, so I'll try it now, running under Windows 2000 (or at least it will think it is).

    Thanks for any help!

  2. #2
    Setting the compatibility mode to Windows 2000 didn't work, but Windows 98/ME seems to work at least a bit. The game now crashes later in the game, instead of at the menu screen. Still really annoying. Hope it gets better.

  3. #3
    The 98 compatibility shouldn't work, but go figure. I'm thinking it's something with the dual core processor. Something about setting it to single core when trying to play the game. You should be able to find the right help by searching the term.

  4. #4
    Originally Posted by Catman
    The 98 compatibility shouldn't work, but go figure. I'm thinking it's something with the dual core processor. Something about setting it to single core when trying to play the game. You should be able to find the right help by searching the term.
    Well, the 98 setting did work better than either the 2000 setting or running it natively. But yes, it still crashes a lot. Really frustrating. Yes, I saw HyperThreading mentioned somewhere and the trick with the Process Manager to turn HT off. Can't remember if that was for DX or DX2, though. I'll do a thorough search. But until I find a solution, this is really annoying. Having bought a game to find it doesn't run properly. On brand spankin' new hardware, to boot. Weird!

  5. #5
    Okay, I had a look at the processor affinity, and found out I already had the EXE set to only run on processor 0. So no, it didn't work. Darn! How to solve it now?!... (Thank god Metroid Prime 3 just came out; at least I'll have a good game to put my hands on until I get this one to work!)