Thread: Install at 80% and this is after 2hrs!

Install at 80% and this is after 2hrs!

  1. #1

    Install at 80% and this is after 2hrs!

    My install has taken 2hrs to get to 80%! All secruity, internet etc off!

    Any ideas please? I did try the DVD on another computer and it worked at work but here on my bestest ever PC, no luck...?

    Thanks in advance

  2. #2
    It had to be your DVD drive.

  3. #3
    Originally Posted by Asterothe
    It had to be your DVD drive.
    yeah remember its something like 6 gigs!

  4. #4
    Battlestations: Midway Lieutenant Commander
    Join Date
    Aug 2006
    Posts
    5,513
    Yeah it either the DVD drive or could be your C drive is going.

  5. #5
    Thanks for the replies. My harddrive is spanking new so i suspect my DVD drive. I've installed many games in this drive before but maybe this being a larger install she "just can not do it, captain!"...

    I'll try another drive this eve, and scream, post like hell if theres something else. At the moment the game (box, CD) is a nice cup coaster up to now.

    I'd love to play...

  6. #6
    Originally Posted by grahamwookie
    Thanks for the replies. My harddrive is spanking new so i suspect my DVD drive. I've installed many games in this drive before but maybe this being a larger install she "just can not do it, captain!"...

    I'll try another drive this eve, and scream, post like hell if theres something else. At the moment the game (box, CD) is a nice cup coaster up to now.

    I'd love to play...

    Some games have copy protections sytems that cause trouble with DVD
    players I don't know if BS has it. I have X360 version but I'll get PC version
    too.

  7. #7
    Yeah BSM has SecuROM copy protection. Well at least the DVD version does. It gives me an error everytime I try and start the game.It say SecuROM wrong disc inserted blah blah put in correct disc and try again. I have to eject the DVD put it in again wait for the Autorun screen to pop up then click play. That usually works. I only have a DVDROM drive so there is no copy software such as Nero,Alcohol or any Emulation software on my PC. I don't know if it's my DVD drive maybe it's not supported by SecuROM. It's a LiteOn DVD-ROM LTD163D. Anyone else have this drive and have problems with SecuROM.