Thread: If you are recieving a Vertex error when launching Just Cause

If you are recieving a Vertex error when launching Just Cause

  1. #51

    guess what

    still not working, putting me right off pc gaming! might aswell just burn my money!

  2. #52
    well especially if u bought it from Game cos u cant take it back cos their returns policy is the biggest load of bull ive ever seen in my life

  3. #53
    Yeah, I'm getting the same thing too. The only catch here is that I bought the game off of Steam, and I'm getting the messages. When I tried to run the .bat files through 3D-Analyze, I got the message, "Could not find Steam."

  4. #54
    maybe in 1-2 years they'll release a patch that will solve the issue, be patient

  5. #55
    thats not the point. Game companies are gettin so lazy these days and this is 2 games now that Eidos have published that arent up to scratch. 1. RACE WTCC Game and then Just Cause

  6. #56
    Hey, well i know this post is rather old, i'm getting the same errors too, and i was just thinking to myself then, i tried just cause for 1hour, you know where you play for 60 minutes then you have to pay money to play the rest? well i played for 1 hour, no problems what so ever, it worked all fine and dandy, but to continue playing it was going to cost £30, so i decided to get a DVD copy from and i get these vertex and pixel shader errors now.... So my guess is, is it to do with the DVD copies?

  7. #57
    intrepid_soul Guest
    Did you uninstall the trial version first? Try uninstalling and reinstalling, if you had it working it should work just fine, the shder error usually is never fixed without the 3d analyze program.

  8. #58
    yes, i have uninstalled both the demo and the trial, and i still get the same erros, so thats why i'm confused

  9. #59

    Just bought game

    3.0 Ghz pentium
    2.5 Gb ram
    Evga 7800 GS with onboard 256 ram. SUpports 3.0 shader model.

    This is a game that I have been meaning to try for some time. I finally found it and I get a vertex shader error. I have tried the following:
    1. Uninstall. Re-install
    2. Try demo, demo works
    3. Copy DLL's from demo to my Full version of just cause.
    NOTE: My error changes now. Instead of a black screen and a pop-up with the vertex shader errors, the game doesn't launch, and has a regular windows pop-up that states I need to have a video card that support 1.1 shader model.
    4. I have tried 3danalyze to no avail. emulate HW Tnl caps, or force 1.1, 1.4 shader, or skip 1.1 , 1.4 shader...... nothing worked.

  10. #60
    Join Date
    May 2007

    Got it to work

    Well I was having this same Error Message come up, Tried everything, updates, 3d emulations(which worked but was rather buggy). So I went to circuit city, found a card that said pacificly that it was Shader 3.0 compliant or something along those lines. Put it in my pc and game went off without a hitch. Note that I can only play with everything on my pc closed, but I might just need a memory upgrade(running 512). But it worth the 50 bucks to go pick up a 256 card from circuit city. GeForce 6200 LE

  11. #61
    Join Date
    May 2007

    If all else fails Try the method in this thread, if this doesn't work, its not your graphics card upgrading would be useless. note the game will be unplayable with these settings but it will start up and show you that it is your graphics card and not the software

  12. #62
    Just a thought... I know this is cross posting (sry) but maybe relevant. I had this error with the steam ver of the game. I got the error, nuked the game and reinstalled and then didn't touch any video settings (which I had done the first time).

    Maybe there is a problem in the code that is triggered by switching resolutions. I even tried switching resolutions back but it wasn't untill I reinstalled that I got it working.

    Have the guys testing this problem done this? I went straight to 1280x1040 cuz that's my monitors native resolution. I'm guessing a lot of other people would probably do the same.

    If I'm wrong, then I'm sorry for wasting your time, but hey, it never hurts to throw it out there.

    **Update** I tried changing the resolution and the game launched fine. I may be jinxing myself but I'm going to try and reproduce the error. (maybe it involves changing resolutions prior to first launch of the game?)

  13. #63

    Thumbs Down Same Problem

    Hey Guys, Know This Is An Old Thread, Just posting some info for the guys/girls

    I bought the steam version of Just Cause. And Im Ticked Cuz I Used Up all My Internet to get it
    I am on a Toshiba Laptop, But, Im not using Nvidia or AVI Cards.
    Im Using a INTEL 945GM Express Chipset Family.
    I am also running on Windows Vista [But i checked on a site that All Games On Steam Will Work With Vista]

    So Now i Learn that i for a change are not the only one experenceing problems with Games.

    I just find it very strange that i can do many other games, and not Just Cause.

    Please Help, [would be much appreicated]

    P.S Sorry For Grammar/Spelling [Im shocking]


  14. #64

    no solution?

    I'm assuming guys that there still is no solution? Just got this game after watching someone play it on 360. I'm very disappointed that there isn't even any patches out for the game yet.

    got the same dam error

    p.s. i have tried all fixes mentioned on this forum plus others. still can't start the game

    sys stats

    Win XP SP2
    .net framework 1.1, 2 and 3
    1.5 gb of ram
    ATI 9800Pro 256 agp app 256
    2046 mb virt mem
    cat 7.7 drivers
    dfi lanparty NF2 rev. b
    AMD XP2600+

  15. #65


    guys, thats silly
    why cant you just realase some kind of patch...
    i love this game, cuz i played the demo
    today i bought the full version, i've installed it and...ZONK!
    problem with P/V shader, WTF?
    i have a GF7900GT, along with AMD Athlon 64x2 5600+, 2 Gigs of ram and a MSI k9N Platinium motherboard, all my games run more than fine, why this piece of doesn't?
    it says, that i don't have SM1.1, prffff , my graphics card hass 3.0...
    common boys, get to work, we're paying you to make a good game, and if it has problems-fix them with a PATCH, it doesn't take too long to make a patch, maybe 2 weeks, and after that you can go back to Hawaii and ignore us...but make a ^$@&*@ patch that will repair this 4^!&*&)^) game...

    gosh, i'm sorry for that, but it freaks me out, that i can't play a game, that i have paid for...

    pls, guys, fix it ASAP!!!! It is really a great game, and i respect your job (thats why i didn't download the game [no serrial...] but i bought it, pls, help!!!!)

    p.s.-I'm NOT playing on a laptop...Just Cause is the first game that i have problems with ((((

  16. #66
    For what its worth...

    I downloaded it using steam, it wasnt working on either of my two pc's.

    I got annoyed, renamed the name of the "just cause" folder in steamapps/common to "just cause2", in steam tried to delete it (right clicked it, delete local content) then moved it back and tried to download it again (thinking it would just redownload the gcf's and verify the just cause folder contents.

    It didnt, it went to download the whole thing again, but started at 20%. Messing about some more, by opening and closing steam a few times over two hours it eventually got back to 60% through downloading and i guess using the existing files. So i tried to launch it and instead of saying how long left to download, it launched, fine.

    So i can only guess that reinstalling can work, but it is buggy as hell.

  17. #67
    Join Date
    Aug 2007
    I'm getting the same error. I just tried the demo yesterday, and that worked, then I paid $30 for the full game on Steam. And it doesn't work.

    Update: I selected "verify game content" on the Steam menu, and it started the download again at 87%. When it was done I was able to play the game and it worked.

  18. #68
    Shouldn't we get our money back? Eidos has released a massive faulty batch(all their Just Cause games). We should theoretically get our money back because they've failed to provide.

    Just reading back of book.

    Eidos limited Warranty
    Eidos warrants the original purchaser...(look at back of book, page 21)

    So what if we purchased the game from the store "GAME" which doesn't offer money if you take back faulty goods, they will just continuously give you another game to try, because there so tight arsed that they think EVERYONE is gonna copy the whole game into their computer, mount it onto another disc, then take original back to petty.

    Hmm...wonder if i'll be able to move all my files into steam, and try and get steam to comply with it :P

  19. #69
    Join Date
    Jul 2007
    Well, i just redownloaded it via steam and its all good now, i changed the resolution during the startup and it's all gg. Im guessing a reinstall should work, as seein it worked with a few peps.

  20. #70
    Oh, well i got it to work on about the third reinstall, i didn't change and video settings this time and it worked! But i was kind of disappointed :|. Its not as fun as i hoped, oh well, at least i can say i played it :P

  21. #71
    Join Date
    Feb 2008

    No vertex error!

    *** thanks guys! I have reinstalled demo and no *** vertex error. Many thanks (but I still think that Eidos do nothing) Try to reinstall, it may help
    oh, btw, after this, i'm going going to buy this *** amazing game, I love freefalls.
    (Sorry for this post, but I'm *** excited)

  22. #72
    Maybe it will help tech guys

    ok I had
    GeForce 6200 GT
    Athlon 2200+
    512 Ram
    Mainboard with nforce 2 chipset
    I wasn't able to play this game because this ty error. I could play demo, but full game couldn't start
    After some time I've changed the graphic card and now I have
    GeForce 6600 GT Gainward
    Still same error.
    I've bought after some time 1 GB Ram
    So now i have 1,5 GB Ram - Still same error.
    Couple days ago i bought new processor.
    Athlon 3000+ ( barton ) - STILL THE SAME ERROR !!!
    So it is clear for me, that that game is colidating with mainboard chipset !!!
    ( I have the newest drivers, and directX 9.0c )
    System of course Windows XP SP 2
    And I was cleaning completely system after each hardware change.

  23. #73
    Join Date
    Apr 2008
    Yeaah...i have the same start up error of shader version and stuff, but what's really wierd is that some time ago i installed the game and played it for week without any problem then i decided to format my C partition and reinstall windows, then i reinstalled the game and i can't play it anymore what has changed since the last Operating System is directx now i have the 10 version and nero 8...that's all, but i don't think it's from directx10 because all my other games work. IT'S REALLY REALLY REALLY REALLY FRUSTRATING!!!

  24. #74

    just (stupid) cause

    just bought the game i have a brand new hp pavillion a6519fh PC.
    same shading errors as all the rest.
    i have tried all the suggestion, except how about this one you should refund my money. if you guys are going to produce a game then figure out the problem ar recall and refund.... i would love to play the game so some help would be nice.....

  25. #75
    and from the looks of this forum eidos doesnt care because these post ere almost 6 months ago and seems to mee they are trying to just let us forget and move on , problem is they are still selling the game. so get off your behinds and help us solve this problem and fast

Page 3 of 4 First First 1234 Last