Page 2 of 2 First First 12

Thread: Deus Ex: Invisible War crashes at load screen

Deus Ex: Invisible War crashes at load screen

  1. #26


    Here's my specs...

    XP Media Center
    Dual Centrino @ 1.6GHz
    2x 512 PC4300 DDR2-SDRAM1GB RAM (1GB)
    Mobile Intel(R) 945GM Express Chipset Family (integrated)
    93GB HD
    DVD+/-RW (not sure brand...)

    gta san andreas runs well on medium draw distance and low graphic settings, and it's newer than dx2... but then again I remember playing dx2 on my now deceased ailenware notebook and it being rather graphic intensive for the time. perhaps it is still too much for my dime-a-dozen toshiba satellite to swallow.

  2. #27
    Originally Posted by Kneo24
    For something under $100 for a video card, I'd suggest either an 8400GS from Nvidia, or a Radeon 2400 from ATI (You'll get a little more bang for the buck if you go with the 8400GS, and twice the amount of memory on the card).

    It might be saying you only have 898 for one of two reasons.

    1.) It could be telling you how much you have available (not currently being used.
    2.) Windows is using a different system of memory size. Instead of binary, it's using something else.

    You have enough RAM, so I wouldn't worry with that. If you really want more, you'll have to tell us what type it supports (it should tell you this in the manual that came with the PC, or on the vendors website).

    Anyway, those two recommendations are under the $100 price range. If you live in America, you can buy them on
    Would those work well for Deus Ex 2, Oblivion, or both? Or would I have to go with the "twice the price" model to get to Oblivion level? Vista looks nice, but apparently runs slow (if Vista would just shut down it's interface while games were playing, perhaps things would run better).

    I've heard testimony from a guy who used the graphics card I have integrated into my PC and he said that Oblivion plays terrible even on the lowest settings. If the poor graphics card interferes with gameplay that much, I'm not sure if I want to purchase Oblivion just yet...

  3. #28
    Either of those cards should work just fine. Just do a little comparing. You might find a 8500GT, for example, to be the better buy. Here's a more direct link to what I'd recommend under the $100 price tag:

  4. #29

    Big Grin Deus Ex 2 Solution!!!

    Hello Everyone, My Names Ed and I've found a solution!

    I was literally at the point of uninstalling DX2 and giving up.
    However, I hate being beaten by games!

    So, here is the solution I managed to come up with, if you have been like me, installed the patches, new drivers etc and still doesn’t work (even though it used to when you bought it back in 2003!!!)

    Ok, this is for determined people everywhere, it’s clunky, but it works for me.

    [B]POINT 1 [/B](Game doesn't load saved games)

    Whenever you load a game, it just freezes and wont progress? Ultimately leading to a reset of PC well, here is the solution to this (This will also work for when you load into a new area)

    1) Start loading the game
    2) After about 5 seconds of it not working, hit Ctrl + Alt + Delete, if this doesn’t immediately bring up your console, do it again until it does.
    3) Now, Alt + Tab to the Console and go to Task Manager, you should see Running Programs "Ion Launcher" Kill this task.
    4) Now you will be back at desktop, wait 3 to 4 seconds and bam, Ion Launcher restarts and your game will hopefully load.

    POINT 2

    Ok, so basically, you cannot save in the Bio Labs and when you get in the Bio Labs lift (elevator) it crashes to desktop? What I did for this problem was before I started the game, I opened up;

    1) My Documents Folder to "Deus Ex - Invisible War"
    2) Started the game, loaded up and got to the elevator point, literally, in the elevator ready to click the button.
    3) Alt + Tab to the my documents folder, and locate the "Current Save" folder within the "Deus Ex - Invisible War folder"
    4) Completely Delete the current save folder (Make a Backup of this)
    5) Alt + Tab back to the game and travel to the Seattle upper levels.

    Now, with a bit of luck this should start you in the upper levels of Seattle.
    If it doesn’t work the first time, repeat this process a few times, it will hopefully work, I mean it did for me the first time. But then I had to do it maybe 3 or 4 times to get it to do it again.

    POINT 3

    Right, so now you are in Seattle, but, you will probably be a woman, with no Guns or Biomods, even though you maybe started as a guy? Well, you will end up playing the game as a chick, but I can sort out your missing items.

    Ok, so this following bit is courtesy of Gamespot UK,

    To use this, I suggest making a copy of your DX2UI.ini file, which can be found in the game's /System folder. The original should be modified like so:

    Find the tag named "[DebugMenu]" and modify the data to match this:


    Once done, save this and load the game. You'll notice a menu in the screen on the lower right. To use it, load or start a game, press escape to bring down the HUD, and scroll the menu with your mouse.

    Ok so now you have the debug menu, Hit ESC and go to the debug menu,
    Cheats and go to ALLWEAPONSLOAD.

    Now once you select this and go back to the game, Bam, a long line of everything appears from the game.

    What I did is got a long corridor and looked slightly up and it spawned everything in a row. I collected and repeated until I had precisely what I had before I lost everything from bio labs.

    I then saved, went back to the system folder and restored the original file so I did not have cheats enabled.

    It can be a Bit of a Drag, but ultimately if you are desperate to play the game you'll do it, And after the initial pain of restoring your items and changing file names, all you will need to repeat is POINT 1, Ctrl + Alt + Delete and killing the ion launcher.

    Happy Gaming Deus Ex fans (Cant wait for Number 3 )

    Ed (check my tunes out at )

  5. #30
    Hello, me again. I upgraded to a NVIDIA 8600 GT 512 Overclocked card by PNY, and now I'm not getting the error thing, instead it crashes before it even loads.

    "dx2.exe has stopped working, Windows is checking for a solution."


    "A problem has caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

    Except, of course there is no solution they can notify me about. Anyone care to notify me of a possible solution?

    Okay, I reinstalled the thing, and I STILL get a VIKTORIA error, okay I'm using a next to top of the line graphics card, the only thing better than this, according to the back of the box is an 8800. This is a MODERN graphics card, this game is near five freakin' years old, this card was manufactured last year.

    Error Message
    Exception 0xC0000005: Access Violation

    Call Stack
    0x005F3A7F DX2MAIN! (+0x1F2A7F)

    Register Info
    EAX=0x0012E4F0 EBX=0x7FD724B8 ECX=0x7FD724B8 EDX=0x00000000
    ESI=0x00000000 EDI=0x7FD83918 EBP=0x7FD52A00 ESP=0x0012E42C EIP=0x005F3A7F

    System Info

    EXE Name : C:\Program Files\Eidos Interactive\Deus Ex - Invisible War\System\DX2Main.exe
    EXE Date & Time : 17:18:22 2/11/2004
    Current Directory : C:\Program Files\Eidos Interactive\Deus Ex - Invisible War\System
    PDB File (not found) : C:\Program Files\Eidos Interactive\Deus Ex - Invisible War\System\DX2Main.PDB
    Current Date & Time : 01:39:25 PM 1/23/2008
    Username : User
    Computer Name : USER-PC
    OS Version : Windows (unknown)
    Time Since Boot : 38 hours 24 minutes 1 seconds
    Physical Memory Usage : 46
    Physical Memory (Total) : 1608384512 bytes (1534 megabytes)
    Physical Memory (Available) : 862085120 bytes (822 megabytes)
    Swapfile (Total) : 3463839744 bytes (3303 megabytes)
    Swapfile (Available) : 2601279488 bytes (2481 megabytes)
    Virtual Memory (Total) : 2147352576 bytes (2048 megabytes)
    Virtual Memory (Available) : 2055413760 bytes (1960 megabytes)

    Standard DLLs
    msvcrt.dll - Version 7.0.6000.16386 from C:\Windows\system32
    msvcrtd.dll - NOT FOUND
    msvcirt.dll - Version 6.0.6000.16386 from C:\Windows\system32
    msvcirtd.dll - NOT FOUND

    DirectX DLLs
    dsound.dll - Version 6.0.6000.16386 from C:\Windows\system32
    dinput.dll - Version 6.0.6000.16386 from C:\Windows\system32
    d3dim.dll - Version 6.0.6000.16386 from C:\Windows\system32
    ddraw.dll - Version 6.0.6000.16386 from C:\Windows\system32
    dplayx.dll - Version 6.0.6000.16386 from C:\Windows\system32

    Unreal DLLs
    Core.dll - NOT FOUND
    D3DDrv.dll - NOT FOUND
    Editor.dll - NOT FOUND
    Engine.dll - NOT FOUND
    Fire.dll - NOT FOUND
    DXAudio.dll - NOT FOUND
    IpDrv.dll - NOT FOUND
    Render.dll - NOT FOUND
    WinDrv.dll - NOT FOUND
    UWeb.dll - NOT FOUND
    Window.dll - NOT FOUND

    App-Specific Logging Text
    *** Win32 Runtime Fault : ACCESS_VIOLATION
    *** Build Feb 11 2004 17:16:57
    *** Thread Id : 00000478h
    *** Stack Trace Follows...
    frame: IP=005F3A7F SP=0012E42C BP=7FD52A00
    { 0001:001F2A7F C:\Program Files\Eidos Interactive\Deus Ex - Invisible War\System\DX2Main.exe }

    I think it SHOULD be safe to say it's not my video card this time, eh? Then what on God's good Earth IS IT?!

    Could it have something to do with those .dll files it says are NOT FOUND? Maybe I should try looking for one of those dll sites to see if I can get them or something. Worth a shot, anyway.

    Okay, found, downloaded, and copied into the proper places, except for the unreal stuff-not sure where those go. I could see if I can just find them, I suppose.

    It's back to saying the program's stopped working...

  6. #31

    Me too DJGamer

    Greets all,

    Hey DJGamer, nice upgrade to the 8600. And to answer your question, No, having the 8800 would not improve your situation. I have 2 of them in running in sli and I'm getting the exact same error.

    BTW, one of the previous posts listed all the unreal dll's and where they were found. That would be my guide. I might attempt what you're doing if you succeed. If you get it working please post and let me know.

    *Update* After about an hour I finally got the game to work.

    Long overdue update... well since it's almost been 1 year and I've received a couple of emails concerning this, the latest being last night, I figured I'd better do something to help before I either lose the information or die. ha ha Anyway, the way that I originally got the game working I described as a two step process. I have no clue what I was talking about. The original install was on a different operating system. Which I don't really use that much anymore, but still have access to. After I was contacted yesterday I re-downloaded the game and it proceeded to crash during start up. Which was to be expected, so situation normal. The fresh install executable file for the game, DX2.exe was roughly 1.5 MB. The working installation's executable file weighed in at a mere 30 KB. So I renamed the chubby one and copy/pasted the 30 KB DX2.exe in the new installation. The game started without issue. Now the original install was in a 32 bit environment and the new install is in a 64 bit one, both vista ultimate. I've taken the liberty of uploading the working DX2.exe in zipped format to my rapidshare account for direct download. The compressed file size is just over 16 KB.
    I apologize for not posting this sooner.

    Game on,

  7. #32

    Found new fix for Main Menu Crash

    I have been getting a crash in the main menu until I right clicked/properties the dx2 exe and ran it in Windows NT. service pack 5 mode. It seems to run on my slied GeForce 7600gs fine with the 1.02 patch too. If this was helpful for anyone else please reply and I will spread the word to other sites. Good Luck and enjoy. IF you want to know my specs also ask..Im on XP

  8. #33
    Join Date
    Dec 2009
    Originally Posted by xy0n28
    I think I might also be having the same problem. But i see all the logos and hear the sounds fine. It is when i encounter the first loading screen with the blue building that my game crashes to the desktop.

    this is the same spot im stuck at my computer crashes an then it says wrong disc anybody know what im doin wrong?? im useing radeon 9800 somebody please get back at me im ready to play this

  9. #34
    Join Date
    Dec 2009

  10. #35
    Join Date
    Dec 2009
    if this game was a person i would kick it in the nuts

  11. #36
    I kept getting crashing (winXP, ATI graphics, core2 dual core) when changing levels - starting at the lift up to seattle early on. I tried a "single core affinity" programme that put ion launcher.exe and a couple of others (all those I could find basically) onto the same core. It helped but I still got occasional reboots. Finally I read about booting up in single processor mode. In winXP this can be done with msconfig or editing boot.ini to have the switch /numproc=1 . It's easier in vista and win7 I think.

    Hope this helps. I only found out about it from searching for others' solutions.

  12. #37
    Originally Posted by bugmenot7
    I got the same problem as the first guy. Everything was black. The intro movies weren't playing. I could get a couple of the first menus by pressing the ESC key, but the game was crashing on the loading screen.

    Here is what I think I did wrong - I loaded the game, and I didn't realise it was already version 1.2, so I tried to load the 1.2 patch. This started to install, but then failed. I'm guessing it overwrote something perhaps. Also, I messed about with the game video settings before loading starting a new game.

    The fix Just uninstalled the game, and reinstalled the game leaving everything default. It now works. Hope this helps somebody

    The 1.2 patch is the issue. (I think)
    Yeap, it helped me !!! I did the same thing trying to patch etc... Now everything works fine! Thanks!

  13. #38
    The solution I've found for both games, running a dual/Quad core Processor system is to set the "Processor Afinity" to only one of the cores.
    The app is was not preapared to work with 2 or more cores. Even though many app that are not preapared to work on multicore systems, the OS does his job (Not in this case as u see)

    You have to be quick to set it once the process for the game starts, but before the game opens and crashes (or stay at 1 FPS) Then CONTROL+SHIFT+ESC ---> Go to Process and right clic over the process: "DX2Main.exe" and set the afinity to 1 core

  14. #39


    I have a quad core + the steam version of the game on 32 bit VISTA. I would get to the intro movie, get to the character selection screen, but then when I would click yes to start the game, I would get a dark screen that did nothing.

    So I hit CTRL+ALT+DEL to bring up the task manager. I started killing things that were unrelated to the game to free up memory. This eventually caused it to start working. Specifically, it would start working when I killed G35.exe (Which is the program my gaming keybaord installed to interface with local games). Makes me wonder if my particular issue is not in fact a bug with the G35 Logitech keyboard support driver. I dont actually have the G35 keyboard plugged into the computer anymore, but the driver is still installed. I could see that being an issue.

    Anyway, hope this helps someone else.

  15. #40
    Originally Posted by Firebird1
    I just bought this game off of Steam and I'm having a similar problem. I can get through the first level, but when loading Upper Seattle the load screen crashes back to the Desktop. There is no error message that pops up when this happens and there is no error in the Event Log for it either. Anything else then just rolling back drivers? Seeing that this is only happening on one game I really can't justify rolling back drivers that could affect other things on this computer.
    Another option: Try lowering all graphics and sound options to minimum before going through the transition to Upper Seattle.

    You might also check the Thief forums for this problem with Thief Deadly Shadows -- it uses the same engine, so the fix may be similar.

    Lastly, check to see if there's anything on the Steam forums for the problem. There may be something unique in their version.

    watch movies online

  16. #41
    Join Date
    Dec 2012

    Fix for games not running after patch 1.2

    I had the same problem as many here. I installed the game. Ran it. Saved it. Installed patch v1.2 and then couldn't run it. I then ran the install again using the MODIFY installation option w/ default options. You have to restart the whole game, but it is reading as v1.2 in game. :-)

    Hope this helps anyone that has come across this awful deus ex - invisible war patch 1.2 install problem.

Page 2 of 2 First First 12

Similar Threads

  1. What's the minimum spec?
    By quaver in forum Tomb Raider 1 - 6 - Technical Forum
    Replies: 7
    Last Post: 3rd Aug 2003, 13:48
  2. Oh thanx to all the brilliant brains in here
    By Slemma in forum Tomb Raider 1 - 6 - Gaming Help Center
    Replies: 2
    Last Post: 22nd Jul 2003, 20:35
  3. Gangsters 2
    By Metalpunk9dotcom in forum Members Lounge (formerly Eidos Community Chat)
    Replies: 0
    Last Post: 5th Jan 2003, 16:14
  4. Bloodrayne- The new, more gothic Tomb Raider?
    By HikingBoots in forum Members Lounge (formerly Eidos Community Chat)
    Replies: 27
    Last Post: 27th Oct 2002, 19:57