Page 1 of 2 12 LastLast
Results 1 to 25 of 31

Thread: Another SBLive sound problem...

  1. #1

    Another SBLive sound problem...

    I had the demo installed which runs PERFECTLY I get the full game and now I get a clicking sound. Sometimes on odd occasions I'll get graphics glitches too.

    Just lately TRL has been crashing. If I try to restart it I get a directx error "Failed to initialize Direct3D with current settings". After a reboot I can restart TRL and nothing is wrong with Dx9.0c on my comp

    Does the patch fix these issues?

    Athlon 64 3200+, Chaintech Apogee Geforce 6800, 2G Giel ram, SBLive! 5.1

    Thanks in advance
    Author of :-
    Thief Book Wizard v2.2
    Thief 2 Objects List (versions 1, 2 and 3)
    FM's : Bassett's Keep, The Ring, The Game, Karras' Diary, Secret Weapon and co Author Mixed Messages.

    I have the builders patience on my side!
    http://www.spankdonkey.com/jamming/view.php/99.png

  2. #2

    similar problems.

    I'm getting similar problems - read my thread.

    I think this has something to do with the creative sounds cards, especially Live! 24 bit.

    No, unfortunately the patch doesn't fix any of these issues.

    I'm also experiencing graphical glitches and I know for a fact that my X800XT isn't breaking/damaged: all drivers are up to date; I'm playing Oblivion, which is a far more taxing game in comparison, and I don't notice any graphical issues; my card isn't over clocked; and no other games display artifacts, etc.

    These simple annoyances should have been sorted out way before release. Either that, or the beta testers were a bit rubbish.

  3. #3
    I have issues with hardware setting in Battlefield 2 with my soundcard too

    I won't be buying another creative product.
    Author of :-
    Thief Book Wizard v2.2
    Thief 2 Objects List (versions 1, 2 and 3)
    FM's : Bassett's Keep, The Ring, The Game, Karras' Diary, Secret Weapon and co Author Mixed Messages.

    I have the builders patience on my side!
    http://www.spankdonkey.com/jamming/view.php/99.png

  4. #4
    The game runs fine on a Sound Blaster Live! Platinum here.
    Possible solution for your problem: Disable On-Board sound on your mainboard chipset. It can cause a lot of problems when a soundcard and the On-Board sound chip are activated.

  5. #5
    Onboard sound is deactivated in my bios. The main problem I have which gets on my nerves I start TRL, I see the eidos trade mark bumpf then I get a black screen but like when you alt & tab (i.e windowed & always on top). If I try to restart TRL I get the directx error and I can't play any other 3d game either unless I reboot

    TRL is buggy if it breaks directx when it crashes. BTW when I reboot dxdiag shows NO errors and all other games work fine until TRL crashes again. Looks like this game is going back on the shelf until eidos fix it. The demo works fine so whatever they did in the full version...
    Author of :-
    Thief Book Wizard v2.2
    Thief 2 Objects List (versions 1, 2 and 3)
    FM's : Bassett's Keep, The Ring, The Game, Karras' Diary, Secret Weapon and co Author Mixed Messages.

    I have the builders patience on my side!
    http://www.spankdonkey.com/jamming/view.php/99.png

  6. #6
    disable hardware acceleration for your sound card.

    Go to run, type in dxdiag, then to sound. Slide the slider to "no acceleration", close out and play the game!


    Yea I have the same card as you, this sucks.

  7. #7
    I tried that too. After a few minutes of perfect sound quality it starts to echo and distort.

    I reinstalled it again last night and everything seems ok now.... I'll see how it goes. Thanks for the input
    Author of :-
    Thief Book Wizard v2.2
    Thief 2 Objects List (versions 1, 2 and 3)
    FM's : Bassett's Keep, The Ring, The Game, Karras' Diary, Secret Weapon and co Author Mixed Messages.

    I have the builders patience on my side!
    http://www.spankdonkey.com/jamming/view.php/99.png

  8. #8
    Yea your right, I got passed the dirt bike mission then the studdering sounds came back. My only advice would be to complete a check point (if in the middle of it) and save. Dont try saving halfway through a checkpoint then quit. The game will only place you back at that checkpoint! Exit the game, reboot game, then reload your file.

    Havnt tried it yet, but it should help.

  9. #9
    I tried a bit of jiggerypokery if you will. This worked with a few Creative Cards ive tried, it may work for others. Aslong as it has EAX support.


    This involves changing settings in your registry, so if you dont feel too happy doing it then dont.


    But for others willing here we go


    1. Press START then goto run, in this type regedit and press ok

    2. Now in Regedit window, navigate to the following (click on the + to the left of each name)

    i) HKEY_CURRENT_USER
    ii) SOFTWARE
    iii) Crystal Dynamics
    iv) Tomb Raider : Legend (click on this)

    Now you will see these options

    EAXSupport - click on this and change the value from 0 to 1
    UseReverb - click on this and change the value from 1 to 0

    Make sure you set the audio settings back up to full again in dxdiag.


    (also if your having problems with the Shader3 still being laggy or jumpy, click the + on iv) option and you will see a graphics folder, at the bottom will be 2 entries Shader2 and Shader3, to enable one set it 1 and disable with 0)

  10. #10
    Thanks, gonna go try this. I had EAX on but I didnt know reverb had anything to do with it.


    EDIT: Just tried, didnt work

  11. #11
    disable hardware acceleration for your sound card

    Start-Settings-Control Panel- Sounds and Audio Devices-Speaker Settings Advanced- Performance- Hardware Acceleration-None

    I really hope there will be patch to fix this problem

  12. #12
    Same problem here (same sound card too, SB Live 24). Even with the acceleration disabled I still have to restart the game every 45 mins or so because the clicking sound comes back. Pain in the butt! And forget the new patch too, it doesn't change a thing.

  13. #13
    I really need to find out why this is doing it. Seems to be Bass control, it set way to high and causes the boom affect like stuttering.

    But I fixed with the registry, I guess its not a 100% fix, but it has to be something, perhaps the codec they use for sound play back it could be that thats not compatible with some creative cards.

  14. #14

    Smile

    Hi DABhand I have these same problems and the one of the guy's at technical support is giong to contact the developers about it. However I've tried all of the things to stop this buzzing sound and is ruining the game somewhat. Deactivating hardware acceleration doesn't stop it at all neither does the registery things with EAX and reverb. Like You said I think it's the bass that's doing it. Can you tell me what you did in the registery to cut it out please?

  15. #15
    Thanks for the suggestions; reducing acceleration, registry settings, disabling onboard sound. None work

    #1 Google hit for "tombraider legend sound": Creative support forums:

    Audigy LS has major issues with Tomb Raider Legend


    I agree it does sound very much like distorted bass, like taking 5.1 sound, mixing LFE channel into the stereo channels with the LFE boosted way too high. You can even tap out a beat to it. At least for me, the crackling is an extra layer of sound added over top of otherwise undistorted music, sound effects and speech.

  16. #16
    Ive tried other number of things, and had a sneaky peak at what they used and tried other codecs, but nothing.


    Even tried tweaking my drivers I have but nothing again.


    Game engine at fault basically, sorry to say.

  17. #17

    Rushed Game

    Turning Hardware Accel off works for a short time and then the sound gets really screwed up and you need to restart the game.
    Its a code problem.
    Lets face it just one more example of a company rushing a game out the door before its done to make a few bucks.
    Lets hope they at least release a patch that fixes the screwup.
    While their at it perhaps they can fix the fact that I can stand in the middle of rocks and walk thru some of the walls hehe.
    And viewing the japan girl model in the extras crashes the game.

  18. #18
    Join Date
    Apr 2006
    Posts
    17
    This is the exact same problem Project Snowblind had. From the same developer too, Crystal Dynamics. I don't think they even released a patch to fix this problem. So I highly doubt they will fix this problem, base on their past "actions" to fix this sound problem.

  19. #19
    Join Date
    Apr 2006
    Posts
    2
    I'm having the same problem with the sound. I think I have a seperate on board sound card aswell, could somebody please tell me how I could disable my soundblaster live and reactivate the on board sound?

  20. #20
    It means either the following..


    1. Right click My Computer > Properties > Hardware > Device Manager

    In here disable the SoundBlaster and if your other card is active also (should be listed under the sound and game controllers) you may just need to restart windows for it to be automatically used, or you may have to do the following also...

    Start > Control Panel > Sounds you will see under the 3rd tab that your sound etc will be set to Soundblaster Live card, change them to your other soundcard by using the drop down arrow and selecting.


    2. If you card isnt showing then it may have been disabled in the BIOS, which you can get into when starting your PC, it is usually Delete key to get in and look for integrated peripherials in the BIOS and set AC97 or Sound to enabled.

    Then disable soundblaster card in device manager etc.

  21. #21
    WTF!! i wait all this time for a game that finally has 16:9 compatible but CRACKLES OMFG FIX IT NOW!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  22. #22

    Lightbulb

    Ok, for a good laugh. Does anyone have a driver that is newer than 2004?

    I recently reinstalled my Windows and used the SB-Live driver disk to install the driver. Then I went online to update the driver but the little program told me I had the latest driver installed. Odd, because the soundcard is quite old. But when I check the driver date in DXDiag it says the driver is from 2001.

    However, when I reduce the sound acceleration to BASIC the noise problem is gone.

    Funny, in'it?
    The thing about Canadians is, they are very friendly people. But give them a hockey stick and they'll kill you.

  23. #23
    Join Date
    Jul 2002
    Posts
    656

    Cool

    In Creative-terminologi 2001 is up-to-date. Mine's also from 2001 - 9-10-2001.

  24. #24

    Big Grin

    I hear there are even people out there that still run Windows 98 on their computers.
    The thing about Canadians is, they are very friendly people. But give them a hockey stick and they'll kill you.

  25. #25

    disappointment.

    So, is anyone actually going to fix this or do I have to close/start up TR:L every 45 minutes?

    This is really dumb. I shan't be purchasing another crystal dynamics game... ever.

Page 1 of 2 12 LastLast

Similar Threads

  1. Where can i download BO1
    By CookieJR in forum Blood Omen Series - General Discussion
    Replies: 9
    Last Post: 8th Mar 2004, 09:26
  2. What Gives Man?
    By grb800 in forum Commandos 3: Destination Berlin
    Replies: 2
    Last Post: 28th Oct 2003, 01:05
  3. Mission 22 battle for alexanderia.help
    By atk1 in forum Praetorians - General Discussion
    Replies: 5
    Last Post: 5th Jun 2003, 17:25
  4. EIDOS Website Thief Portal is GONE
    By Zaccheus in forum Thief - The Crippled Burrick Inn (General Discussion)
    Replies: 7
    Last Post: 1st Nov 2002, 01:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •