Thread: Graphics problem!

Graphics problem!

  1. #1

    Unhappy Graphics problem!

    The main menu for Startopia is completely dark, with no text visible. You just barely get an outline of the menu display graphic.

    I've got the 1.01 patch, and all the latest drivers for my card - Plus, I've tried changing the shortcut for the game to startup with only my main Graphics driver with the /v0 trick. I've also downloaded the "other graphics card support" file, to no avail.
    Nothing seems to work, help!


    Thank you for your time!

  2. #2

    Question

    Which card? Specifically!

    Check for warning or error messages in the file "your gfxcard.txt" located in the Startopia directory. (Its more readable in Wordpad than Notepad) That may narrow down the problem.

  3. #3
    My apologies for not giving the specifics on my card!

    The card I've got is an : Nvidia 128MB GeForce 4 MX440 Vertigo, which I believe is basically a GeForce 2.
    I'll look into the error message in my Startopia directory. Thanks for the help!

  4. #4
    Here's a copy of what I've found on my "gfxcard" textfile that might be of interest:

    GfxTweak file version 13, <9/6/03:Old_ATI_cards_fail_TFACTOR>
    I know this vendor: <nVidia>
    I know this device: <GeForce4MX>
    Set tweak SRT_Z_BUFFER_USE_SAME_DEPTH to 1
    Set tweak SRT_Z_BUFFER_USE_SAME_SIZE to 1
    Set tweak SRT_Z_BUFFER_DONT_USE_BACKBUFFER_Z to 1
    Set tweak SRT_POLYGON_SUBRECT_CLEARS to 1
    Set tweak SRT_ENABLE to 1
    Set tweak IMPOSTOR_ENABLE to 1
    Set tweak RENDERSTATE_STATE_BLOCK_MACROS_ENABLE to 0
    Recognised this card and loaded optimal setup.

  5. #5
    My GF plays Startopia without incident on a 64MB GeForce MX 420. Drivers are at least six months old, so I'll upgrade Forceware to 78.01 to see if that's the culprit.

    P.S. As of Catalyst 5.9, ATI owners may want to check out how adaptive anti-aliasing looks in Startopia. It also blends alpha transparency, of which Startopia has a few, so should be pretty gnarly. Here's how

  6. #6
    And there's another thing that came to mind.. I'll look into my registry and see if I can completely wipe Startopia from my computer - And then try a re-install to see if that fixes the problem.

  7. #7
    A GF4MX should be pretty standard, and pretty much exactly the hardware StarTopia was designed on (GF2 and Radeon 7x00). As it says, it recognises that type of hardware, which means at some time in the past it's been tested on it, or something very close to it. I'm surprised it's having so much trouble. Things that could cause problems:

    -Control panel forcing anti-aliasing on (or other odd options). DON'T do this. Sometimes, in some games, you'll get away with this, but you're doing something the game isn't expecting, and there will be problems. StarTopia has a perfectly good AA option in the video card options panel - I advise using that instead.

    -Multi-monitor wierdness. All this happened after StarTopia shipped, so support for multiple monitors is pretty basic and hans't been tested much.

    -Really odd screen modes. StarTopia mostly copes with whatever you throw at it, but it can get confused if the resolutions are not 4:3 ratios. Mostly it just means the front-end menus are slightly odd (I have tested it with a 2048x768 res - wierd, but still playable), but I guess it could still get confused by this. Start with a pretty standard res of 800x600 - you can force this by adding /r800x600x32 on the command-line, which might at least get you to the video options screen.

    -Just plain broken drivers. It happens. Try updating, or maybe "downdating" - using some older drivers.

    StarTopia doesn't use the registry at all - you should just be able to delete the files and reinstall.

    ToMF.

  8. #8
    Originally Posted by Mucky Foot
    Try updating, or maybe "downdating" - using some older drivers.
    ToMF.
    When you say "Downdating", do you mean re-installing previous update drivers? Or is there an option for my card where I can restore the original drivers?

    Anyway, I've tried re-installing older drivers, but still no change.

    Here is a link to a screenshot of the menu I see.
    Startopia menu
    I'm also not using any graphics settings on my card for Startopia. Everything I would change, would be done so using the options within game.

    Thank you for your help Mucky Foot!

  9. #9
    I've looked at every solution to this problem I could think of...

    I'm probably stating the obvious here, but it looks like the writing is on the wall... I'm screwed.
    I'm fairly confident I've got all the latest drivers for my card - And in so doing it seems I've upgraded myself into a corner.

  10. #10
    Upgraded to Forceware 78.01 for GeForce4 MX420. Startopia continues to run fine. I tried auto, on, off, max, low settings for all Startopia graphics settings. I even forced AA/AF, vibrant color, etc driver settings, everything is still ok. I could not replicate your black menu.

    Startopia appears to save graphics setting in user profiles. It remembers if safe mode is enabled before you select a profile. Which is confusing. But lacking a command line option for safe mode, I uploaded a profile with safe mode on and everything else on default. Delete any other profiles in .\Program Files\Eidos Interactive\Mucky Foot\StarTopia\Profiles and unzip the file in there. Worth a shot.

    safe mode profile

  11. #11
    Thank you for your help Thorn.
    The latest driver I can get for my card is : 77.72, and the only available other is 71.84 - Both drivers have zero effect on the problem.

    I just downloaded your SafeMode file and loaded it from the game's menu. Still no effect I'm sorry to say.

    I have Gremlins!! Gremlins!! Aghhh!

  12. #12
    Do you DirectX 9.0c installed? If not, install it rather than trust that Forceware is 100% backwards compatible with earlier DX versions.

    Also make sure you are getting drivers direct from Nvidia. I see that the PNY Verto support page redirects to nvidia.com but had to ask.

    Lastly consider getting a newer card. eBay and discount merchants are flooded with Nvidia FX5200's, shop on the right day you can pick one up for $20 and shipping. Quite a bargain to get an entry level card for DX9 games.

  13. #13
    I've now downloaded the latest version of DirectX 9.0c... Still no effect on Startopia.
    It seems I'll either have to buy a new Gfix card or wait for another update to my drivers.

    And yes, you're right, I'm getting all my drivers direct from Nvidia

    Thank again for your help Thorn.

  14. #14
    Tom was the graphics man in Mucky Foot. And the Mucky Foot account, being a shared account for all MF members, does not point to his Email.

    Why not send him a message? If he can't help you I doubt anyone can...

    --
    Signing off,
    Overmind
    Yetucyun Development Team

  15. #15
    We've already talked here, and he's offered a few solutions... So I'm not going to bother them any further.

  16. #16
    Did you try a command line option to force your card into a lower mode?
    Try one of the following:

    Startopia /r640x480x16
    or
    Startopia /r640x480x32
    or
    Startopia /r800x600x16
    or
    Startopia /r800x600x32

  17. #17
    When I play Startopia, I'll always set the resolution to 800x600. When the game boots up, it looks like it's already in 800x600.
    I'll try 640x480.

  18. #18
    Sorry - I'm totally out of ideas. That screenshot just looks totally insane - it's not drawing half of the polygons, and the parts it is drawing are in the wrong place. I can't even begin to imagine what would cause that on a perfectly standard bit of hardware. Consider my mind well and truly boggled.

    ToMF.

  19. #19
    hmm that reminds me a bit of what far cry and deus ex 2 did to me. You can see the fix for far cry here, I'm not sure if its related though.

  20. #20
    Thanks for all the help guys.
    I think the only thing that will fix this is a reformat of my HD.
    I'm strongly thinking about it.. I just haven't had the courage to do it yet.

  21. #21
    There are a few things you might want to try first. Depending on what's causing the problem, these may or may not work.

    Few people know that the graphics codes for StarTopia work from the main menu. Try pressing F11 and typing in the following: BANGUNSNOTGAMES(Wireframe mode) XYZY (Transparency) or as a last resort CLIVEROOLZ (ZX Spectrum effect, *ALMOST* playable). Type once for low-res, twice for high-res for that one. There is also a black outline for StarTopia coded by Tom which needs F11 and TOMFDIGSMANGA. If nothing works you'll have to reformat. And when you do get it working why not download the Yetucyun Guild from StarTopia.Wideopen.Biz?

    --
    Signing off,
    Overmind
    Yetucyun Guild Development Team

  22. #22
    I've tried the "Wireframe" mode. The code enabled itself, but the graphics problem didn't change. Infact, the game just crashed itself afterwards.
    I used Alt-Tab while running the game however when it crashed.

    Anyway, thanks for the help Overmind.. As soon as I find a solution to the problem I'll check out your mod!

  23. #23
    I recall Tom's code for outlines worked by turning polygons of a certain type black. I wonder if your card has a bug of some sort which involves these?

    Wireframe is just one weapon from your arsenal. Translucency could work, and so could Tom's code. And as the ZX spectrum effect uses a different method to display graphics that could work, though I expect it's more of an overlay.

    There's also the chance you've got a buggy install, or worse, buggy source data from your disk. An easy diagnostic for that one is to download StarTopia from the Home of the Underdogs - if the Underdogs give you clean graphics you've got a problem with your disk.

    Why not go one better than downloading the mod, and join the Guild? We're looking for voice talent at the moment and you could be a guest trader or even a key, pivotal character in the plot. Well worth considering.

    --
    Signing off,
    Overmind
    Yetucyun Guild Development team.

    'In Yetuc we Trust'

  24. #24
    Originally Posted by Overmind
    There's also the chance you've got a buggy install, or worse, buggy source data from your disk. An easy diagnostic for that one is to download StarTopia from the Home of the Underdogs - if the Underdogs give you clean graphics you've got a problem with your disk.
    Hmm... Do you have the link I can go to in order to check this?

  25. #25
    Go to www.the-underdogs.net for these folks.

    Here's a tip for you. Use a search engine such a Google to navigate the web; that way you'll be able to browse by site titles rather that URLs.

    --
    Signing off,
    Overmind
    Yetucyun Development Team