Thread: Windows 98/ME fix to run TDS in W98

Windows 98/ME fix to run TDS in W98

  1. #1

    Windows 98/ME fix-Needs to be sticky

    There is a fix now:
    1 Download PE Explorer
    2 Backup "T3Main.exe" and "Default.ini" for patching puposes
    3 Apply any patches
    4 Open PE Explorer
    5 Go to File > Open File > "T3Main.exe"
    6 Go to View > Resources
    7 Select Icon Entry and delete it
    8 Save and exit
    9 Open "Default.ini"
    10 Find the line "LoadFromResourceBlockFiles=False" and change it to "True"*
    11 Save and exit
    12 Enjoy game

    * Only necessary if you get a white screen instead of a loading screen

    ALL credit goes to TBIRDMANN and the others at the following post. I just organized the info
    http://forums.eidosgames.com/showthr...threadid=41019

    This is the website for PE Explorer.
    http://www.heaventools.com/?r1=iNetShortcut&r2=pex195
    "Never argue with an idiot. He will just drag you down to his level and beat you with experience." ~Unknown

  2. #2
    Grey Mouser Guest
    As requested, making this thread a sticky.

    Note that this is of course an UNOFFICIAL fix for the problem of Thief: Deadly Shadows running under Windows 98/98SE and ME. It involves downloading/installing third-party software for which Eidos can take no responsibility if it hoses your system. So be warned.

    That said, this fix has worked for a number of people and if it helps you to play Thief under Win 98 or ME, so much the better.

    GM

  3. #3
    I thought no one could get past the opening movies, as it just crashed at the main menu?

  4. #4
    Join Date
    Jan 2004
    Posts
    30
    NO it does work and so far flawlessly.

    So glad I've been able to play without shelling out 80 quid for XP. The game looks great, plays great and runs very well and I'm very greatful to Tbirdmann for making this possible.

  5. #5
    Originally posted by Mr. Perfect
    I thought no one could get past the opening movies, as it just crashed at the main menu?
    That's what line 10 is for
    "Never argue with an idiot. He will just drag you down to his level and beat you with experience." ~Unknown

  6. #6
    EDIT: Didn't read the original post by TBIRDMANN properly. Sorry

  7. #7
    Join Date
    Jul 2004
    Posts
    2
    thanks tbirdmann/drake.I wonder-how many people have tried this and found it didn`t work?

  8. #8
    Mine crashes at the menu I think, AND when at the intro movies, it's all black, AND I tried changing from False to True, but it said access was denied. Anything I could do?

  9. #9
    Ok, I did everything you said to do with PE Explorer, and edited the Default.ini file. When I try to start the game it acts as if it's reading the disk and starting the file, but then nothing happens. All I get is the little hourglass thing, then nothing. Why isn't it reading my T3Main file?

  10. #10

    Rolleyes cant figure it out..

    ok did the t3main.exe icon delete with pe explorer then i changed the defualt file and tryied another step i thought would work. but didnt (changed true to false for the begining credits for eidos, nvidia, and ect. it got me to the loading screen a lot faster but still froze it up so i changed back to see if it would work, NOPE) both ways it gets to the loading screen after those begining credits then the pointer would disapear for about 1/4 of the loading bar and come back from 1/4 to fully loaded bar. (i was getting excited) nothing happen but a cool looking background. mouse works but nothing else, not even ctrl, alt, del. so what am i doing wrong. if i can get past the wpa for win xp if i read the readme files im pretty sure i can get this if i know what im leaving out


    system running tds:
    intel celeron 2.4
    via p4xb mainboard
    256MB ram
    radeon 9200se (actually apollo devil monster3 with ati radeon 9200 drivers)
    AND 98SE.....(EWWW ....partial to w2kpro but drivers for video card wont work from either ati or apollo and arent approved by microsoft or in other words not digitally signed)

  11. #11
    Don't worry about the drivers not being signed. that doesnt mean a whole lot. (look at WXP. M$ aproved, but still a piece of crap. ) Try turning the default.ini option about the memory blocks back. That has to do with the 9x kernel not being able to load the game. So try that, and other drivers. I use 4.10 on ME and they work great. (M$ stopped supporting after 4.3)
    If that doesn't work, post back with the results that you do get.
    "Never argue with an idiot. He will just drag you down to his level and beat you with experience." ~Unknown

  12. #12
    Originally posted by Drake51
    Don't worry about the drivers not being signed. that doesnt mean a whole lot. (look at WXP. M$ aproved, but still a piece of crap. ) Try turning the default.ini option about the memory blocks back. That has to do with the 9x kernel not being able to load the game. So try that, and other drivers. I use 4.10 on ME and they work great. (M$ stopped supporting after 4.3)
    If that doesn't work, post back with the results that you do get.
    i know that is true with some drivers but for my video drivers it is another story. because one of 2 things happen it either turned my video off right away (like another card is installed as primary display but not used) or it will reboot once and run ok until the next reboot then it will have no video again. but that is a topic for a different thread though.