Page 1 of 3 123 Last

Thread: Sticky on Bugs and Fixes updated often

Sticky on Bugs and Fixes updated often

  1. #1

    Sticky on Bugs and Fixes updated often

    Check the Bugs and Fixes sticky often. New tips added nearly every hour.

    Not in any specific order as yet, so scan the whole opening post for additions. Trying to keep all related material together but not always possible to do so.

    Keep the tips coming ladies and gents. And as we are thieves, theft from other places is not unwelcome, but tell us where so we can credit them.

    Tweaks and tips at TTLG:
    http://www.ttlg.com/forums/showthread.php?t=83310

  2. #2
    You could stick this as well....
    RedLegg

  3. #3
    If you have a fix, then PM me with it.

    If it is just a bug, post it in a thread asking for a fix. Or check the threads for the last 3 days or so to see if it is already posted, then add your comments.

  4. #4
    Join Date
    May 2004
    Posts
    25
    I dont wish to sign up to another forum tonight or soon, but here's something I found that you're free to add to your thread.

    In the default ini file
    PlayerHumping_MaxTime=1.25 ;Number of seconds the player must be in contact with an object before increasing the impulse

    Set playerhumping_maxtime equal to 0.35

    It makes knocking things over less of a burden, especially if you want to block a path or crush someone with a load of crates. The number is high enough that you wont knock over anything you so much as nudge though. Some people may wish it to be slightly higher

  5. #5
    bravus
    It's the first fix listed in the BUGS and FIXES after the INFO SO FAR.

    I also put it in the install section.

    But thanks for the eyeball.

  6. #6
    Join Date
    Feb 2000
    Posts
    2,704

    AI bug fix

    Salvage reported in another thread that a temporary fix is available for the AI bug, in which they revert to Normal difficulty after a save or when returning to a zone. Go here:

    http://forums.ionstorm.com/index.php?showtopic=211258

    Eidos is preparing a patch as well.

  7. #7
    In the main heading post already updated. Thanks Peter

  8. #8
    Join Date
    Jun 2004
    Posts
    26
    I found a sound crash bug in the Audale level it repeats then lets you play again. I have a SoundBlaster audigy 2 SZ with updated drivers. It occurs the most when I enable EAX and hardware acceleration. Nothing is wrong with any other games I play.

  9. #9
    I found an interesting bug in the Museum. It might appear other places as well, because it's related to movement and terrain. I'm going to spoiler the location because it might be considered a plot twist:
    I squeezed in between two pillars that were close together to hide from a patroling guard. I didn't know if I could even get in the crack because it was small. I did get in, but when I did Garrett started rising quickly into the air, ending up all the way at the top of the wall, hovered there for a sec while I was still pushing towards the wall, and fell back to the floor a few seconds later. Making him stay in the air wasn't reliable, he would randomly slip down a bit, but I was unable to go into that crack without it happening. I was facing away from the wall and pressing 'back' to go between the pillars when it happened. I didn't get a chance to play with it much because obviously whenever he fell down he lost most of his health, and I'd been playing way too late into the night anyway so I just gave up for the night.

    EDIT: This is without the new patch, but I was under the impression that the only thing changed in the patch was the difficulty bug.

  10. #10
    I found a sound bug in the museum.
    When you're inside that elevator on the top floor, you can't hear anything at all except ambient sound. Probably an EAX thing.

    EDIT: Happened again in the Hammer compound, at the top of the stairs near the Holy Water.

  11. #11
    Well since making a new thread for this subject didn't work I'll put it here, since this is more or less a bug.
    After the whole 'won't work in win 98se' fiasco...I have installed thief on a second computer that has windows 2000 on it....now after I install and try to run it it gives me a very lengthy error saying problems with trying to find a file on the library when it seems to be looking in the systems folder when I have Thief installed on a whole nother drive altogether. After that error about a minute later I get one that says something about it can't run because it's timed out waiting on t3main.exe?? I'm going to pull my hair out and choke myself with it

  12. #12
    I don't think that's a bug, that's a problem with your computer personally. Something, probably a driver, isn't installed right.

  13. #13
    Well.........I went through and updated everything I could think of and now when I go to start the game it goes to a pure white screen and needs to be ctrl alt dlted =\

  14. #14
    This thread is for consistent bugs in the game engine, like the oil potion in the Clocktower that cannot be picked up no matter what you do. Not for "this one time I started the game and something weird happened" or "my computer can't run the game" or "I can't figure out how to get something to happen." The rest of the forum's open game, but this is a special sticky post put here by the admins for reporting bugs so that they can patch things more easily. If it gets filled up with junk they might just ignore or delete the thread.

    Edited for content: This information is correct. Please, BUGS only, not one time problems. Thanks, theBlackman (mod)

  15. #15
    grafixmonkey
    got it.

  16. #16
    I'm having a weird glitch in my game. During the mission "Robbing The Cradle" when I go to the room of patient number 5 to remove the stones in the back of the wall to gain access to Lauryl's nightgown, none of the stones will highlight. Thus I cannot continue with my mission. Also, I cannot pickup any of the items in the patient's rooms. They gleam like any other loot and I've read in walkthroughs that I'll need to pick up one of these toys and take it to its special location. I'm not sure if that's the same problem I'm having with the stones in the wall or if you just can't pick those objects up until you get farther along in the mission. Anyway if anyone else has had this problem and has figured out how to fix it, please let me know! Thanks!
    ~Courtney~

  17. #17
    I just recently bought thief 3, and came across a strange bug--at least I am assuming it is a bug. A few times during game play I would be sneaking, and when I let go of the sneak button I am still in "sneak mode" and cannot run. Usually a quick save and load will correct this, but this time midway through the Cradle I am stuck in sneak mode and no matter what I do I cannot get out of it. I can no longer run which means if I am seen I am dog meat. Not a clue on what to do.

  18. #18
    have you guys had this problem before?



    well my mission stats say that i had one body discovered... what doesn't make sense is that my total for the game says i have 2 bodies discovered.. how could this be, since i've not even knocked out a single person up to that point besides the forced inkeeper knockout in the training mission...?

  19. #19
    what doesn't make sense is that my total for the game says i have 2 bodies discovered..
    One body discovered twice, maybe?

  20. #20
    actually i figured out the problem, read this thread

    sorry about not researching more before putting this message in the thread

  21. #21

    movement problem

    I just purchased this game this afternoon, and loaded it. It's weird but Garret moves on his own..... I have to use the backup key (s) to keep him from going forward into a guard or other danger. And crouch all the time to slow him down!
    My Machine:
    P-4 3.0ghz
    1gb PC4000 ddr ram
    Asus P4C800-E mainboard
    2x 120gb Seagate hard drives
    Asylum 5600 FX 256mb ram video
    Microsoft Natural keyboard Elite
    Microsoft Intellimouse optical PS2 compatible
    XP Professional with latest service pks.
    Onboard AC97 sound.... "not using EAX at all"
    ALL LATEST DRIVERS, Nvidia, Sound AC97, Mainboard, SATA/IDE
    etc. etc.

    Everything works great with all other games.....
    Tom Clancy's RavenShield 3... Ghost Recon... Athena Sword
    Also have played FarCry, Return to Castle Wolfenstein and Line Of Sight Viet Nam without Any problems whatsoever.

    Everything seems to work OK with Thief Deadly Shadows.... Except Garret seems to want to move on his own!
    HELP .... haven't seen this before!

  22. #22
    unplug your joystick

  23. #23
    every time i try to enter auldale i crash - i've disabled eax
    i'm able to go to every otehr area so far with no problems.

  24. #24
    Originally posted by JavaGod
    every time i try to enter auldale i crash - i've disabled eax
    i'm able to go to every otehr area so far with no problems.
    i grabbed this post from wakane over in another thread... seems to work for everyone who's had this issue

    jm



    I had this same exact crash. But for some reason, I passed it. Kinda lucky, though. I didn't wanna try it again.

    Anyway here's what I did. I don't think this works on anybody, but at least you can try.

    In front of the the portal to auldele from old quarter, I switched to 3rd person view. I jump to the upper wall of the portal and climb (you can only climb a step or two). The game will register as you're entering the portal instead.

    Then you go to the loading screen, you wait...

    Now for my system, just before it crashes, there's a split second window that the game works when the screen starts fading in to clear from total black. I immediatly go the the menu and save the game.

    After that I quit the game and reload that save game that I just made inside the entrance of auldele. It worked for me.

    Anyway that's it guys. Not exactly a real solution, but for some reason it worked for me. Hopefully it works with you guys, too 'cuz I know the frustation of ctd.

  25. #25

    Game Problems

    It seems that many people are having problems with this game. I did get the (Garret moves on his own fixed, thanks to Wolfsbane),
    But, the performance Is Not what it should be. I have a feeling that there will be several serious patches forthcoming for this game. I think it is a good game, but it still needs much work. I wish Thief Gold would play on Win 2000/XP. I really did enjoy that game. Oh, Well maybe they will get this one fixed. I am certain it isn't hardware.
    Pentium 4 3.0ghz Northwood
    1gb PC4000 HighSpeed ddr ram
    Asylum 5600 FX 256mb video card
    Dual SATA Seagate 120gb Harddrives
    Asus PC4800-E Deluxe Mainboard
    Microsoft Elite Keyboard
    Microsoft Intellimouse Optical USB
    Win XP Professional
    ALL latest Drivers have been loaded, Intel, Promise, Nvidia, Onboard SoundMax sound, Asus, etc. etc.

    Funny, but FarCry, Ravenshield Six 3, Ghost Recon, Athena Sword,
    Return to Castle Wolfenstein, Line of Sight Viet Nam, All Run without Any Problems Whatsoever. This is the Only Software that I've had Any problem with performance.... or anything else. I'm sure Eidos will get it fixed, it's in their best interest.

Page 1 of 3 123 Last