Page 2 of 3 First First 123 Last

Thread: Sticky on Bugs and Fixes updated often

Sticky on Bugs and Fixes updated often

  1. #26

    Crash bug

    Ok i don't know if anyone else is having this problem but my game crashes right before the end. Im just about to put the last item on the fountain in south quarter and as i enter the square in front of garrets house the game crashes. ive tried differnt video settings but nothing seems to work. it always crashes at the same place.

  2. #27

    Re: Game Problems

    Originally posted by Otto Kill
    ...I wish Thief Gold would play on Win 2000/XP. I really did enjoy that game. Oh, Well maybe they will get this one fixed. I am certain it isn't hardware.
    I play GOLD on XP all the time. Many play it on 2000, and many XP users use the 2000 Compatibility mode.

    Did you disable HYPERTHREADING? :

  3. #28
    Join Date
    Jul 2004
    I've got some real irritating sound problems. During gameplay, some sounds just dissapear, I mean when I pick loot, throw a body on the ground, open the doors I can't hear characteristic sounds. And especially when I know somebody just said something (subtitles: on) and I don't hear him I get really pissed off. I supose this problem doesn't depend on sound card, because after purchasing SB Augidy the problem is still the same as when I was previously playing with simple music card installed on motherboard. And I've noticed that theese sounds dissapear in some location especially: I don't hear Garret's speech during debriefing after S. Cradle mission. I append that this bug sometimes may be solved after restarting computer, but it doesn't work all the times and is really annoying.
    My machine: Athlon 1.9 Ghz, Abit Nf7 motherboard, 512 Mb RAM DDR 400, 120 Gb Seagate, Omega Radeon 9500 Pro 64Mb, SounBlaster Audigy, Creative 6.1 speakers.
    In Sb options I've got EAX 4.0 version and CMSS on.
    Thank's for any advice.

  4. #29
    Join Date
    Jul 2004
    It's me again. I've just solved this sound problem. I had to update EAX drivers and simply reinstal game. So it wasn't a bug associated with TS but only with my software.

  5. #30
    I think, I have figured out a small problem about getting in game on Win98 SE. After deleting the icon entries of T3main.exe, willing to play the game after an hour of Forum reading, I ran T: DS and after the videos the game crashed to desktop without any error message. While I was wondering through the graphics card properties section, I decided to set the Anti Aliasing and filtering modes in Manual mode(Not application controlled), and the game runs fine on my computer.

    Windows 98SE
    P4 1.8 512k
    ASUS P4-TE Motherboard
    256 MB RD-RAM
    256 MB ASUS V9570 TD Ge Force FX 5700
    Sound Blaster Live 5.1

  6. #31

    Thief Gold on XP Pro

    I used the setup -lgntforce switch to install Thief Gold. I tried to play and it crashed to desktop after a short black screen & No Error Message. I updated my Nvidia FX 5600 drivers. I turned off Hyperthreading and it still crashed to desktop after the black screen.
    So... I turned off the Onboard Soundmax Sound and installed a Creative Soundblaster Audigy card thinking it might be sound issues, and it still crashes.
    I un-installed then re-installed Thief Gold & it still won't work.
    I then read somewhere to go back & use Old Nvidia drivers.... like (52.00--55.00), so I hunted an Old set of drivers down and installed them and it still won't work.
    It looks like I'll either have to set up a dual boot system or give up on Thief Gold. It would be Nice & Wise of Eidos to make their games compatible with all Windows OS's like Valve/Gearbox did with the great HalfLife series,.... I went out and bought their Platinum series as did thousands of others. (I'm sure it was more than just profitable)
    I have been told that Riven/Myst is also doing this, although I don't plan to buy that one.
    I'm positive their would be tons of Ole Taffers that would break down doors to get at a Thief trillogy that was compatible with all Windows 98/ME/2000/XP and direct-X 8 & 9.
    Until then, guess I'll give up on Thief Gold & II Metal Age

  7. #32
    I believe I've found a bug in Still Life with Blackjack, and I'm hoping someone can confirm:

    In the mission, turn off the power in the museum, save you game, then exit the game. Now come back and wait for the electricity to start up again. The electric nosies thast play when the power comes back on will start, but the electricity doesn't turn on. Even stranger, when you go under where a light source would be, your character and objects/enemy characters are illuminatedf as if the light WERE there... but your light gem doesn't show any difference and the enemy AI doesn't notice either.

  8. #33
    After the part where you are chased around by the Enforcers or whatever they're called (the telekenetic guys), and I talk to the few Keepers in the Graveyard, then I am supposed to go back to the Keeper Library. When I do the game doesn't check off the objective complete and doesn't give me any new objectives, so here I go all the way through the Keeper compound through the Forbidden Library and it won't let me get any farther.

    I think this may have to do with the fact that I had already been though this Forbidden Library back when I first came to the Keeper Compound when they wanted my help. I went into the hidden room and everything, has this now screwed me later in the game now, when perhaps I am supposed to just discover the secret room now?

    Or is this a bug of not updating my ojectives when I enter the keeper compound to search for evidence of the true Betrayer?

    Another bug I found was on the Clock Tower mission, where if I took the stuff from the room with the beds and chests in it, and tried to save it would crash the game.

    Other than that the game runs great on my system and everything.

    EDIT: Ok, I might not have run into a bug after all:
    Sorry guys!

  9. #34
    You are in luck, that's not a bug . Highlight the text below for information on what to do:

    Not sure about the crash bugs, it's nothing I've come across myself. Good to get that info out in case other people have troubles.

  10. #35
    Join Date
    Oct 2004
    I'm having a problem getting into Stonemarket Plaza. Everytime at the load screen, the game crashes after it's 3/4 loaded. No error message. Nothing. Just goes straight to the desktop. I've tried getting to Stonemarket Plaza from Stonemarket Proper and from South Quarter, but the same thing happens. What's the deal?

  11. #36
    Join Date
    Aug 2005

    Bug involving Mission Loading after Secret Tunnel

    Originally Posted by Clumsyorchid
    You are in luck, that's not a bug . Highlight the text below for information on what to do:

    Not sure about the crash bugs, it's nothing I've come across myself. Good to get that info out in case other people have troubles.
    Okay, this may or may not be a bug. But it seems that way to me and it's related to the mission loading directly after the secret tunnel you are talking about above.

    I have been playing this game for almost a week now, and have not had a single problem that hindered the progression of the game. There were times when I could not jump, or run, and i would just save, exit and restart the game and the minor annoyances would be gone. But I had just gotten into this game, I mean really into it, and just as I think things are going to get really good, a quarter of the way through the loading of the mission following your discovery of the Secret Tunnel in Orlands office, my game crashes to the desktop, with Windows saying how sorry they were.

    Does anyone know how to fix this? Here is what I have tried. I downloaded older versions of my Nvidia drivers which WERE the most current until someone said that they fixed crashes by rolling back driver versions. That solved nothing. I went back three save games and that did not work. I uninstalled the game and re-installed it, and that did not work. I turned off Bloom and decreased my resolution and that did not work. This has been the first occurence I have had of this sort, and it is frustrating, as I paid for a game that I am not very likely to finish now.

    Any help would be appreciated....

  12. #37
    Another 'Is this a bug?' thing - I was in the Clock Tower last night, working my way to the bottom. I found one of the "lift the grate and crawl thru the tunnel" shortcuts, which I used. In the room on the other end of tunnel, I could see a guard thru the grate but could not hear his footsteps, until I opened the grate. I tried this a few times to be sure - grate closed, no footsteps; grate opened, footsteps. I thought this was the game treating the grate as a door (as in, can't hear thru doors), until I remembered that I can hear noises (footsteps, voices, etc) thru other closed doors.

    I can't specifically remember if this has happened with other grates, but I don't think so.

  13. #38
    Sounds like a "bug". I don't remember that problem, but as I can see through grates, I just time the patrol. When I know that he passes and then takes 15 to 20 seconds to come back, I sneak out between passes.

    BTW. Any object you bring up in inventory (use loot or keys) stays on screen 30 seconds. So you can cycle them and use them for timers.

  14. #39
    Originally Posted by grafixmonkey
    This thread is for consistent bugs in the game engine, like the oil potion in the Clocktower that cannot be picked up no matter what you do.
    I just finished this mission. If you're talking about the potion in the trunk, I managed to get hold of it. I jumped into the trunk and when I tried to grab the potion, I accidently closed the trunk instead. The lid went right through me and all of a sudden there came a constant rattling sound in the trunk and, in third person view, I saw myself kinda bouncing around then all of a sudden the potion popped out through the wall of the trunk! The commotion stopped, I opened the trunk, jumped out, and grabbed the potion! I can't imagine that's the way they intended you to get the thing though!

  15. #40
    Join Date
    Feb 2006
    hello, I was having trouble with Garrett moving by himself and I didn't have a joystick or anything plugged in. It turns out the problem was coming from my Saitek keyboard. I found the solution on their web site and wanted to share it here:

    There are a couple of known games that have issues with the presence of the Gamers' Keyboard; known titles that have problems are the moment are Planetside, Star Wars: Battlefront and Thief: Deadly Shadows. Other titles may exist that have problems but they have not been reported yet.

    There is a possible solution though - Click Start>Control Panel and open the System in there (you may have to click Performance and Maintenance before you can see the System icon if you're running Control Panel in Category View) and then click Hardware at the top of the window that comes up and then click Device Manager. Click the plus sign next to Human Interface Devices in the list of devices and you should see one or two (maybe more) entries called USB Human Interface Device. You need to disable one of them by right-clicking it and choosing Disable from the drop-down list of options.
    Note: If you have only two such entries there in Device Manager then only one will be able to be disabled - the other will have the disable option greyed out in the drop-down list when you right click it. If however you have more than two such entries in Device Manager then you will need to ewnsure that you disable the correct one. This is done by double clicking on each one in turn and looking at what it says next to Location on the Properties page. The one that should be disabled will say USB Gaming Keyboard Pro next to Location. Once you have disabled that then try the game again and it should work fine.

  16. #41
    Join Date
    Mar 2006
    Originally Posted by wolfsbane
    unplug your joystick
    I have the same walking garret (plus he always looks straight up) problem and I don't have a joystik plugged in...

  17. #42
    jtbalogh Guest
    If not a joystick, then you might have a USB keyboard or mouse, or wireless setup.

  18. #43
    Join Date
    Mar 2006
    Ok I got it thanx... I just had to disable it in the device manager thanx felluz!

  19. #44

  20. #45


    Damn...i just bought deadly shadows...and i have problems...i installed the game...i entered the game (i see the ads and the sound of them) when the menu apears: no sound. I start to sound again... I reach the guard which i have to distract with my bow...i shoot an front of his face...but he doesent move...
    and no sound in the game!

    i have a AMD Sempron 1700+, 256DDR, ATI Radeon 9600 (128 Mb), Nvidia Sound Card, and DirectX 9.0c installed (oh...and XP Pro SP2)

    the 1.1 patch didn`t solve my problem... (problem which some of my friends had to)
    If the answer is Microsoft...then you ask the wrong question!
    Any electrical object works better if you plug it in the power outlet.

  21. #46
    Join Date
    Apr 2007
    Originally Posted by kuddo
    Damn...i just bought deadly shadows...and i have problems...i installed the game...i entered the game (i see the ads and the sound of them) when the menu apears: no sound. I start to sound again... I reach the guard which i have to distract with my bow...i shoot an front of his face...but he doesent move...
    and no sound in the game!

    i have a AMD Sempron 1700+, 256DDR, ATI Radeon 9600 (128 Mb), Nvidia Sound Card, and DirectX 9.0c installed (oh...and XP Pro SP2)

    the 1.1 patch didn`t solve my problem... (problem which some of my friends had to)
    Hey, I had the exact same problem in Deus Ex II: Invisible War/ That game is based exactly on the same Unreal engine, and is even developed by the same company (Ion Storm), same publisher too... (Eidos).

    Anyway, the thing that helped me, was to run things like registry cleaners (TuneUp Utilities 2007 did magic), remove antispyware software (damn heavy Spyware Doctor) and update my audio drivers.

  22. #47

    Crash on Gamall's cutscene

    the game crashes in the middle of this cutscene. i have restarted the game, tried to get to this from previous save points, have tried running at lower video settings, and i have tried restarting my computer, and the game still crashes during the cutscene

  23. #48

    DEP Problem

    I just installed Thief: DS on my System. Specs are as follows:

    Intel Pentium D 2.80ghz CPU Dual Core
    1Gb RAM
    ATI Radeon XPress 1200 Series 128mb Graphics Card
    Windows Vista Home Premium

    After I installed the game and tried to run it, windows closed it and brought up a "Data Execution Prevention" Explanation. Apparently, DEP keeps programs from running harmful code on your system. Thief obviously doesn't do this. When I try to add TDS to my list of accepted programs to not use DEP the system won't let me, saying it's required.

    Is there any workaround to this? Any help would be appreciated.

    Oh, and the game DOES run in vista as far as I know and according to the guide.

  24. #49

    Can't even start

    I just got this game off steam. i boot it up and i hit space to skip all the ads and such and then the starting FMV begins, i watch it and i wait thinking that the menu will pop up but nope the FMV starts again so i figure well I'll just hit ESC and it will bring up the menu, so what do you know it doesn't. It flashs the menu and some quote and the FMV starts again, so i hold the ESC key down and i don't get crap just a flashing screen with a menu that when i click something crashes the game and freezes up my computer.

    Please help

    p.s. i know for a fact that my computer meet the requirements and then some so i don't know whats going on atm.

  25. #50
    There have been a number of complaints about "Steam" and other DL copies of the game.

    Regardless of what "you" think. List your system specs.

    Operating system,
    Video (on board or card)
    Are you using a USB mouse, keyboard, joystick, gamepad?

    Laptop or desktop.

    What you think cuts no ice. The specs are needed for accurate or potential solutions.

    And the best place to ask is in the Tech boards.

    This thread is for FIXES FOUND. If you have a fix, or have found one elsewhere.

    If it is just a bug, or a problem, post it in a thread in the Deadly Shadows forums.

    State the specific problem, system specs and ask for a fix in a thread or in response within an existing thread. Or check the threads for the last 3 days or so to see if it is already posted, then add your comments.

Page 2 of 3 First First 123 Last