Thread: Finally got the game to go super SMOOTH as glass

Finally got the game to go super SMOOTH as glass

  1. #1
    hirad Guest

    Finally got the game to go super SMOOTH as glass

    well finally i manage to get the game working and go super smooth in 1024 X 786 with 4x multisampling. the trick is to put the dx2.exe in windows 2000 compability mode this has only been tested for windows Xp user though. He he he hope its working for all u frustrated fans of deus ex 2

  2. #2
    hirad Guest
    hmm i forgot my comp spec is:

    amd xp 2600+
    768 mb ram
    geforce fx 5600 with 128 mb mem
    sb audigy player
    directx 9.0 installed

  3. #3
    how do i do this?

  4. #4
    hirad Guest
    ABRAXAAS :

    well to put the dx2.exe in win 2000 compatibily mode just right click on the file and u should see the option there if u look closely

  5. #5
    yeah i already found it lol

  6. #6
    hirad Guest
    hehe good try it out u will be surprise

  7. #7
    Well, it did little to nothing for my FPS, still averaging about 15-20.

    However, it no longer drops to desktop, then pops up the game again every time I load a level. That's kinda nice.

  8. #8
    Dunkerque Guest
    OMG

    I cannot thank you enough for this one. DRAMATIC increase ! I can play at 800x600 with all to medium and 2x FSAA on my crappy machine without the back to desktop bug each time a level loads.

    Thank you a lot for this one, really appreciate !

    My specs suck but DX was too good for me to miss it :

    1.333 Ghz Athlon
    512 Ram
    GeForce 3 Ti 200 64 Mb

    Now I can play it fine without too much lag and with "decent" graphics. Real pleasure !

  9. #9
    This definetely fixed the loading glitch, but I can't seem to tell a difference performance-wise. I followed all of the recommended default.ini tweaks and it runs nice and smooth for me at 800x600.

  10. #10
    deffinatley runs way smoother now I LOVE THIS GAME ITS SO MUCH FUN!

  11. #11
    hirad Guest
    hmm well the game was lagging very much for when i played it at first, then i mean very laggy. my average fps r around 60 after the trick and i tried playing in 1280X1024 and the game still goes quite smoothly. Donno why u guys performence hasnt improve but the loading glicht is fixed yeah never though of metion it but still the games performance increased quite much for me

  12. #12
    Johannes Guest

    Smile Thanks mate!

    Yeah! This definetly helped! No more crashes and got quite a perormance boost as well. Still getting low fps now and again but this did indeed help alot!

    Cheers for this one!

  13. #13
    Trulok Guest
    what if Im running windows 2000? I don't see it.

    3.0ghz P4 overclocked to a 3400+
    1gig DDR ram
    geforce 4 ti4600

    I can run the game fine at 640-480 full graphics but no higher ><

  14. #14
    hirad Guest
    Trulok

    Like i said in my first post this has only been tested on win Xp users so i have no clue how it works for other OS. And if u got win 2000 then another sulution must be out there

  15. #15
    DivineRight Guest

    Thumbs Up

    Thanks man, this really helped with CTD everytime I would load the game or load a level.

    CHEERS

  16. #16
    Burnz Guest
    Didn't seem to do anything for performance to me (I'm using XP pro).

    It DID fix the problem with the game minimizing itself everytime I loaded a game, which is nice.

    Wierd.

  17. #17
    No joy here.
    There should be a "X-Box" or "Console" compatability mode available for us suckers who bought the game.


    AMD 2400
    Windows XP SP1
    384mb ram
    GeForce 4 Ti4800 SE 128mb

    With ALL updated drivers.

  18. #18
    Originally posted by BoomStick
    No joy here.
    There should be a "X-Box" or "Console" compatability mode available for us suckers who bought the game.


    AMD 2400
    Windows XP SP1
    384mb ram
    GeForce 4 Ti4800 SE 128mb

    With ALL updated drivers.
    u said it m8!
    Specs;
    AMD XP 2800+
    512 mb ram
    Geforce 5600 fx

    And still DX2 runs like a 3 legged donkey!

  19. #19

    Re: Finally got the game to go super SMOOTH as glass

    Originally posted by hirad
    well finally i manage to get the game working and go super smooth in 1024 X 786 with 4x multisampling. the trick is to put the dx2.exe in windows 2000 compability mode this has only been tested for windows Xp user though. He he he hope its working for all u frustrated fans of deus ex 2
    omf i have identical pc specs yto you and same gfx card?
    but i cant play at that res..

    can u post all teh settings for ur gfx card (i have the same one)
    and the driver version please m8!
    Specs;
    AMD XP 2800+
    512 mb ram
    Geforce 5600 fx

    And still DX2 runs like a 3 legged donkey!

  20. #20
    Wow! weird... thanks

  21. #21
    Join Date
    Dec 2003
    Posts
    17
    nope no difference here:

    1280*960
    full effects
    average 24 - 15 fps depending on what's on sceen

    no different under XP or Win2000

    i've never had the dropping to desktop problem

    my system:
    2100XP
    768 MB
    RADION 9700
    Sound Blaster Live!
    DirectX 9.0b