Results 1 to 6 of 6

Thread: TRLR and TRC won't run if you have TRAOD!!!!!!

  1. #1

    Rolleyes TRLR and TRC won't run if you have TRAOD!!!!!!

    After loading TR-AOD, I could not run either TRLR or TRC.

    Having had several exchanges of email with EIDOS technical support, they sent me the answer - if you install DirectX 9, you can't run TRLR or TRC... I quote:

    "The simple fact is that TRLR and Chronicles were made before Directx 9 came out and so we could never guarantee that they would work with it as it didn't exist at the time."

    TRAOD comes with DirectX9 on the disk, which it installs, rendering the previous two (and better!) games unplayable.

    According to Microsoft, DirectX is backward compatible, so what gives?

    Any technical boffins out there with an answer to this? I can't find a way of "uninstalling" DirectX9, so I have no way of going back.

    Surely EIDOS should be providing a DirectX9 patch for TRLR and TRC???

    I really think this is unacceptable...

    ...unless I'm missing something obvious?

  2. #2
    Join Date
    Sep 2002
    Posts
    1,066
    I didn't have any problems with chronicles. There is a way to remove it but I wouldn't do that if I were you. If you're running XP try installing the patch at www.tombraiderchronicles.com

    Tipsko

  3. #3
    I finished AOD , and started TRLR right after. I also have DirectX 9. No problem's here either. Assuming you have the latest drivers for everything.I would start looking to see how you're Video card if configured.Find any and all patches. And if you are running XP,either put the game into compatibility mode or download the XP patch for either game.Keeping in mind if you run the XP TR4.exe , you need to take the game out of compatibility mode.Good Luck

  4. #4
    ...unless I'm missing something obvious?
    Short answer: yeah you are.

    Obviously Eidos couldn't guarantee DX9 compatibility before it even came about. Now they're copping the flak for DX9 shortcommings.

    According to Microsoft, DirectX is backward compatible, so what gives?
    /me stares.
    You really need an answer to that?...
    ... ok, well I believe the keyword in that question is Microsoft. What gives, you ask? Microsoft.

    TRAOD comes with DirectX9 on the disk, which it installs, rendering the previous two (and better!) games unplayable.
    hmmmm well, since AOD (and most new games now) rely on DX9, it is indeed going to install it if it doesn't detect it already being there.

    There shouldn't be a problem with older games (pre-DX9 etc) games running under DX9. Try the handy suggestions left by zappmon. If that fails and you have no further use for DX9 (be incredibly careful to research this and make sure you have absolutely nothing else that relies on DX9) then by all means uninstall it.

    I can't find a way of "uninstalling" DirectX9, so I have no way of going back.
    DX can be uninstalled, but it's not recommended you do that. You'll need to reinstall an earlier version of DX (probably DX8 or so). If you have absolutely no use for DX9 apart from AOD (and rememebr, DX is not just graphics!!) then there's a nifty little tool you might consider using called DirectX Eradicator. DirectX Eradicator allows you to uninstall a stuffed-up install of DX.

    Good luck. Hope you get it sorted out.

    Linkage: http://www.freewebs.com/firecat/

  5. #5
    Join Date
    Aug 2002
    Posts
    1,017
    I've played through TRAOD twice, the last time with the V49 patch with no crashes or other problems.

    I just now loaded The Last Revelation and Chronicles, and they both load and play with no trouble.

    My system is Win XP, Pentium 4 2.0 GHz, 512 MB RAM, Nvidia GeForce2 MX400, and SB Live!

    I recently used Bokkie's tr1advinst installer program to load the original Tomb Raider with Glidos and VDMSound on this Win XP computer. The graphics are glorious. I was never before able to get Tomb Raider I to work with Win XP on this computer.

  6. #6
    Same here. I've got TRAOD, TRC, and TRLR all running in DX9, and TR1 in GLIDOS works great. I think I lucked out - My old Radeon in combination with DX9 and the new ATI driver suite is just golden - even GTA3 and TRAOD run great. TR2 & 3 run great with DX9 too. Whatever your problem is, it aint DX9.
    ALL COMMENTS BASED ON PC VERSIONS ONLY.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •