Page 1 of 64 123451151 ... Last

Thread: FFXIV: Account/Square Enix ID Questions and Issues

FFXIV: Account/Square Enix ID Questions and Issues

  1. #1

    FFXIV: Account/Square Enix ID Questions and Issues

    Discuss and help each other out with account-related matters and issues here in this thread.
    But, first and foremost: make sure to contact customer support.
    NA
    EU
    JP

    ---------------------

    MAde this new account to play FF14 wont it won't let me log into the website
    Last edited by Grimoire; 22nd Mar 2014 at 06:07.

  2. #2
    Join Date
    Aug 2013
    Posts
    208

    The FF14 forums are their own thing. You'll have to make an account on finalfantasyxiv.com

  3. #3

    I tried, but it just takes you to makes a Square-enix account again.

  4. #4
    Join Date
    Aug 2013
    Posts
    208

    I'll check it out for you.

  5. #5
    Join Date
    Aug 2013
    Posts
    208

    Okay, log in here with your SE account, or make one if you don't have one: secure.square-enix.com/account/app/svc/l...





    Then you'll be asked to create a forum name, enter your timezone, etc. Once you do that you can complete registration and begin posting.

  6. #6

    Man I feel dumb now lol.


    Don't know why I couldn't figure that out.


    Thanks!

  7. #7
    Join Date
    Aug 2013
    Posts
    208

    No problem I know it can be confusing sometimes.

  8. #8

    I'm having the same problem but it always tells me that my password is wrong even when I'm certain it's right, I can log in to SE's page here just fine but it always tells me it's wrong when I try to log in there. I've been having this problem for almost a whole day now and starting to feel really ripped off.

  9. #9
    Join Date
    Aug 2013
    Posts
    208

    Originally Posted by David A


    I'm having the same problem but it always tells me that my password is wrong even when I'm certain it's right, I can log in to SE's page here just fine but it always tells me it's wrong when I try to log in there. I've been having this problem for almost a whole day now and starting to feel really ripped off.



    Have you tried password recovery on the Account log-in before? I had to do it once and reset my password just in case.

  10. #10

    did you make a SE account from the FF14 page?

  11. #11

    I've reset my password three times...waiting 30 min -1 hr between tries, and every single time it didn't work, so I made a new account, which is this one...so now I can get on SE, but I can't get on FFXIV's Lodestone page or the game...


    I'll try making another new account from the FFXIV page but I'm about at my wit's end.

  12. #12

    Ha! Now I can't even do that! I try to go their North American page and it pops up this error:


    Kohana_Exception [ 0 ]: Directory APPPATH/cache must be writable


    This is really really starting to bug me.

  13. #13
    Join Date
    Aug 2013
    Posts
    208

  14. #14

    Ok...well I reset my computer, and managed to get past that error. Now it's telling me my registration code is wrong. *whacks head on the wall*

  15. #15
    Join Date
    Aug 2013
    Posts
    208

    Originally Posted by David A


    Ok...well I reset my computer, and managed to get past that error. Now it's telling me my registration code is wrong. *whacks head on the wall*



    Did you try the link I posted above?

  16. #16

    I accessed the page through the FFXIV game launcher...but I'll try that one too. *rubs temples*


    Okay the registration through there is the one I'm stuck in the middle of now.

  17. #17

    Okay, apparently that is also case-sensitive. Wow... Anyway...moving along.

  18. #18
    Join Date
    Aug 2013
    Posts
    208

    Going directly through that link seems to be the best I think.

  19. #19

    Okay, now I finally got the account registered...I'm having all kinds of trouble with this browser though, think I'm gonna have to use Firefox instead. Thanks for your help Fire.

  20. #20
    Join Date
    Aug 2013
    Posts
    208

    Originally Posted by David A


    Okay, now I finally got the account registered...I'm having all kinds of trouble with this browser though, think I'm gonna have to use Firefox instead. Thanks for your help Fire.



    You're welcome, and yeah I do recommend using Firefox on the site.

  21. #21

    I'm having a similar issue myself. I've gone to the sites that Fire mentioned and tried logging in with my account whenever I use my ID that I use to log into this account it says wrong account name or password whenever I try to use my email that is registered under this website for my account nothing happens. I've tried clicking on the right side to create new account but at the date of birth section the submit button doesn't work. I've tried every variation of my account name and password as well as hours of searching on forums for help. I can't even use forum.square-enix.com/ffxiv/forum.php because it says that I either haven't been approved or I need to log in to post there. I've tried using a different browser and restarting my PC but it seems impossible to setup an account so that I might play FFXIV.


    Edit: Oh and I've also reset my password as well and that doesn't seem to work either.

  22. #22
    I'm having a terrible time getting my account set up so I can start in on FFXIV. Customer service has been horrendous, and I am seriously reconsidering whether I want to play a game with such awful customer service. With that said, let's see if anyone here can help me.

    I created a SE account around the launch of FFXIII to redeem my "points," and haven't logged in since.

    Now I need to log in so I can start FFXIV. I was told my User ID/password was incorrect -- so i changed my password and the confirmation email was sent to the appropriate address, therefore I know I am using the email associated with the account. Based on this, I assumed the issue must be with my User ID -- So I submitted a ticket requesting the information, and 2 days later, i received an automated message telling me that they coulnd't verify my ownership of the account. I've done this 3 times, with the exact same automated reply.

    So, I decided to just create a new account -- my new log in information works properly here on this site -- na.square-enix.com -- however, on square-enix.com/account and the FFXIV log-in client, it continues to tell me that my User ID/password is incorrect. When I try to create an account on this site, it tells me that my email is already in use -- and i refuse to create a new email specifically for Square-Enix games.

    This account management system is horrendously broken and needs to be fixed before the influx of Version 2.0 players.

  23. #23

    The whole website crash happened soon after FFXIII came out, the last time your on the site, so I am guessing that it must have erased your information due to your prolonged inactivity. If you want to get into FFXIV the best thing to do is to create a new email address specifically for the game. It should not be that much of a hassle because I have two emails. But if you really don't want to make a new one you will have to go through customer service and some how erase the old password completely. A little more difficult than just creating a new email. [img]/tools/tiny_mce/plugins/emotions/img/smiley-cool.gif[/img]

  24. #24

    The problem is not with my password -- i changed it through the "forgot your password?" option, which worked fine. The problem must be the User ID, which I imagine should be the same as the User ID here on this site -- aFlockOfMoosen. I don't understand why they can't allow me to use the email address to log in like every other service ever.

  25. #25

    i just bought the game and i cannot log in it refuses to let me when tryign to start the game.... -__- hopeless

Page 1 of 64 123451151 ... Last

Tags for this Thread