To summarize in a reddit post:

Basically, I've managed to play the game about 2 times. Once just to get past the tutorial, and another to about half liberate the first island. 3rd time I attempted to play, the game loads up to the beach screen with Rico saluting an explosion with what looks like Scorpion brand Jack Daniel's, then it goes to black with the little loading icon in the right only filling about 5 of the little slots and then freezes. Pretty much never moves even after being left alone for an hour.

I've tried everything in the Steam page and none of it has worked. I've tried everything from unplugging my monitors, reinstalling my graphics drivers (despite them being freshly installed about 2 weeks ago), tried running with Steam in offline mode, and still nothing. Hell, even tried doing a reinstall, and it STILL refuses to let the game launch. Here's a video of it happening.

Does anyone know of a fix or a work around that gets it working again, or should I just go ahead and get a refund? I haven't been able to play for over a month.