Hello, first off, I want to say "Wow!". These message boards are D E A D!

Secondly, I wanted to hopefully bring it to someones attention here at SE. I've made a few tickets, and gotten no replies, I see people complaining about it on reddit and gamespot, but basically it's 1-2 people bashing Square-Enix and a bunch on people agreeing, and no one taking action.

On PS4, it seems that a lot of users are unable to play the multiplayer mode. Myself, and my brother included. I purchased the physical version of the game, and purchased the digital for him. Two different types of software, two different systems, two different cities, two different ISP's..

We have both tried:
-Power cycled our networks
-Change DNS from default to and
-Tried various MTU settings (1500, 1478, 1473, 1450)
-New save files/characters
-Clearing more of the games content and unlocking more labyrinth levels

I have a list of players that I know of that are having issues, some from the Dragon Quest Heroes 2 PS4 communities, some from reddit, some from gamespot, and some that I know personally. Some players seem to have no issues AT ALL, while others are totally unable to create multiplayer lobbies, or summon help for boss fights. While trying to create a lobby, it says that you're connected, then says please wait, then says the lobby wasn't able to be created. I've tried AT LEAST 100 times...I tried 10-15 times each time I go back to Acadia, I try 10-15 times each time I launch the software, and I try periodically just because...still I am unable to figure this one out. I think it's safe to say that I've narrowed the issue down to a software issue on Square's side, however, I'm open to trying any solutions that may allow me to play with friends.

Side Note:
I can still use the auto matchmaking with Erinn, and I can be invited to other players lobbies that aren't having issues.