Thread: Books


  1. #1


    I've read over-and-over the Book tutorials and the tutorials that have the info on books, but DromEd2 can't find my books! I have them in Thief2\Books or/and Thief2\Books\English. I've checked spellings and both files are .str (not .str.txt). What am I doing wrong???

  2. In dromed add>book>text> bookname.str

    I always add the .str on the end and they ALWAYS work for me.
    You might have to restart dromed first! I don't always have to

  3. #3

    Thumbs Up

    Yep, I think Thorin found what is wrong: You made your mybook.str while dromed was open, and now dromed gives you the childish "but it wasn't there when you started me"-whine.

    You will notice that it's the same (even worse) with new skins and objects.

    Anyway, close the dromed, reload it, counter check that you have the filename correct (you want to add <u>"mybook"</u> in the dromed book->text if the file is called "mybook.str", <b>NOT</b> "mybook.str"), and it will be there.

    Notice that it won't give a fluffy rat's backside for updates of the file while you are in one dromed session, so don't expect it to realize anything if you change the text.

    <small>... hey, I'm all cool. It's just that it just gave me the "bad willowisp"- and/or the "hoho, don't mess with the physics of the broken arrow"-crash. And I only had spent some time to set up the Willowisp path nicely (which is tough.)

  4. #4
    It's still not working. I do "worried" and "worried.str" and I reload and close and reload and it still does not work.

  5. #5
    And worried.str follows the syntax correctly?

    worried.str (to be put into <b>/books</b> = Thief2\books\worried.str)


    Page_0: "I'm worried that dromed hates me today, my frog won't frob the button for the emitter trap anymore."

    In Dromed:

    Make RedBook (Household -> Books).

    Grab RedBook in dromed. Enter properties of RedBook. Add Book -> Text "worried")

    (it's maybe case sensitive, just be consistent and you should be fine)

    It should definitely be there in game mode.

    Did you add all the scripts (gen & convict) and stuff, right?

    Check out if directory "books" hasn't a capital "b", maybe that is the problem.

    You did not type in the "'s in the Books -> Text, right? Just a plain <b>worried</b> should do it.

  6. #6
    Daventry, I was plagued by the same problem - it wouldn't work, and I tried EVERYTHING (I even emailed poor KoMaG about it, and asked for ideas). And then I figured it out - this might be your problem!

    Although my book (I'll use 'message' as the name, 'cause I forget what it was, and it's entirely irrelavent) was titled message.str, it was, in fact, a .txt file - right click, and check out the properties of your file; it may very well be a .txt file! To fix this, open your text file in Notepad. Click File>SaveAs; in the bottom, change from Save as Type Text Documents, to 'All Files *.*' NOW save it as message.str (or whatever you want), and it will work.

    Hope this helps!!

  7. #7
    That's what it was. It did the stupid little ".str.txt" thing on me. My computer usually will put the file type or whatever (the .txt or .jpeg or.gif, or .str in this case) but it didn't put the .txt. Sorry for the problems.

  8. If you download my ThiefBookWizard you won't have that problem ever again!
    Author of :-
    Thief Book Wizard v2.2
    Thief 2 Objects List (versions 1, 2 and 3)
    FM's : Bassett's Keep, The Ring, The Game, Karras' Diary, Secret Weapon and co Author Mixed Messages.

    I have the builders patience on my side!

  9. #9
    Originally posted by Danventry
    That's what it was. It did the stupid little ".str.txt" thing on me. My computer usually will put the file type or whatever (the .txt or .jpeg or.gif, or .str in this case) but it didn't put the .txt. Sorry for the problems.
    No problem here, Daventry - I'm just glad I could be of assistance (that had me muddled for awhile when I was building my mission, until I explored the properties of the file...that's when I found that it wasn't actually an .str file; something I've learned since is that files shouldn't ussually have the file extension after them, in their names, for documents, and graphics (at least with Windows ME))!!

  10. #10
    I can recommend "editpad", that's a texteditor with some extras to avoid such hassle. I found it at a while ago, and I love it (I make basically everything with it).

    It will not automatically add the ".txt" or whatever.

  11. #11
    Something that works everywhere in Windows...

    If, when typing the name for a file in the "Save As..." dialog box, you enclose the name including extension in double-quotes, then Windows accepts that extension and doesn't try to add another one.

    I.E. Type...

  12. #12
    Wouldn't changing the notepad saving window option from "textfile" to "all files" maybe work, too?

    I don't use notepad at all, but maybe that would do the trick. Or use editpad, it's really a lot friendler. And prettier.

  13. #13
    They both work. I've tired them both. Either choose "All Files (*.*)" or put the file with " 's ("mybook.str"). Or both to be extra safe.