Page 1 of 2 12 Last

Thread: Having trouble with multiplayer, crash-to-desktop

Having trouble with multiplayer, crash-to-desktop

  1. #1
    Join Date
    Aug 2002
    Posts
    4

    Having trouble with multiplayer, crash-to-desktop

    I'm having trouble with playing multiplayer with my friends on our LAN. It crashes to desktop on a regular basis during multiplayer, typically around 10-15 minutes into a game regardless of use of save/load games. The computers share almost nothing in common in terms of hardware or operating system, and one even had just a clean install of WinXP on it. I have no problems playing single-player sandbox games or missions up to 5 (I haven't gotten past mission 5 yet).

    System 1 is running Startopia 1.1B on an AthXP1800, nForce 415D, WinXP. System 2 is running on an AthXP1700, KT266A, SBLive, and Win2k. System3 is running on an AthXP1600, SBAudigy, and Win98.

    Thanks in advance for advice.

  2. #2
    Have you ever heard of an ENTER key?
    That lot makes my brain spin.

  3. #3
    Have you aletered any in-game files, such as giving your self more e, or scuzzers in a mission?

  4. #4
    Are all three systems running the patch?

  5. #5
    Join Date
    Aug 2002
    Posts
    4
    I'm sorry I confused you -- I'll try to use the ENTER key more often, but I feel that breaking my explanation into multiple paragraphs might be less benefitial than leave it as a single topic.

    I haven't altered any of the in-game files. Just an install and a patch, all of them running v1.1B. What's the difference between 1.1B and 1.1, by the way?

    Six months ago I assumed it was Startopia itself, so I put it down. Now that it's been patched, when I tried it again it still doesn't work. Disappointing.

    --Ed

  6. #6

    Ed = Ed Mack?

    Make sure all players are running on the SAME version. That is very important.
    Thank you for your cooperation, your resident villain:
    http://www.staticon.co.uk/hosted_pix/ghyron.GIF

  7. #7
    The B might mean thhat it's a later or earlier version.

  8. #8
    The "B" doesn't mean jack. I have 1.01b and I can play people with 1.01 without any problems. The "B" just makes it more compatible with more systems.

    As for this StarTopia crashing bug thingey. This is what we know so far:
    1. All three computers are BEASTS!
    2. All three of them has the patch
    3. Atleast one of them can run single player games without problems
    4. Games start then crash during actual play itself
    Sensor, could you please tell us if all three games can play single player without any problems?

    If that checks out fine, then try playing lan games with just two of the computers at one time (and rotate which computers get used each time, ie you play 1 vs 2, then 1 vs 3, then 2 vs 3). That way we will be able to see if it is just one of the computers causing your problems.

    You may also want to try testing each computer individually on Gamespy (by bribing me or Startopiafrance [or anyone else who is keen] into meeting with you at specific times so you can have games).

    Hopefully it will be just one computer causing your problems, though I have one last idea: Your LAN. Is it a home or work LAN, and how many other computers are on it? Any other information you can supply on your LAN, firewalls, and general PC information would really help.

  9. #9
    Join Date
    Aug 2002
    Posts
    4
    That's a hefty reply, and I'll try and give it a hefty response.

    All of them play single-player games fine. This has been tested with 1 hour+ sandbox games. 1 computer, 3 computers, instant research, it doesn't seem to make a difference.

    The very first night we installed it, XP1600 played with XP1800 for 3 hours (one computer player). We started a new game with two computers; it crashed. We assumed it was the computers. We played with one computer player again, and I never finished researching past a trash bin.

    Furthermore, we tried switching from TCP/IP to IPX. We got a good 30-minutes in before the first time it crashed. We had been saving it every 10 minutes-ish, fortunately, but when we load the save game, it crashes at approximately the same point in time.

    Which brings me to another point: the autosaves aren't the same. When one of us crashes out to desktop, that person's autosaves are not compatible for loading with the other two. Once one crashes, we immediately exit to prevent newer autosaves from overwriting older ones, but it's no use. It's an anomaly.

    It's a home LAN. We're behind a D-link router with 192.168.0.x IP's, plugged immediately into a 4-port Linksys switch. One of us has a 3Com, another a Realtek, and another using the nForce ICP as NICs. We have no problems with anything else in terms of network performance.

    One time when crashing to desktop with the Win98/XP1600 machine, I got a small window that said it was "Ddplay" with an error, which got me thinking that it may be a DirectX issue.

    There were some DirectX9 betas leaked this week. I was wondering if anyone had any opinion as to whether that would fix the problem. All the computers are running DX8.1 instead of DX8.0a as the game requires, so the thought occured to me it may be DX.

  10. #10
    This is what we know so far:
    1. System 1: AthXP1800, nForce 415D, WinXP, 1.01b patch
    2. System 2: AthXP1700, KT266A, SBLive, and Win2k, 1.01b patch
    3. System 3: AthXP1600, SBAudigy, and Win98, 1.01b patch
    4. All three of them can run single player games without problems
    5. Games start then crash during actual play itself
    6. Systems 1 & 3 can play each other without probems
    Okay, one thing you may want to do is turn off autosaves altogether. Not by any means a life saver, but it's the little things that count right?

    I know next to nothing about how LANs work, but atleast you've got it out in the open and hopefully someone a bit more informed will be able to see if there are any potential problems there.

    Whenever you guys have time, you may want to test out Systems 1 & 2 alone, and then 2 & 3 alone. If you crash both times, then we can figure out what is wrong with System 2 and hopefully we'll all live happily ever after. What do you think of testing these systems individually online by the way?

    As for the betas, I would suggest staying away. I am running DirectX 8.1 without any problems (P41600, 512 DDR Ram, Geforce 2 MX400, WinXP), and generally beta means it's either unstable or incompatible with whatever you have (that's why it's a beta, it's still in the testing and fixing stages - I'd just wait until you get a game that requires the new version. I've never had to update DirectX any other way).

    I've gotten plenty of strange errors in XP, between STOP errors and "Cannot initiliase video card, please check it is installed properly". My favourite error was back in Win98, where I got "No keyboard decected, press F1 to continue". I have even heard stories of one error message going "Printer on fire". I'm waffling again, aren't I?

  11. #11
    Maybe it's that all the computers have different versions of windows.

  12. #12
    Don't forget that the Win98 system and the WinXP played each other without problems.

  13. #13
    Join Date
    Aug 2002
    Posts
    4
    Only once!

    None of the systems are able to play together anymore. This led me to believe something had corrupted between games, but an uninstall/directory delete and a reinstall made no difference.

    By the way, if I didn't mention it before, all three computers have experienced crash-to-desktop during multiplayer; the XP1600/Win98 crashes the most, the XP1700/XP crashes the least.

    I'm guessing the problem lies in DirectX, for some reason. The one common denominator between them is nVidia video cards with Detonator drivers (and I've tried many different detonator drivers). If it's nVidia cards in general, then the game gets to wait another 6 months before we try it again.

    Thanks for all your support guys, it's nice that people try to help, particularly when corporations don't reply to emails.

    --Ed

  14. #14
    Oh god. Another person with this problem.

    I had this ages ago. But I have reformatted my HDD since then, and don't know if it still occurs.

    What I do know is that it worked perfectly when we decided not to build Stardocks. Not at all, not even buy them.

    Why did we try this? Well, I noticed it happening about the time of trader warnings, so thought "what if I can make it so we don't get them". Lo and behold, it worked.

    Oh, and another thing. We didn't get the problem before the patch. It might suck, but try reinstalling and playing w/o the patches.

    That is all I can offer which is not including in what everyone else said.

    Good luck, hope it helps.

  15. #15
    Guest Guest
    This thread seems to be a little old, but I've the same problem.
    I read all the replys, but nothing worked.
    I tried the original version and the patches.
    First I thougt it's because one pc is very old (PPro 200 128Megs), but now I've got a new one (XP1700 512megs).
    the other one is an athlon 600 320megs.

    The client crashes to desktop after approximately 30mins.
    It seems to happen even sooner if you open the wall between two human players.
    Could it be that the game loses of sync and then crashes?
    This bug really sucks because the game is really fun.
    Oh, both pcs have win98 and 2k...

    Thanks for help (and excuse my bad english)

  16. #16
    Just a note on the patches. The 1.01B patch does not include the 1.01 patch. You must install the 1.01 patch seperately. The 1.01B is just a replacement file that supports more graphics cards. The 1.01 patch has all the bug fixes.

  17. #17
    I'd say the culprit is DirectPlay, and the different OS'. This sounds just like a communication error on the machines, i.e. info gets mixed up between the operating systems.

  18. #18
    Different OS's shouldn't be a problem with Direct X / Directplay, I mean look at ever other game using it that all work perfectly . . . . and it occured when I played versus my sisters at home a while back -> both on Win ME.

    I'm pretty sure it's a problem with the game.

    Really all we can do is hope MF comment . . . *hint*hint*

  19. #19
    Guest Guest
    Yeah, they released only 2 crappy patches (and the 2nd was only a patch for the patch)

  20. #20
    *Bump*

    I had to do this (bump) because I've been trying to play this game online for 3 weeks now and I crash to the desktop everytime. I found this post, but apparently the issue hasn't been resolved.

    Is there an answer for this yet?

  21. #21
    Problem Solving Steps:

    1. Patch
    2. Apply Other patches
    3. Use new cardid.tom files
    4. Update ALL system hardware drivers
    5. Eliminate any non-essential software when running StarTopia
    6. Tweak StarTopia graphics / sound settings, try different things
    7. Reinstall Game
    8. Reformat

  22. #22
    Originally posted by AlphaOmega
    Problem Solving Steps:

    3. Use new cardid.tom files

    What's that?


    I have patch 1.01, I know there is a 1.01b, but from the previous messages, that is not needed. I did try to install it though and I got an error message about the .exe. file, so I cancelled.

    Besides the latest video card drivers what other drivers are you talking about?

  23. #23

    Thumbs Up

    Install the b patch for sure (install StarTopia from scratch if you have to to make it work).

    For the cardid.tom file and an explanation, check the sticky "New Patch" thread in this forum.

  24. #24
    I am also experiencing frequent CTD's during multiplayer lan games.... (not internet).

    So far only the client (comp1) Crashes.. It's so frequent though that it makes the game unplayable multiplayer.. Both computers play single player fine.... (We've resorted to playing 2 seperate sandbox games with comp players instead of playing MP)..

    Comp1
    p3 600
    FICA vb 600
    Win2000 sp4+latest
    1024 mb ram
    radeon 8500 LE (128mb)
    SBlive (Value)
    netgear 10/100

    Comp2
    p4 2.4 ghz
    Intel db845gb
    WinXp home (latest updates)
    1024 mb ram
    geforce 4 ti 4400
    onboard intel audio
    onboard intel nic

  25. #25
    Seems like crashing is very usual. Same thing happens to me when i try to play over LAN.

Page 1 of 2 12 Last