Thread: On Traps

On Traps

  1. #1

    Question On Traps

    I hope I can download your trap tut in the next month, Komag, maybe that will help me with my problem.


    I have a room called "TrapRoom" with TrigRoomPlayer.

    I also have a switch.

    And I have a conversation in my blueroom, I will call this one "Conversation" below.

    Once the switch has been activated and is sending out the ON signal, the room is supposed to ControlDevice (CD) the conversation.

    I have tried it with an RequireAll Trap (RAT):

    CD: Switch -> RAT
    CD: TrapRoom -> RAT
    CD: RAT -> Conversation

    The problem with this setup seems to be related to the player walking through the TrapRoom already before the switch is activated. Then it sends out the ON to the RAT, and OFF once the player leaves the TrapRoom; and then, when frobbing the Switch and entering the TrapRoom again, my RAT seems to be as confused as I am (as in: not CDing the Conversation).

    I've checked this by entering the game mode and frobbing the button with and without firstly walzing through the TrapRoom. The Conversation itself is working properly.

    I've also already tried to replace the TrapRoom with a BoundsTrigger, but it seemed to have the same effect. Can't CreateTraps make BoundsTriggers, btw? That just did not seem to work at all when I went ahead to copy the createtrap from ToB's Trickster Mouth.

    After a lot of reading, I ponder if maybe RelayTraps might help me (no idea how to set them up yet.)

    Maybe I could make a SwitchConversation that adds the CD link between a RelayTrap and the Conversation? SwitchConversation and add CD link between TrapRoom and Conversation did not work - problem might be the same as with the RAT setup described above.

    What exactly do RelayTraps do?

    Would a setup possibly work that looks like:

    CD: TrapRoom -> RelayTrap
    CD: Switch -> SwitchConv (add link: CD: RelayTrap -> Conversation)

    Player enters TrapRoom. TrapRoom sends ON to the RelayTrap. RelayTrap looks confused around.

    Player leaves TrapRoom. TrapRoom sends OFF (I hope) to the RelayTrap. RelayTrap stops looking confused around.

    Switch is frobbed. SwitchConv starts, and a frog adds the link ControlDevice; Conversation; Relaytray (Flavour, To; From)

    Player enters TrapRoom again. TrapRoom sends ON to the RelayTrap. RelayTrap activates the Conversation.

    But why should this be any different from the direct SwitchConv (add link CD; Conversation; TrapRoom?

    Yikes. Or is there some really easy way to make the Signal of the TrapRoom reset to OFF in a way that convinces the RAT (back to the idea of the RAT setup).

    Or if I should kill the RAT and the TrapRoom, and instead my Switch should teleport in some AI who will frob another button that will activate the conversation as soon as she sees the player in the TrapRoom.

  2. #2
    Hmm ... a normal conversation happens only the first time the player enters a room, perhaps that's the problem.

    Maybe there is some setting which changes this behaviour to 'always', so that the conversation trigger happens everytime the player enters your room.
    Then, when the switch is on and the player enters the room, you could run the conversation and use a destroy trap to delete the room trap, so that the conversation only happens once.
    The Honest Thief - FMs, screenshots, DromED, links ... Zaccheus' hospital blog

  3. #3
    Hm... "locked"... you can lock doors. And doors send out ON and OFF messages when they are opening or closing.

    Door is locked.
    CD: TrapRoom -> Door
    CD: Switch -> unlocks Door (I <i>know</i> that this ought to work somehow)
    CD: Door -> Conv

    In what state is the door then when I unlock it? It has received an ON from the TrapRoom, but it was locked, so it couldn't open or send out an ON to the Conv, so it <i>should</i> be in the OFF state until I waltz through the TrapRoom again.

    Okay, this is down now to the level of "alarm systems that function by having a Guard (bad1) slay the Hammerite Novice (bad2) who was hiding behind a portcullis in a blue room until the other Hammerite Novice turned on the alarm" (not that this isn't funny, but...)

    Why is that dromed central thingie so extremely hard to find stuff in? ("Is my problem a fnord, a S&R, or a conv or a misc?") Aw man.

    If this <i>should</i> work, I only need to find other objects that can be locked like doors.

  4. #4

    The problem is definitely the RAT. hoho. Just make two up/down switches, CD both to the RAT and the RAT to whatever you want. Flip around with the switches in a chaotic order (makes me problems with the concept of Keepers are thirsty even more obvious to me (not sure if I have pulled the lever already, and pulling it twice may potentially kill the RAT.))

    After a while, the RAT will refuse to work.

    Hey, just like with the Keeper in MM when he is in the lying mood.

    It doesn't matter if the switches are pulled manually or by a TrigRoomPlayer; it just screws the RAT up when the switches are pulled back and forth.

    Buttons... I guess not. But who knows... At least, buttons can't screw up the RAT with OFFs. hmmm...

    Oh, and the doors? Hah. Once unlocked, they open (ON). That is not what I wanted, that the Conv starts when I am in the other end of the mission.

    I guess... I'll go and backstab something now...

    Err. And make a workaround. Enough of this engineering nonsense. I hate engineering anyway.

    I only need a way to make it feel "natural" and "it's a <i>feature</i>" that the player can't enter this room until the switch is pulled. Which is tough.

    And a workaround without RATs...

  5. #5


    Lytha, in Bonehord OM, there is a RAT when you have to light up those torches in the black and white room.

    If you lite up one of those torches, and then extinguish it again, would that mess up the mission so you can't complete it anymore?!
    The Honest Thief - FMs, screenshots, DromED, links ... Zaccheus' hospital blog

  6. #6
    Good point. I don't know.

    Maybe it depends too on the kind of input traps (TrigRoomPlayer, Boundstrigger), and on the kind of output.

    I think I managed to break the RAT though even already with two switches and an emitter trap.

    Like the skull-orb, my workaround will be a feature now, of course. It even solves a problem with the gameplay that I was already moaning about all the time when I was thinking about it.

  7. #7
    Hm... I removed all the buttons and doors and extra frogs that I had spilled all over the streets of my mission in the last days, but left two switches and a RAT and the conversation.

    CD: SwitchA -> RAT
    CD: SwitchB -> RAT
    CD: RAT -> Conv

    Oh, there's also a CD: RAT -> Emitter

    The weird part is now... the conversation <i>will</i> start (my frog displays the "froggie wuz here" testmessage, and the rest happens) after I did my best to screw the RAT by abusing the switches. But he starts up to one minute late.

    It is possible that it worked before, but that I -in my rage about the "screwed RAT"- didn't notice: Adjust the trap spaghetti-wires, Alt-G, run through the TrapRoom, pull Switch, run back into the TrapRoom. I guess I waited always only up to 20 seconds at most.

    Weird. When the original Switch was pulled, and I entered the TrapRoom, the Conv would start immediately. After some screwing around, the froggie needs a while to start frobbing. Instant effect vs. "wait up to 1 minute". Hmm...

    Just like the "be PATIENT" when summoning the Amulett in CL #2. I guess there was a RAT with the tendency to get screwed up after a few attempts to place the summoning items neatly and in exact place.

    So, I guess that screwing up the RAT in the Bonehoard with water arrows <i>might</i> cause a significant delay, but maybe it works after up to a minute.

    Ah well. The workaround is cooler anyway, and I need an INSTANT effect there. The one minute delay is unaccepteable.

    (just like the workaround for the "I can't customize object skins"... I *can* now edit these object skins (trick is to save it with less than 256 colours, saving it with i.e. 4 colours works just fine), but I will stick to my workaround because he is such a cutie.)

  8. #8
    I'm still at it, lol...

    <b>Thanks Komag for the TrapTut!</b> You're great.

    Looks like I used the RevertTrap in a dumb spot in the wirelines before. Possibly. Maybe? I don't know. I had linked it to the TrapRoom or to the relay from the TrapRoom, and that did not affect the confused RAT.

    (My engineering teachers would ROTFL now and say something like "just like we knew her back then at school")

    CD: TrapRoom -> RAT
    CD: Switch -> Revert; Relay
    CD: Revert -> RAT
    CD: Relay -> Destroy; RAT (timing: longer than the Destroy needs?)
    CD: Destroy -> Revert
    CD: RAT -> Conv

    Or the Revert could be triggered by the TrapRoom, not by the switch. I think. At least, not from the RAT itself. Hmm...

    Player waltzes through the TrapRoom, RAT gets 1 ON (1 of 2 = she is waiting now for the 2nd ON).

    Player leaves the TrapRoom, RAT is screwed and irritated now and would need up to a minute to CD the Conv if #2 ON is given and the #1 ON is given again. Lets leave her in this confused state until the Switch gets activated.

    Switch reverts the RAT (I hope she is back to the original 0 state now instead of being confused). Switch also sends the ON to the Relay; the Relay goes ahead and sends the Destroy to kill the Revert, and it sends his ON to the RAT.

    When the player enters now the TrapRoom again, it should work like when he enters it first time (instant effect).

    Given that the Switch will & <i>can</i> only be pulled once and that the Switch is the cause for the Revert to do anything, it maybe doesn't even need to be Destroyed.

    Just a

    CD: TrapRoom -> RAT
    CD: Switch -> Revert; Relay
    CD: Revert -> RAT
    CD: Relay -> RAT (this being linked via a Relay so that the ON from the Switch needs a bit longer to reach the RAT than the Revert signal needs... This Relay can get a timing too, if needed, so that the Revert is faster. The player won't reach the TrapRoom anyway in the next few minutes.)
    CD: RAT -> Conv & DestroyAll
    CD: DestroyAll -> the Revert, Relay, the RAT &amp;amp; itself (and then it rains), Switch is already gone.

    Or Froggie nukes them all during the conversation.

    Wasn't it possible to make a Destroy to a button, so that Froggie just needs to frob the Destroy?

    In theory, this should work. I think. Maybe. But the workaround #1 is still wayyyy cooler, and I'm curious if I could get workaround #2 to work (opens a loophole though, this stinks... ah... got it, froggie kills workaround #2...)

    Traps are about as sick as S&R and the Conversations, right? Some weird people will say that they love the traps because it's possible to do everything with them... Making a wireline of 60 traps in a row isn't as much different from the approach of dropping flowerpots or from the frogs and their buttons. Or from Guards bad1 that kill the hammerite Novices bad2... though, I think the latter approach wasn't used all that much.

    Or was it? Maybe more glances behind the scenes of some FMs would give really scary views with Novices drowning, burning, falling into the lava, getting knocked out, getting splattered by frogs, attacked by Guards, falling down shafts, getting pressed to death by elevators. Hmmm... that has a certain charming aspect. Maybe Totality's ingame shop would be funnier too with a Novice that gets the damage instead of the poor flowerpot named "purse"...

    TrapRoom ------------>
    -----> RAT ----> Conv
    | -->
    | |
    | |
    Switch -> Revert |
    | |
    ---> Relay --

    Well, a problem is that I am not sure what a Revert does with a half-activated and confused RAT.

  9. #9
    Hm... my test mission (featuring teleport with S&R and doors that are destroyed when shot at with arrows) is now featuring a TrapRoom, Button, and the "froggie wuz here" etc.

    Just like in the wireplan above, including a flowerpot being deleted by the DestroyThemAll so that I can see if it is working (additional to the "froggie wuz here")

    I need to give the button a kick though (push it twice) for the INSTANT effect of entering the TrapRoom, now that is, that is weird.

    I added some "timing" to the relay, but that did not seem to have any effect. When I entered the TrapRoom after I had frobbed the Switch, it will start the Conv.

    Well... if that is the only problem with the wireplan, I can have another froggie frob the button twice. What gives. There was anyway already another froggie needed and planned for the workaround #1.

    Hohoho... some testing later, I am glad that I did not start to put it into the mission again. Looks like the RAT forgets inpút after a while, very weird...

    Okay, back to the workarounds.

  10. #10
    Uh, yeah, something like that! Seriously, a bunch of traps and triggers can sometimes get confusing, but it's also fun to come up with things that work!

  11. #11
    I think you are the Totality/Sledge for Traps, Komag.

    Okay, I have debugged and debugged. Even without the RAT, I had a trigger problem.

    The main part of the problem (RATs acting funny aside) was the following:

    My Conv took place in a room quite far away from the TrapRoom (blueroom with a froggie, I thought I did not want this blueroom with the plaques and buttons and the froggies floating around over my mission, so I had tossed it to the side.)

    When I walked into the TrapRoom right at the start of the gamemode, Froggie wasn't in the frozen "efficient" mode, I guess.

    Because, as soon as I walked into the opposite direction and fooled around a bit, he would not activate anymore, until I walked a lot closer to his room. That made me already think that some other of my buttons messed up the rooms (I have a lot of room types for the automap.. heh...), so I debugged them. When a BoundsTrigger showed the same effect, I was at the end of my wits until I recalled the frozen AI effect. Yep, that was it. The frog-room is now in one of the decorative buildings without any purpose (but to look nice), and it worked.

    I'll torture my prae-alpha tester a bit now, I guess ("break it!")