Page 1 of 5 12345 Last

Thread: FFVII Login Problems

FFVII Login Problems

  1. #1

    FFVII Login Problems

    It keeps asking me for my email/username and password. Ive evntered both and no dice. Ive changed my password, no dice. I asked the client for a password reset and entering my email returns a No Email found even though I just recieved a email to change my password. --;

    And yes, I'm trying to log into the SquareEnix NA part.

  2. #2
    Originally Posted by Andre
    It keeps asking me for my email/username and password. Ive evntered both and no dice. Ive changed my password, no dice. I asked the client for a password reset and entering my email returns a No Email found even though I just recieved a email to change my password. --;

    And yes, I'm trying to log into the SquareEnix NA part.
    Im also gnow getting a must be connected to the internet error. I have no firewalls or anything on. Im just using Microsoft Security Essentials.

  3. #3

    Could I not play FFVII because I made my account today and apparently there is 24 hours before you can use your account? Cause that is stupid then. --

  4. #4

    LOG IN PROBLEMS FIX


    I've been having nothing but trouble getting this to work. I just wanted to share what finally worked for me. Two problems I had:

    1) Game loading hung up at 10% and said I had no internet connection.

    It's clear now that this has nothing to do with your internet connection and just means that Squares servers are busy. Keep trying it will work.

    2) After getting to the login screen it tells me my email address is invalid even though I used it to buy the game and register at square? Can't even rest password because email address is invalid.

    Solution to this was mind boggling. To the left of the email address and password field you will see two boxes. One for facebook and below it one for Square Enix. CLICK THE SQUARE ENIX BOX. Now you can log in with your account name or email address. Wtf Square. Ugh.

  5. I don't want to log in with facebook on this game, so I choose to log with my square enix account. I enter the correct information and correct password, I press Log in and than........




    the change you wanted was rejected. Maybe you tried to change something you didn't have access to.


    So... How can I resolve this, I don't want to log with facebook.</pre>

  6. #6

    I can't log in either...I'm REALLY not impressed with this.

  7. #7

    Is anyone having trouble with the site loading after you click 'View Online Profile' In FF7 Launcher

  8. #8

    Originally Posted by taylor


    Is anyone having trouble with the site loading after you click 'View Online Profile' In FF7 Launcher






    I don't have a problem loading the site, but it's displaying me as Member_19382130983, or some odd string of random numbers.

  9. #9

    I was having this issue a few weeks ago and then a few days later I was suddenly able to logon.....not sure what SE is doing.

  10. #10

    I FINALLY got to the login and I put in my info and it says invalid. So I click to recover my pasword because maybe i forgot it and it says the email i just put in is not found. Seriously wtf square

  11. #11
    Join Date
    Dec 2013
    Posts
    45

    Click on Square Enix North America icon the left of the login. Then try again.

  12. #12

    i just bought this game and its telling me my password is wrong when i try to enter the game... it is not wrong... why is this happening?


    i just bought this game and its telling me my password is wrong when i try to enter the game. I can log into this site.. obviously, but the game client tells me my info is incorrect.. Edit. also tried to log into the support area and im having the same problem.


    any help would be great, thought buying games was spose to be easier then pirating... guess times change lol













  13. #13

    I am having the exact same problem. Very funny. : |

  14. #14

    I could only get it to work with my email not my username

  15. #15

    I finally got it to recognize my screen name and password, but none of the buttons: PLAY, ACHIEVEMENTS, SETTINGS will do anything when clicked on. Seriously, why the hell does an offline game (with OPTIONAL online features) need to be linked online to play??? This is stupid!

  16. #16

    You'll want to click on the button on the left that says Square Enix North America and input your password and information there.

  17. #17

    thanks for the reply but in both the support log in page and the shortcut on my desktop, there is no button that says that

    in my browser address it already states i am in the "NA" page... if that means anything

    thx





    i should add that late last night i went to log in, and it worked, but told me the server was offline


  18. @Crono1973 I did try that, and it isn't working!

  19. #19

    Yup, says invalid email or password. Then when I request my password it tells me my email is invalid. Okay, so maybe something messed up when I registered; I go to register again, and ooh! My email and account are already taken! Guess what, I have forum access but no game access! This is just stupid.

  20. #20

    same problem here as the OP.i can log in here at this website but when opeing the game(FF7) i get invalid username/password in NA sign up.SE should fix this ASAP.

  21. #21

    IM on hold with them now.. having the same exact issues..





    I have to reset my password every time I want to log onto the forums.

  22. #22
    Originally Posted by Dany
    I don't want to log in with facebook on this game, so I choose to log with my square enix account. I enter the correct information and correct password, I press Log in and than........




    the change you wanted was rejected. Maybe you tried to change something you didn't have access to.


    So... How can I resolve this, I don't want to log with facebook.</pre>
    Well I am able to log in to my account, but the weird thing is I just started an account, but I didn't realize that I had set one up a couple of years ago. I used the same username and email to set it up, but different passwords. So now, when I enter the username but a different password (each time) I get two different accounts with different names on it. They are both mine, but its weird. I don't know which account I used to get my FF VII game from since I can't see the order and I need my stupid activation code, and I haven't received any email. I am so frustrated...argh.

  23. #23
    So I have an NA account (obviously since I'm posting here and not the EU site) and it won't let me use either my Square Enix account info (for FFXI) or my member account info (which is linked to the my square enix account). So I have to click the NA members box to the left. I then have to use my username (which is the same for both my square enix account and square enix members account). When I log in, i'm now known as member_10033216 instead of Reks, which I'm assuming it should be. Anyone else have this problem? Anyone else know how to fix it? Not super important, but more annoying than anything else. When i view my online profile page it comes up the same.

  24. #24

    I'm having the same issue.


  25. I decided to log in with facebook and it works...!

Page 1 of 5 12345 Last