Thread: Elevator crash t29 building on mission 4 or 5

Elevator crash t29 building on mission 4 or 5

  1. #1

    Exclamation Elevator crash t29 building on mission 4 or 5

    Kk... so I have been stuck in the game for over a week now, a literal week I have not been able to progress the game because it always freezes when I go down the elevator to hand in the evidence and speak to the shrink. I have done all the side missions and explored everything. They said a patch was going to be out in a "few days" like 12 days ago. I am on xbox one btw, this is really annoying AF, I even convinced two friends to buy this game because I told them how fun the first was. We all have the same issue.

    When the F are you going to fix this... so many people have the same issue yet nothing is resolved what a joke. I have tried waiting patiently but you don't seem to be doing anything about it. Can you give ANY updates? This is really a huge waste of 80 bucks (canada price) or does anyone have a fix? Yes I did try to reload an older save it didn't work, then I did all the side missions since a patch was "out in a few days" so no I am not starting this game over.

    Someone help please, maybe this game can leave a decent impression if I can get this working

  2. #2
    Join Date
    Sep 2016
    Posts
    1
    Have the exact same problem, can't even get anywhere around Praha Dohva. This game is so broken yet it seems like they are doing nothing to fix it.

  3. #3
    I feel your pain brother, what a let down. They give no updates or anything, how can it take 2 weeks to fix this issue?

  4. #4
    seriously still no mod from square enix has responded to this? What a joke, clearly they don't give 2 s

  5. #5
    sent an email to the help desk 12 hours ago and still no response back, sweet

  6. #6
    Join Date
    Jul 2014
    Location
    Montréal
    Posts
    61
    As mentioned in our Known Issues sticky thread, we are currently working on a fix for this issue.

  7. #7
    right I get that and I don't seem to sound like a *, but it also states a fix will be out in a few days - dated august 28, it's september 9 now, so people haven't been able to play for over 2 weeks now

Tags for this Thread