Results 1 to 8 of 8

Thread: Soul Reaver 2 - Bink playback problem - Win10

  1. #1

    Question Soul Reaver 2 - Bink playback problem - Win10

    I'm completely stumped ...

    Problem:

    Running SR2 v1.02 in Win10 x64 + nVIDIA GeForce GTX 870M Rev A2 (6GB) - Driver v368.81, the first FMV with Raziel and Kain starts, and looks like the picture below. The audio is very rushed and skippy, like it's playing in fast-forward mode.

    As far as I can tell the gameplay is actually fine. All cut-scenes play fine too. So this is purely a Bink problem.



    What I've tried:



    For the record, the movie#.dat files I have play fine in binkplay.exe

    Game was installed from CD (not Steam or GOG).

    My specs:


    I've searched high and low and can't seem to find anyone who has seen or even heard of this kind of response from the game. This glitch is amazingly consistent. Almost no matter what I've tried it's the same result.

    Anybody got any ideas?
    Last edited by TheArkyTekt; 15th Aug 2016 at 14:13.

  2. #2
    Just wanted to add a bit more. Found a nice program called DxWnd and managed to get the first (of 2) FMV sequences to play. But it's still way off, though at least the audio plays back normally.

    It looks like this:


    Also, when I go into the spectral realm, I can't move Raziel, he's stuck, and the scene doesn't change at all. After about 3-5 mins it finally changes and then I can move Raziel. It's weird. Not like a freeze, but a "delay" of entering the spectral realm.

    Found a post on Steam forum for this one. DxWnd was their solution, but not fully working for me yet.

    EDIT: Found another tool called dgVoodoo. I'll be messing with this too just to see what I can make happen.
    Last edited by TheArkyTekt; 15th Aug 2016 at 06:39.

  3. #3
    Join Date
    Sep 2007
    Location
    Russia
    Posts
    293
    As I know, dgVoodoo really solves some problems with intro (for example, it helps for me), but for one fan it can't solve problems with the colors (I do not have such problems on my PC with Win-10 x64, Intel HD and nVidia). For the test I created the patch (SR2_BinkHookBeta.exe on OneDrive, see link in my signature) but I do not know whether it can help (because that guy disappeared and no one with the same problem can test this patch) + it was created for the Steam/gog version of SR2 (i.e. 1.0.2). It is known that version 1.0 of SR2 had some problems with colors (not only in the movies but in the game itself too) - fans solved them early by some settings of the registry.
    Support of LOK-games is the duty of Square Enix and Crystal Dynamics.

  4. #4
    Thanks for your reply!

    I'm running SR2 v1.02 (updated OP to show that - my bad). I'll try the patch, and post my findings. Hopefully it will work even though I'm on vanilla PC version.

  5. #5
    Just wanted to report back the "fix" for this issue!

    Source: https://sourceforge.net/p/dxwnd/disc...c6785f19/#1d1c

    Thanks to DXWnd's author, a very simple fix can be applied with no patching required. Just set the color depth to 32-bit in the game menu.

    The problem is that the Windows 10 desktop is 32-bit by default and can't easily be scaled down. Then trying to configure software to play back video in 16-bit on top of that gives the funky colors and aspect ratio. DXWnd's author may actually still come up with a fix for this, but at least this issue is actually very easy to fix for now!

    I used to swear by 16-bit for the sake of performance and frame-rate. But now that modern hardware and software is so fast, and given how old this game is, I don't get ANY frame-rate drop by using 32-bit so ... cool!

    NOTE: I use the vanilla PC version, not steam. Though if you get the same issues in Steam, I would imagine that you can fix this the same way. Please reply here if anyone gets it confirmed and working!

    NOTE2: When I try to implement the new bink32/64 DLL's and the new videos, I get video but no audio. I may have missed a required patch or something... still looking into it.

  6. #6
    Join Date
    Sep 2007
    Location
    Russia
    Posts
    293
    Setting the color depth to 32-bit in the game menu does not help with this problem - it is default setting in my own case.
    still looking into it
    Look further.
    Support of LOK-games is the duty of Square Enix and Crystal Dynamics.

  7. #7
    Hmm... I was using DXWnd and dgVoodoo to get my result (on the PC version). Are you using the Steam version? GOG version? Old CD version?

  8. #8
    Join Date
    Sep 2007
    Location
    Russia
    Posts
    293
    Steam version = gog version = old cd version with applied official patch + removed protection from sr2.exe.
    For me dgVoodoo solved all problems with bink-video (I checked original intro from SR2 + intro from SR1 too) also as my own patch (fix sooner). On Win-10 x64 Intel HD & nVidia.
    I do not use DXWnd since this utility does too many (much more than dgVoodoo or even my patches) unneeded changes (hooks) in many dlls.
    Support of LOK-games is the duty of Square Enix and Crystal Dynamics.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •