Results 1 to 6 of 6

Thread: [Linux] Game crashes on startup.

  1. #1

    [Linux] Game crashes on startup.

    I am running the latest RC of the Kernel with support for CIK hardware and the AMD GPU-PRO 16.30.3 on Ubuntu 16.04. The game crashes after clicking on Play in Steam.
    Middle Earth: Shadow of Mordor by Warner showed the same behavior with v16.20, haven't tested it with 16.30.3 yet.

    System Info:

    Crash dump: http://www.mediafire.com/download/qu...0-6bf3e1f7.dmp

  2. #2
    Join Date
    Feb 2016
    Posts
    27
    Hi,

    The Linux support is here:
    http://support.feralinteractive.com/...es/tombraider/

    However, please use mesa 11.2 (mini) for the best performance.

    An I have found an issue for that:

    You need to modify TombRaider.sh in steam path (../steam/common/Tomb Raider)

    Find this line:

    HAS_CATALYST= "$(lsmod | grep fglrx)" #"$(grep fglrx /proc/modules)"

    and replace by:

    HAS_CATALYST= "$(cat /proc/modules | grep fglrx)"

    In fact, you use fglrx drivers, but the Tomb Raider start script not detect correctly fglrx drivers.
    With this line, the game start, but you have a warning "no fglrx installed". Ignore that and enjoy.

    PS: I don't know if the game, with this modifications, use fully fglrx acceleration. But it work!

  3. #3
    Thanks for your helpful reply! I didn't know that the publisher is different for the Linux versions.

    Unfortunately your suggestion didn't work. I am not using the fglrx driver but the brand new AMD GPU-PRO driver.
    Code:
    user@PC:~$ cat /proc/modules | grep fglrx
    user@PC:~$ cat /proc/modules | grep amdgpu
    amdgpu 1372160 7 - Live 0x0000000000000000
    ttm 98304 1 amdgpu, Live 0x0000000000000000
    drm_kms_helper 147456 1 amdgpu, Live 0x0000000000000000
    drm 364544 10 amdgpu,ttm,drm_kms_helper, Live 0x0000000000000000
    i2c_algo_bit 16384 2 amdgpu,igb, Live 0x0000000000000000
    But with your link I found out that the driver isn't supported yet. So I will send Feral Interactive the URL of this thread so they can use it to make the game work with AMD Fury and newer by default with the current Ubuntu release.

  4. #4
    Join Date
    Feb 2016
    Posts
    27
    Ok

    At same lines try to replace "if" condition:

    #HAS_CATALYST= "$(cat /proc/modules | grep fglrx)" #"$(lsmod | grep fglrx)" #"$(grep fglrx /proc/modules)"
    #if not [ -n "${HAS_CATALYST}" ]; then
    export LD_PRELOAD_ADDITIONS="YOURSTEAMFULLPATH/steamapps/common/Tomb\ Raider/lib/i686/libtcmalloc_minimal.so:${LD_PRELOAD_ADDITIONS}"
    #fi

    It work for me.

    And ignore warning at startup.

    Important: At line begin to "export" replace YOURSTEAMFULLPATH by your steam full path. You need to sure that path is correct.

  5. #5
    Join Date
    Feb 2016
    Posts
    27
    Quote Originally Posted by OOOverclocker View Post
    Thanks for your helpful reply! I didn't know that the publisher is different for the Linux versions.

    Unfortunately your suggestion didn't work. I am not using the fglrx driver but the brand new AMD GPU-PRO driver.
    Code:
    user@PC:~$ cat /proc/modules | grep fglrx
    user@PC:~$ cat /proc/modules | grep amdgpu
    amdgpu 1372160 7 - Live 0x0000000000000000
    ttm 98304 1 amdgpu, Live 0x0000000000000000
    drm_kms_helper 147456 1 amdgpu, Live 0x0000000000000000
    drm 364544 10 amdgpu,ttm,drm_kms_helper, Live 0x0000000000000000
    i2c_algo_bit 16384 2 amdgpu,igb, Live 0x0000000000000000
    But with your link I found out that the driver isn't supported yet. So I will send Feral Interactive the URL of this thread so they can use it to make the game work with AMD Fury and newer by default with the current Ubuntu release.
    However you can replace fglrx by amdgpu in Tombraider.sh

  6. #6
    Thank you for taking your time but I think that these not-loaded additions are not the (only) reason for the crash because both haven't worked either. I guess I can just wait for the driver getting supported.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •