Results 1 to 3 of 3

Thread: EVGA 970GTX SC VS Rise Of The Tomb Raider frame rate issues!

  1. #1
    Join Date
    Apr 2016
    Posts
    1

    EVGA 970GTX SC VS Rise Of The Tomb Raider frame rate issues!

    Okay so i pretty much tried everything in order to fix my frame Rate issues for Rise of the tomb raider. From going to nivida control panel and turning on Maximum performance to highest frames allowed to updating my GPU drivers to the latest one as of lately i am still getting bad stuttering issues for this game in certain levels.

    Right now i am in the lost city level and i am getting like 40 to 50 fps. The main issue is that once i get to that fps the game starts to stutter. I am okay when i am in the caves or anything to do with indoor gameplay but once i am like in a free roam section the game really starts to stutter for me. Is anyone else facing this issue? I even put everything to the lowest setting possible go back to the lost city level and while i am running on the roof top i am still getting the same issues of 40 to 50 fps and it still stutters.

    Is something wrong with the game or is it just me?

    Cause i have a pretty good PC: 8350 FX, 970GTX 4GB, 8GB DDR3 1600mhz, SSD 840 samsung. 1000wat PSU antec.

    I am aware that the 970gtx as that 3.5gb memory issue and if i go anything over i read you run into some slow performance but when i play Tomb Raider i am hitting around 2gb Vrm and on low setting 1gb VM and it still stutters.

  2. #2
    Quote Originally Posted by raiderman1984 View Post
    Okay so i pretty much tried everything in order to fix my frame Rate issues for Rise of the tomb raider. From going to nivida control panel and turning on Maximum performance to highest frames allowed to updating my GPU drivers to the latest one as of lately i am still getting bad stuttering issues for this game in certain levels.

    Right now i am in the lost city level and i am getting like 40 to 50 fps. The main issue is that once i get to that fps the game starts to stutter. I am okay when i am in the caves or anything to do with indoor gameplay but once i am like in a free roam section the game really starts to stutter for me. Is anyone else facing this issue? I even put everything to the lowest setting possible go back to the lost city level and while i am running on the roof top i am still getting the same issues of 40 to 50 fps and it still stutters.

    Is something wrong with the game or is it just me?

    Cause i have a pretty good PC: 8350 FX, 970GTX 4GB, 8GB DDR3 1600mhz, SSD 840 samsung. 1000wat PSU antec.

    I am aware that the 970gtx as that 3.5gb memory issue and if i go anything over i read you run into some slow performance but when i play Tomb Raider i am hitting around 2gb Vrm and on low setting 1gb VM and it still stutters.
    I still haven't played Rise of the Tomb Raider, but I'm pretty sure anyone would need to know what resolution you're running the game at. Just because it stutters at a triple-monitor, 4K setup (I know this isn't your setup), doesn't mean it should stutter at 1 x 1080p. Also, I don't believe 1 x 1080p would use more than 3.5 GB of your graphics card's RAM, so I doubt the 0.5 GB of "slower" RAM is the issue. My best advice is to let GPU-Z (and CPU-Z) log in the background while playing so you can check CPU/GPU load when the game is stuttering.

    Good luck!

  3. #3
    Join Date
    Jan 2016
    Location
    Croatia
    Posts
    45
    Try switching to DX12
    Rise Of The Tomb Raider max settings Xtreme Benchmark 1501MHz: https://youtu.be/kzA3Cvx8CNo


    (click image to enlarge)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •