Thread: Another "Nosgoth doesn't starting after patch" thred

Another "Nosgoth doesn't starting after patch" thred

  1. #1

    Another "Nosgoth doesn't starting after patch" thred

    Okey devs you are pretty well informed about a bug that doesnt allow many players to play nosgoth. I am talking about pressing Play button in laucher and nothing happens. I tried almost all advices that were given in other threads ( and none of them helped. Honestly we both know that problem not in my or other players computer or software but in your game because it is completely clear and obvious that game worked fine before an update and game broken after update. Why should I reinstall tons of software or even a windows (or change from windows 7 to windows 10) because you only copied an eldrich guard and called it a chain lighting? No new graphics or game engine, so i dont see a problem running this game after update on same PC with same software.
    Summing up i want to ask only one question - how long will it take for YOU to make a fix patch that will solve this problem for all community, so we can just press an update button, wait a bit and simply play (like every decent game does) without becoming an IT PhD?
    Last edited by Tunnel_VisionX; 16th Mar 2016 at 14:08.

  2. #2
    Hi there,

    I've got something new for you to try if you're up for it.

    We're currently trialling Nosgoth's desktop launcher at the moment. If you log in to and click the play button, the desktop installer will download. It uses a different prerequisite installation process to Steam, so it may well fix your issue. If you want to download the installer and let it install the launcher and prerequisites, that may well fix your issue.
    Square Enix Europe Community Manager
    Square Enix Europe Community : Facebook | Twitter | YouTube | Twitch

  3. #3
    Join Date
    Mar 2016
    I download the installer from the homepage and install the game with the lancher.(not Steam)
    at 99.9 % it stucked but after a restart of the launcher erverything work fine
    Last edited by Roboxx; 16th Mar 2016 at 16:59.

  4. #4
    Hi Oghamsmith i tried your advice but it didnt help. I got windows 7 64-bit and your installer gives me and error 0x800713ec-Asia when it tries to install microsoft net framework 4.6 . But as we can see from this page 4.6 version is only for windows 8 and above. Is your game no longer supports windows 7 after adding a couple of skins and a bird guy?
    Here is a logfile
    Last edited by Tunnel_VisionX; 16th Mar 2016 at 16:04. Reason: Added spoiler tag for the code

  5. #5
    Thanks for the info Tunnel_VisionX.

    Windows 7 does indeed, support .NetFramework 4.6, however you do need to ensure that your operating system is up to date with the latest service pack. If you haven't run it in a while, please run Windows Update to make sure that it's on Service Pack 1 and up to date.
    Square Enix Europe Community Manager
    Square Enix Europe Community : Facebook | Twitter | YouTube | Twitch

  6. #6
    Oghamsmith I installed Service Pack 1 and after it i managed to install nosgoth through desktop installer, but it still doesn't work. When i click play button in the laucher it gives me a "The procedure entry point urctbase.terminate could not be located in the dynamic link library api-ms-win-crt-runtime-1-1-0.dll" error. I googled that this error is connected with vcredist 2015, and i succesfully reinstalled both x64 and x86 versions but it didnt help. Do you actually have any evidence of your game working after beastamaster patch on windows 7? And can you explain if it is possible why i have to evert my whole system after you added only some minor almost cosmetic changes? I have never faced such a problem with any other games or software.

    I mean have you intentionally raised software requirements for your game (for example your game only runs now on latest updates of all windows soft)? If you did so is it really neccesary if you only added a new class and skins?
    Last edited by RainaAudron; 17th Mar 2016 at 12:00. Reason: Double posting