Thread: Nemesis Trophy bug

Nemesis Trophy bug

  1. #1

    Nemesis Trophy bug

    Hello everyone,

    Sorry if this issue has been dealt with in another thread, but I couldn't find it if it was. I just played 210 hours @ Final Fantasy X HD Remaster on my Ps4 and managed to build a super strong team by replacing all the nodes in the Sphere Grind.

    I then proceeded to get all the monsters in the Arena and killed them all in order to unlock Nemesis.

    I did unlock it. The issue is... I didn't get my trophy when beating it ! I tried several times, nothing. I left the zone, came back again, killed it again, still nothing. I left the game and came back, nothing. I restarted my Ps4, nothing... The strange thing is that I received the Mark of Conquest from the old guy after I beated it, but no trophy...

    Can anybody help me out ? I was really looking forward to get my Platinum but it seems I won't be able to if I can't get this one... And I sure don't want to start over since I played for over 200 hours already...

  2. #2
    Update : I got to fix the issue by myself : Rebooting your Ps4 or the game won't help, I had tried it many times and it didn't change anything. I had also tried to go in another zone (Mt. Gagazet) but when I came back to rekill Nemesis it still wouldn't give me the Trophy. What you need to do is to go back on the airship, then back on the Calm Land again. I did that and the trophy unlocked himself after I beat Nemesis again.

    It would be nice if Square Enix could definitely fix the issue though...

Tags for this Thread