Thread: Nosgoth Launcher Troubleshooting

Nosgoth Launcher Troubleshooting

  1. #51
    but thanks for try

  2. #52
    i don't realy understand....the launcher has a 1000 different problems!!!!

    you fix one and than another appears...even ahrd core fans like me who play from the closed beta have had it...

    when you want to play a a game you click play and paly it...not do a thousand things just to be able to do that simple thing

    not enough thet the game has a 1o00 bugs that have not been fixed , lag issues ..and other stuff that is sloppy ley implemented....now on top of all that , you come up with this brand new ..so it is a damn CHORE EVEN TO START THE DAMN GAME!!!
    Last edited by RainaAudron; 25th Jan 2016 at 17:47. Reason: TOU 10.

  3. #53
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    750
    SERVER PROBLEMS?

    Sometimes, for about 5min at a time at random times during the day, my Launcher will not log into my account.
    The Play button is greyed out and the box above just has the loading icon spinning forever. Worst part: When I try to log into the forums, I get an error. As soon as the forum login is back, I can also get back into the game.

    ______________
    While I'm here:
    - What's the point of having an |X| button if it only minimizes the window? Thats what |-| is for!
    - Sometimes the launcher opens in the background. I click on Nosgoth in Steam and nothing happens for 3 min, because I forget to check my tray to open the Launcher. (Just give us a "Automaticall start the game" / "Automaticall close Launcher after the game closes" option!)
    - The Launcher has the steam overlay enabled... Why? Every time the stupid steam notifications block the play button!
    - It would be useful to change graphic settings and bindings from the launcher (Quality of life)
    - What about a showcase for upcoming ESL tournaments and rankings of the Monthly Finals?

  4. #54
    Join Date
    Dec 2014
    Location
    Netherlands
    Posts
    40
    I had a grey play button a few times, but that only meant that the launcher couldn't link my account.
    When i checked the main square enix website it gave me a internal server error when i tried to login manually.
    So when you see that just wait a while. Besides that the launcher worked flawless.

  5. #55
    Join Date
    Jan 2016
    Posts
    1
    I installed windose 10. tried different drivers, direct x, reinstal all Netframework and Visual C++, reinstal game, useless.... The account SQUARE Enix there is no possibility to connect the steam account, only facebook xbox and playstation, no steam in list. Still I am looking for a solution !! When you start the game, nothing happens (no errors)... Looking for help...

  6. #56
    I recently had some computer troubles and had to reinstall everything. After finishing, I couldn't start Nosgoth. At first the game didn't start when I pressed play in the launcher. After I installed various Visual Studio C++ packages, I started getting some appcrashes with the "Fault Module Name: KERNELBASE.dll" errors. So I reinstalled windows (windows 7 64bit) again, and again getting the same error. I tried installing Windows 10, still same error. So I tried windows 7 again.

    This time I got a "MSVCP120.dll missing" error along with some KERNELBASE.dll errors when I tried starting the game. After some digging I found out that even if you have a 64bit windows, you still need the 32bit versions of Visual C++ packages.

    Long story short, I finally got Nosgoth working by doing the following:
    1. Go to https://www.microsoft.com/en-GB/down....aspx?id=40784
    2. Download both vcredist_x64.exe and vcredist_x86.exe.
    3. Install both, even if you have a 64bits windows.

    Hope this helps.

    ---

    Rusty Razor

  7. #57
    Originally Posted by Oghamsmith
    Updated for a solution for another scenario.
    I am curious how come those scenarios are not solved by developers side but community needs to get PHD in nosgoth troubleshooting so we can actually get to play the game ?
    And yet these scenarios are currently not working for some of the cases .

  8. #58
    Have 800+ hours in game.

    Resintalled my windows 10 clean, installed full pack of whatever is in that common folder - doesn't help, reinstalling the game doesn't help.

    Symptoms - after clicking play in launcher the button grays out and nothing happens, few seconds later it goes red again (as i the game opened and closed...).

    Any advice?

    Lava

  9. #59
    Originally Posted by Lavamancer
    Have 800+ hours in game.

    Resintalled my windows 10 clean, installed full pack of whatever is in that common folder - doesn't help, reinstalling the game doesn't help.

    Symptoms - after clicking play in launcher the button grays out and nothing happens, few seconds later it goes red again (as i the game opened and closed...).

    Any advice?

    Lava
    Try running the Launcher exe as administrator - that is the common fix.

    EDIT: To find the exe - open your Steam library -> click Properties on Nosgoth -> Local Files tab -> Browse Local Files...

  10. #60
    Tried this, getting stuck at


    The circle goes infinite and play button is grey. Tried relogging, relaunching steam and launcher, always getting the crap above when I run the launcher and always get the same red-> grey -> red button when I launch through steam.

  11. #61
    I got bored and installed X-Com, which also has some prerequisites, these files have fixed Nosgoth...

  12. #62
    Hello all

    I've just got a new laptop and nosgoth wont run. I can bring up the launcher fine but when i press the play button it just grays out and doesnt do anything. My launcher also does not show anything related to linking my square enix account. I've tried reinstalling the game numerous times, redownloading the vcredist files, my drivers are completely up to date i dont know what to do.

    For reference here is what the launcher looks like: http://imgur.com/VEhDAg1

  13. #63
    Join Date
    Feb 2016
    Posts
    1
    I have followed all the tips on this post and nothing works. I have googled and done everything I can think of to get my launcher to work. My wife and I have twin machines, identical hardware/software/etc, her Nosgoth works and mine does not.

    The launcher opens and connects to my square enix account but it gets stuck trying to verify the link to my Steam account. Nothing works. If I go to Manage my Accounts and then come back the launcher freezes completely and turns into just a blank white screen. This white freeze happens if I manage accounts or click on any other menu option at the top of the launcher.

    Here is a brief list of what we have tried (not in any order):

    - Opening a ticket to Square Enix (lol) - sent in another one today
    - Verifying integrity of game files through Steam
    - Deleting Cache folder
    - Updating C++ and .NET files
    - Followed official troubleshooting guide (listed here)
    - Uninstalled, restarted, reinstalled x1000
    - Deleted existing Appcrash reports
    - Ran game as Administrator x1000
    - Unlink account in browser, uninstall/reinstall, restart, relink account in browser, launch. x1000
    - Changed language of launcher

    I have tried literally everything we have thought of and read online, even the fixes to seemingly unrelated problems. I see a lot of people having issues with the launcher and it really feels like the devs are not taking it seriously. They should at least allow Steam users to bypass the launcher until they fix all the problems with it. What a mess, and a disappointment.

  14. #64
    If your nosgoth crash while you click start.Just copy that files to game folder: http://www.opendll.com/index.php?fil...untime-Library and http://www.opendll.com/index.php?fil...ntime-Library# It work for me

  15. #65
    Join Date
    Sep 2013
    Location
    Sweden
    Posts
    581
    Originally Posted by LaveHawk
    If your nosgoth crash while you click start.Just copy that files to game folder: http://www.opendll.com/index.php?fil...untime-Library and http://www.opendll.com/index.php?fil...ntime-Library# It work for me
    what does it do? what am I copying into the game folder?

    (click image to enlarge)

  16. #66
    Join Date
    Feb 2016
    Posts
    1
    Hello all,

    I've been having the same trouble as "SargentLee" from above. When I launch the game this shows up: http://imgur.com/v3cPzk7 . Notice there is no "Log out" button under my name.

    Once I click the "play" button, this happens: http://imgur.com/6ykWOlw . The dreaded Greyed Out button.

    I've tried everything suggested on the first post of this thread, plus:
    -Uninstall/reinstall both Nosgoth and Steam
    -check/uninstall/reinstall C++
    -Reboot everything a MILLION times
    -voodoo rituals to appease the computer Gods
    -crying

    Nothing has worked. Why developers, why? Can someone help?

  17. #67
    Join Date
    Sep 2013
    Location
    Sweden
    Posts
    581
    Originally Posted by Lavamancer
    I got bored and installed X-Com, which also has some prerequisites, these files have fixed Nosgoth...
    I can actually confirm this "fix"
    I had to reinstall everything today when I got another SSD. So when everything was up and running and I tried to launch nosgoth I got the error message "nosgoth have stopped working"
    So I closed everything and installed Xcom2. Having read Lavamancers comment I tried launching nosgoth afterwards and it worked.
    So a 100% fix to launch nosgoth is to install Xcom2 and run the first time installer when it launches.

    (click image to enlarge)

  18. #68
    I counterd a white stuck screen after i launch nosgoth, and the issue was because i used a software which causes to change my proxy settings, so i disabled lan settings from internet explorer and it worked again.

  19. #69
    Join Date
    Feb 2016
    Posts
    1
    Originally Posted by LaveHawk
    If your nosgoth crash while you click start.Just copy that files to game folder: http://www.opendll.com/index.php?fil...untime-Library and http://www.opendll.com/index.php?fil...ntime-Library# It work for me
    Also, unistall all visual c++ completly and install it starting from 2005 both x86 and x64. https://knowledge.autodesk.com/suppo...Libraries.html
    after that if necesary do the "unlink\link" steps. and thats it

  20. #70
    Join Date
    Feb 2016
    Posts
    1
    Originally Posted by Lavamancer
    I got bored and installed X-Com, which also has some prerequisites, these files have fixed Nosgoth...
    worked for me too. Had the same problem, playbutton red, click greyed out, some seconds later playbutton went red again. Installed XCOM Demo after i read your post right from Steam and Nosgoth started after reboot of computer. Thx

  21. #71
    Originally Posted by Yadish
    Hello all

    I've just got a new laptop and nosgoth wont run. I can bring up the launcher fine but when i press the play button it just grays out and doesnt do anything. My launcher also does not show anything related to linking my square enix account. I've tried reinstalling the game numerous times, redownloading the vcredist files, my drivers are completely up to date i dont know what to do.

    For reference here is what the launcher looks like: http://imgur.com/VEhDAg1
    Originally Posted by Koshinger
    worked for me too. Had the same problem, playbutton red, click greyed out, some seconds later playbutton went red again. Installed XCOM Demo after i read your post right from Steam and Nosgoth started after reboot of computer. Thx
    Originally Posted by MasterShuriko
    I can actually confirm this "fix"
    I had to reinstall everything today when I got another SSD. So when everything was up and running and I tried to launch nosgoth I got the error message "nosgoth have stopped working"
    So I closed everything and installed Xcom2. Having read Lavamancers comment I tried launching nosgoth afterwards and it worked.
    So a 100% fix to launch nosgoth is to install Xcom2 and run the first time installer when it launches.
    Originally Posted by Lavamancer
    I got bored and installed X-Com, which also has some prerequisites, these files have fixed Nosgoth...
    Hey guys,

    Which operating system(s) are you running?

    Regards,
    Oghamsmith
    Square Enix Europe Community Manager
    Square Enix Europe Community : Facebook | Twitter | YouTube | Twitch

  22. #72
    Originally Posted by Oghamsmith
    Hey guys,

    Which operating system(s) are you running?

    Regards,
    Oghamsmith
    Windows 10 Home 64 bit

  23. #73
    Join Date
    Sep 2013
    Location
    Sweden
    Posts
    581
    Originally Posted by Oghamsmith
    Hey guys,

    Which operating system(s) are you running?

    Regards,
    Oghamsmith
    Windows 10 64-bit professional.

    On another note.
    I got a friend of mine to try to start nosgoth on his Pc.
    He only got a small window box popping up for less than a second and disappear without anything actually launching.
    What can I do / help him do to fix this so we can play together?

    (click image to enlarge)

  24. #74
    Thanks guys,

    MasterShuriko, having your friend install the files in the following location should fix your issue.
    C:\Program Files (x86)\Steam\steamapps\common\nosgoth\_CommonRedist
    Square Enix Europe Community Manager
    Square Enix Europe Community : Facebook | Twitter | YouTube | Twitch

  25. #75
    Join Date
    Sep 2013
    Location
    Sweden
    Posts
    581
    Originally Posted by Oghamsmith
    Thanks guys,

    MasterShuriko, having your friend install the files in the following location should fix your issue.
    C:\Program Files (x86)\Steam\steamapps\common\nosgoth\_CommonRedist
    Thanks for the reply I just wanna make sure now.
    Shouldnt the game install itself in that location automaticly?
    Could my friend have chosen another install location and thats why this is happening?
    I´ll try talking to him tonight while im at work but Im having issues getting hold of him xD we work 15 hours a day at irregular times atm.

    (click image to enlarge)

Page 3 of 5 First First 12345 Last

Tags for this Thread