Thread: FFXIII on PC - Questions and Issues

FFXIII on PC - Questions and Issues

  1. #26

    Troubles with new patch

    Latest patch (with graphics settings) for PC version broke game for some people - them can't even start playing because of crashes after clicking "Start game" at launcher. Before this patch game was working awesome. Some links:
    http://steamcommunity.com/app/292120...3787350694926/
    http://steamcommunity.com/app/292120...3787345429255/
    http://steamcommunity.com/app/292120...3787339560488/
    P.S. FF XIII-2 has same trouble

  2. #27
    It certainly didn't break it for myself, same goes with 13-2.

    Supplying a DXdiag report should help the port team find the issue.

    A user in the 2nd link posts that it might be the upscale method conflicting with a NVidia driver. Try updating or rolling back the driver.
    Last edited by -Mikfail-; 12th Dec 2014 at 06:09.

  3. #28

    FRAME RATE ISSUES AND MISSING TEXT

    The frame rate in this game is not ANY better since the patch.

    I have an AMD FX 4300 and a Radeon R9280X, not the best in the world but far exceed the recommended specifications. My framerate still chugs along when there is a lot going on and hardly ever scrapes 60fps. It falls into the 20's in battles. Swinging between 20fps and 60fps feels VERY choppy.

    Does anyone else feel that they really need to optimise this game AND XIII-2 so they at least run at 30fps and give us the option to cap the frame rate at either 30fps or 60fps?

    Also, since the patch, when playing at any resolution higher than 720p, the text is missing from the enemy intel screen in battle and the animations on the blue box in the pause screen are also missing, please fix this!

    Can any of the development team hear me here?

    If you can please help!
    "I can help you, if that's what you want."

  4. #29
    I've been having frame rate problems since day one. The only improvement from the new patch is that if I set shadows to 8K the game runs a little better, like with an increase of 2 fps.

    I run at 20 fps pretty much always. Overclocking my CPU helped me achieve 30 fps in some parts and even 60 fps in some cutscenes, but even then the framerate is unstable.

    Also, FF XIII-2 seems to run even worse. I booted up just the very first battle, to not spoil anything since I didn't finish FF XIII yet. I'm getting no more than 18 fps in the first battle.

    Specs:
    FX-8120
    R9 280 3Gb
    8Gb RAM
    Win 8.1

  5. #30
    Originally Posted by Geheimen
    I've been having frame rate problems since day one. The only improvement from the new patch is that if I set shadows to 8K the game runs a little better, like with an increase of 2 fps.

    I run at 20 fps pretty much always. Overclocking my CPU helped me achieve 30 fps in some parts and even 60 fps in some cutscenes, but even then the framerate is unstable.

    Also, FF XIII-2 seems to run even worse. I booted up just the very first battle, to not spoil anything since I didn't finish FF XIII yet. I'm getting no more than 18 fps in the first battle.

    Specs:
    FX-8120
    R9 280 3Gb
    8Gb RAM
    Win 8.1
    This is exactly like my problem, completely erratic, juddering, jumping framerate. Heavily overclocking my CPU makes it slightly more playable but nowhere near acceptable. I can get over 100fps in most other games if I try hard enough but this one can't get out of the 20's.

    We've waited patiently since this game's release two months ago to play it now Square, please keep us in the loop about whether you're going to at least try and fix it
    "I can help you, if that's what you want."

  6. #31
    I haven't been having the frame rate issue as bad as some people from day 1 as I did the Nvidia Control Panel adjustments and was getting a bit more performance, although stuttering was still noticeable.

    Anyways, most of the people I notice having these issue from reading the steam forums seem to be AMD users, so I think Square needs to test the game with those cards and optimize for you guys, or AMD needs to update their drivers.

    So for the missing text on enemy Intel, here's a link to the screenshot of what it looks like when you try to run the game higher than 1280x1024 resolution:

    http://steamcommunity.com//sharedfil.../?id=354704188

    Also can we get the force feed back working in the game please? I am using a wireless Xbox 360 controller for Windows which is very compatible with this feature.

    My Specs:

    i5 3570K intel processor @ 3.4 ghz (stock)

    GTX 760 video card

    8 gigs of ram

    Windows 7 Professional 64 bit

  7. #32
    While I'm happy we got a resolution patch, I'm saddened to say that while there is an option for 2560x1440 the game seems to render improperly.

    And please fix Framerate for us AMD users! (Hd 7970ghz, Intel i5 @ 3.2 ghz, 8gb ram ddr3, windows 8.1 64-bit)

  8. #33
    Can you play this?http://steamcommunity.com/app/292120...3787415474136/
    I have the same problem

  9. #34
    SE please bring back true Full-screen mode as an option.

    With latest patch it was changed to Borderless Full-screen windowed. I assume this was done so you could see the exit dialog when you press esc.

    Without being able to run at Full-screen mode I cannot run a lot of features of my graphics card that require Full-screen mode.
    Examples:
    1. G-sync does not work anymore
    2. Recording video with Nvidia's Shadowplay requires "allow desktop capture" setting check and produces choppy videos.

    Please bring back true Full-screen mode as an option. The trade off to being able to see the exit dialog is not worth it.

    Edit: Found a workaround to enable G-Sync:
    1.windows key+r
    2. type "regedit" and press enter to start it
    3. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Direct3D\Shims\MaximizedWindowedMode
    4. Delete or set to 0 FFXIII path to exe file.

    Now when you run the game G-Sync will be enabled. When you press esc the exit dialog will not be visible, you would need to press y to exit or n to cancel. You have to do this every time you start the game because the exe modifies the registry.
    Last edited by PseudoKite; 8th Jan 2015 at 05:58.

  10. #35
    Originally Posted by x_blade94
    While I'm happy we got a resolution patch, I'm saddened to say that while there is an option for 2560x1440 the game seems to render improperly.

    And please fix Framerate for us AMD users! (Hd 7970ghz, Intel i5 @ 3.2 ghz, 8gb ram ddr3, windows 8.1 64-bit)
    They desperately need to playtest it on an AMD GPU and CPU and takes steps to optimize it accordingly, I'm on AMD and I can't even make myself play the game anymore because the choppiness gives me a headache.
    "I can help you, if that's what you want."

  11. #36
    Latest video drivers and setting setup.xml read-only solve my problem

  12. #37
    https://www.youtube.com/watch?v=eudAywjU2to [720] Gedosato didn't do anything for me but crash my game occasionally.

    http://www.twitch.tv/kanzaki415/c/5670805 [1080] Same thing

    If you can't tell, my spikes are basically whenever a menu pops up in BOTH games. I drop as low as 10 FPS on the load menu or Crystarmium. I have to turn off my mini map in both games or I drop below 30 FPS. My cutscenes and QTE's are perfectly high FPS. I get higher and more stable FPS in Shadow of Mordor and Assassin's Creed Unity (which is poorly optimized.)

    Specs
    EVGA Geforce GTX 670 Superclocked 4gb
    i7 2600k 3.40GHz
    8gb of RAM

  13. #38
    Speaking of menus, I get very low performance on the Crystarium. It gets down to 10 fps in some cases. Also, when I open the options in the main menu, the FPS drops to 20 for a moment and stabilizes in 30 (i guess that's is normal?)

  14. #39
    Temporary fix can be found here (or permanent if they never fix it ):

    http://steamcommunity.com/app/292120...7403571892/#p2

  15. #40

    Unhappy Please fix the FPS and the the bugs when we're running up to 720p

    Square-Enix, please fix the FPS and the resolutions bugs!!

    I'm getting 30FPS lock on battle and on crystarium menu too.

    Also, found out now that those enemies info when you use libra are not appearing when using other resolutions except 1280x720, even when you're looking at enemy intel on the Datalog.

    As you can see on these screenshots:

    1280x720:
    http://cloud-4.steampowered.com/ugc/...261217F9885E2/

    1920x1080:
    http://cloud-4.steampowered.com/ugc/...D95B6836C3FEC/

    The Rating Stars also are kinda buggy, as the lose they shine or something, see the screenshots:

    1280x720:
    http://cloud-2.steampowered.com/ugc/...4180603976CCD/

    1920x1080:
    http://cloud-4.steampowered.com/ugc/...1E6E06EF4931C/

    PC Specs:
    Motherboard: Asus model: P8Z77 V-LX
    CPU: Intel Core i7 3770 3.4 GHz - 4.23GHz Overclocked
    RAM: 8GB 1600 MHz DDR3 Dual Channel Corsair Vengeance
    GPU: NVIDIA Geforce GTX 770 Gigabyte (GV-N770OC-2GD) Currently using Driver 344.75 WHQL
    OS: Windows 7 Ultimate SP1 64 Bits

    Hope this help you guys to fix this.
    Last edited by mike_ptbr; 14th Dec 2014 at 20:21.

  16. #41
    Join Date
    Dec 2014
    Posts
    1

    An easy way to fix Framerate issues ! Please provide us a last patch !!!

    Hello !

    We discovered that the falls of framerate are due to the HUD.
    If you disable the HUD in GedoSato, you have a constant 60fps ! But it's unplayable without an elephant's memory.

    So can we get an ultimate patch to address this simple issue (for XIII-2 too) ?

    Thank you very much !

  17. #42
    Originally Posted by KuroTenshi28
    Hello !

    We discovered that the falls of framerate are due to the HUD.
    If you disable the HUD in GedoSato, you have a constant 60fps ! But it's unplayable without an elephant's memory.

    So can we get an ultimate patch to address this simple issue (for XIII-2 too) ?

    Thank you very much !
    Perhaps an option to change the size or resolution of the HUD so it doesn't suck up so much power?
    "I can help you, if that's what you want."

  18. #43
    Join Date
    Dec 2014
    Posts
    1

    Final Fantasy XIII PC Crashing Every 10 min...

    I have this problem with Final Fantasy XIII PC where the game just crashes to desktop when played for about 10 min haven't timed it but the timing feels perfect, I'm able to pass 2 saves and not long after that it crashes, i can continue the game but it's annoying to have to restart the game all the time to get through it. all i get is "The program is not responding" and the it shuts itself down. no error logs, not a single clue to why it's happening.

    it's not any specific moment it crashes it could be in battle, during cutscene or by moving on outside of battle but after about 10 minutes of playing

    All my drivers are up to date, i have the latest.

    this is my rig:
    CPU: Intel Core i7 3770K 4,5GHz Socket 1155
    GPU: EVGA GTX 980 Super Overclocked
    RAM: Corsair Dominator 2133MHz 8GB
    SSD: OCZ Agility 3 120GB
    HDD: Western Digital Red 3TB x2 (FFXIII is stored on one of these)
    Windows: Windows 8.1, have tried Windows 7 and Windows 10 Tech-Preview too.

    I've tried different fixes suggested on many different forum but it never works and i'm not the only one who still have this problem...
    plz help if possible...

    if you need any more info just ask but this is all i know about the problem

  19. #44

    Nearly 5000 people asking for a performance patch on Steam...

    The thread's here:

    http://steamcommunity.com/app/292120...8693079943510/

    Isn't that pretty much everyone who has the game on PC?

    Everyone on this thread EXCEEDS the recommended specifications but suffer from extreme stutter and framerate drops below 30fps.

    It seems the general consensus is that Square desperately need to try and improve the framerate so it as least 30 and give us an option between a 30frames per second or 60 frames per second cap.

    I know this is certainly what I want, for XIII AND XIII-2.
    "I can help you, if that's what you want."

  20. #45
    FF13-2 IS LITERALLY UNPLAYABLE FOR ME
    https://steamcommunity.com/app/29214...4421198621835/

  21. #46
    I experience the following fps 'flickering' between 30 and 60fps on FFXIII-2.

    http://imgur.com/iR35e1d

    Please remove the 'framepacing' implemented for FFXIII and FFXIII-2.

  22. #47
    That thread was originally created mainly resolution and graphic options. After XIII-2 release and XIII patch in December it was changed to request performance improvements.

    On steam store page SE states 60 fps is supported: "*Maximum supported frame rate: 60fps"
    However, my PC that far exceeds the recommended requirements cannot achieve a consistent 60fps to a point where a locked 30fps looks better.

    SE needs to release a patch just by the fact they support it and in FFXIII-2 current state it's not possible to play at 60fps even if your hardware is high-end.

  23. #48
    Originally Posted by PseudoKite
    That thread was originally created mainly resolution and graphic options. After XIII-2 release and XIII patch in December it was changed to request performance improvements.

    On steam store page SE states 60 fps is supported: "*Maximum supported frame rate: 60fps"
    However, my PC that far exceeds the recommended requirements cannot achieve a consistent 60fps to a point where a locked 30fps looks better.

    SE needs to release a patch just by the fact they support it and in FFXIII-2 current state it's not possible to play at 60fps even if your hardware is high-end.
    Yeah, they really do need to release a patch. The original thread did mention the performance issues as well as the resolution, but thankfully the resolution has been fixed. (Even though now there is a missing text glitch which ALSO needs to be fixed haha.)

    For me the most important issue was always the performace though, I'd rather play a 720p game with a bit of anti aliasing on than a juddery one.
    "I can help you, if that's what you want."

  24. #49
    Join Date
    Dec 2014
    Posts
    1
    I am using an I7 3770 with a gtx 970 and I cannot get a steady frame rate no matter what I do. FFXIII hits 60 sometimes while i'm on the field but as soon as I hit battle it locks down to 30. I tried XIII-2 last night and the frame rates where all over the place to the point where I couldn't keep playing.

    I've been a loyal customer for about 25 years and love the XIII trilogy. I have 100% and Platinum'd the games on 360 and ps3 and was really looking forward to seeing these games at their full potential on pc and have been disappointed ever since XIII was released on steam. Please release a patch to boost performance on these great games. They should not be running so poorly on so many different machines that are more than capable.

  25. #50
    Join Date
    Dec 2014
    Posts
    1
    Hi,

    my box is :
    * Intel Core 2 Duo, 2.33 Ghz
    * NVidia GeForce GTX 580, 1.5 GB
    * Windows 7 SP1 64 bits, 8 GB Ram

    While the CPU is a bit old (thought still meeting the minimum requirements), the video card is exceeding the recommended specs for FFXIII on PC.

    I own more than 250 games on Steam, so I hope you'll trust my experience when I say this game has technical problems. I'm having a framerate between 30 and 60 fps, while ***neither my CPU nor my GPU are used at their maximum*** (I checked with ProcessExplorer). So it's not a bottleneck problem, that's the game engine that is limiting my framerate somehow.

    I did some tests before the December’s patch (with Vsync OFF). I found that the number of monsters present in an area (even if not visible !) was apparently a major factor for framerate drops. I made 5 screenshots : http://paul.siramy.free.fr/ffxiii/monsters_kills_fps/

    I can understand [to a certain point] that the models in the game are very detailed and viewing too many of them at once could explain a performance drops... but honestly, having a 30 fps framerate instead of 60 fps (50 % drop) just because there's 5 monsters that are not even taking 2% of the screen area, it's just plain wrong. In addition, if the number of monsters and/or the % of the screen area they're taking was the problem, then why there is no framerate drop between 5 and 10 monsters ? (30 fps in both cases). Clearly the game engine is at fault.

    As I said, the game is ***not even trying*** to use my hardware as its maximum, so it's is not my hardware who is at fault. The game needs to be fixed. And not by castrating its possibilities to be always 30 fps, but on the contrary by giving it access to the entire power of the available hardware.

    Despite this post, I'm (really!) enjoying the game, just ... not at the fullest that it could have been.

Page 2 of 4 First First 1234 Last

Tags for this Thread