Results 1 to 3 of 3

Thread: Help needed

  1. #1
    Join Date
    Feb 2015
    Posts
    2

    Help needed

    Hi

    I've got a problem. I can't play LoK SR1 on XP, because the site with WinplayFix has expired. Can someone upload it for me and send a link? I would appreciate it very much, because i haven't played it for long time.

  2. #2
    Join Date
    Sep 2007
    Location
    Russia
    Posts
    293
    See on my site. But this patch is already included in the Steam/gog.com version of SR1.
    Support of LOK-games is the duty of Square Enix and Crystal Dynamics.

  3. #3
    Join Date
    Feb 2015
    Posts
    2
    Your patch worked, thanks a lot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •