Thread: DX:IW, Ion Launcher.exe, BLACK SCREEN (i7-4770, GTX 770, Win7x64)

DX:IW, Ion Launcher.exe, BLACK SCREEN (i7-4770, GTX 770, Win7x64)

  1. #1

    Exclamation DX:IW, Ion Launcher.exe, BLACK SCREEN (i7-4770, GTX 770, Win7x64)

    put together a new PC (old mbd died...)
    installed Windows 7 (x64) four days ago.
    updated windows, installed drivers, installed DirectX End-User Runtimes (June 2010), Visual C++ Runtimes for 2005/8/10/12, etc...

    installed Deus Ex Invisible War (Retail DVD version, if that matters).
    Launched game (via dx2.exe), clicked new game from the menu,
    watched intro movie, picked my portrait, clicked done, clicked checkmark to Start Game.

    at this point the screen goes black...
    ALT TAB does not un-focus the black screen/window
    CTRL ALT DEL (or CTRL SHIFT ESC) can open the task manager however it is behind the black screen....
    the only way i got back to the desktop was to use Sysinternals' pstools from another pc to remotely stop "Ion Launcher.exe" & "DX2Main.exe" on my desktop pc...

    The command line for "Ion Launcher.exe" at the black screen is:

    "C:\Program Files (x86)\Deus Ex - Invisible War\System\Ion Launcher.exe" DX2MAIN.exe \\.\DISPLAY1 "dummy" M1_Seattle_Acorp_Lab.gmp?-LoadTravel
    there's only 1 thread in "Ion Launcher.exe" at this time.

    after waiting for a few minutes "Ion Launcher.exe" creates another instance of "DX2Main.exe" (idk if i triggered it with alt tabbing or if it's a time lapse event) with the command line:

    "C:\Program Files (x86)\Deus Ex - Invisible War\System\DX2Main.EXE" -display \\.\DISPLAY1 1600x1200 M1_Seattle_Acorp_Lab.gmp?-LoadTravel
    this second running instance of "DX2Main.exe" has a handful of threads and constantly sits at about 10% CPU usage- all the while the screen stays black and no sound is heard from the speakers...

    i've tried numerous compatibility checkmark options on all three EXEs with no change in observed behavior.

    I've even launched dx2.exe with an affinity of 1 (start /affinity 1 "dx2.exe") which in turn launched the child processes with the single affinity as well... made no difference

    I did capture a Process Monitor trace for the above situation involving those 3 EXEs and can upload it as necessary

    Feels like it's a hardware compatibility issue because I am not having this problem on another PC with the same OS & video driver version (but different CPU and video card).

    The CPU of the affected system is an Intel Core i7-4770.
    the GPU of the affected system is an nVidia GTX 770.

    Also note that other games I've been playing on this system these past 2 days (Arma 2, Battlefield 3) work flawlessly...


  2. #2
    does NOT work on this PC (win7x64 + i7-4770 + GTX 770 + Z87)
    DOES work on the htpc (Win7x64 + E8400 + 9600 GT + G45)
    DOES work on other pc (Win7x64 + Q9550 + GTX 280 + X38)

    above info listed as (OS + CPU + GPU + North Bridge chip)
    feels like a hardware compatibility problem...

  3. #3
    funny... this game worked fine for me for years, then i build a new pc and now it doesn't work... i tried running it again, let it sit there, finally a Viktoria Error window appeared about 3-5 minutes later....

    turns out this is a known issue with the game other people have been having for years that i never got until now, lol, and there's no known 100% working solution...

  4. #4
    *%$#&)*^%#$ Logitech "SetPoint.exe"

    closed "Logitech Keyboard and Mouse" (SetPoint.exe process) and now DX:IW works fine...