Thread: Hitman Launcher will not start/HMA.exe has stopped working [2013 edition]

Hitman Launcher will not start/HMA.exe has stopped working [2013 edition]

  1. #1
    Join Date
    Feb 2013
    Posts
    1

    Hitman Launcher will not start/HMA.exe has stopped working [2013 edition]

    My copy of Hitman Absolution ran absolutely perfectly for about a week until a few days ago when, inexplicably, the launcher will not start and I get this error message window when I try to run it. I am pretty disappointed that the launcher part of the software is this unstable. I have not made any major or minor changes to my system since installing.



    Code:
    Faulting application name: HMA.exe, version: 1.0.446.0, time stamp: 0x50d07b11
    Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
    Exception code: 0xc0000005
    Fault offset: 0x0018e30c
    Faulting process id: 0x11bc
    Faulting application start time: 0x01ce03d839e59948
    Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Hitman Absolution\HMA.exe
    Faulting module path: unknown
    Report Id: 7b12dc32-6fcb-11e2-a1d9-f46d04643b80
    I believe this was the problem some people were having at launch. I have spent many hours googling this issue across some forums and nobody really posts a solution, if it ever went away for them. Maybe it was patched out at one point. I wonder now if a silent patch has re-introduced this as an issue for some people (there are new posts about this problem in the last week or so).

    So, why on earth is it not possible for me to even run the launcher for this game any more, IO? Please post the details of what software the launcher requires so that I can fix this problem and get into the game again.

    I believe BEX when reported here means a buffer overflow problem which is really quite ridiculously bad form. You learn fairly early in coding to mitigate situations where that problem leaks and has to be dealt with by Windows.

    things I have tried: verifying the Hitman Steam cache (it redownloaded HMA.exe, and I keep a copy of that file, but it makes no difference), deleting and restoring the game (not sure if this is equal to a fresh reinstall), disabling a few background services to see if they were interfering, deleting some redistributables installed since, sfc /scannow (no issues).

    things other things people list as a fix that I won't try:
    - adding Hitman to the DEP whitelist. This function is there for a reason and the game ran perfectly previously.
    - Installing new drivers for things. This is a nice cop-out solution that support will often throw out, but again, the game ran absolutely perfectly for a week so I will not risk screwing up my system by installing any drivers.

    my spec: i5 2500k @ 4ghz, 560ti, 8gb RAM, Windows 7 SP1.

    things I installed after Hitman: GTA IV EFLC, Wargame: European Escalation, Alien Swarm. One of these included a 2005 Visual C++ Redist which I uninstalled (no difference), and some from 2012 which I haven't touched. I wonder if the launcher is requiring some particular version of a file which has been changed (though surely newer ones take priority when installers run).

    I have about a dozen .mdmp files in the Hitman directory as well as the Windows error files if they can be any use to anyone at IO to finding the cause of this problem.

    I would dearly like to get this sorted out.

    --

    I encourage anyone else having this particular 'launcher will not start' issue to post their details in this thread and maybe we can get to the cause.

  2. #2
    If your game worked absolutely fine previously and now it doesn't, then I would take a look at what has changed on your system. You have mentioned that you haven't made any changes to your system, but if the game worked previously and now no longer does then something has to have changed. The last update for the game was on the 21st, so unless the issue started happening over 2 weeks before your post, that probably isn't the issue.

    The most likely thing would be a software update that has happened in the background such as a windows update or security software update.

  3. #3
    and this is my probléééém