Page 2 of 2 First First 12

Thread: Mog doesnt come with me in a dying world?

Mog doesnt come with me in a dying world?

  1. #26

    @Davpoulln: That's a shame. I'll post here if I find a solution; but at this point I fear 36 hours have been wasted. And I am not too keen on restarting and risk the same bug happening again.

    @Chaos_Martin: Thanks. I've only heard of the bug on 360, but no one seems to have posted a solution yet that I am aware of.

  2. #27

    I have one question for you guys.

  3. #28

    I have one question for you guys. And you guess it, I'm trying my best to help you out.

    Since I don't own a Xbox 360 system, do you originally have the game disc? Or it is installed inside your Xbox HD?

  4. #29

    @YoshiKatYoko: Thanks for trying to help. I have the original game disc and I am playing from it.

    My educated guess would be that a flag value has been improperly set, and that unless there is some way of resetting or altering that value, we're basically screwed.

  5. #30

    I've tried the Genesis save editor now and used its option to unlock all the timelines, but the game still won't let me progress. Dying World 700 is completely changed, but I am unable to use the exit gate and the Historia Crux still only contains Serendipity, Dying World and Colisseum. So that did not resolve the issue, as I am unable to progress. Fortunately I still have the save file intact before I started messing around with it; so I would still welcome any help people here can offer on the Mog issue!

  6. #31

    these Japanese players was also asking for help to solve this bug in a Dying World. they took a video of it on youtube. so a couple people do have this bug.

  7. #32

    Has anyone find a solution to this bug? I ran unto the same problem and have not found a fix online.

  8. #33
    i am on 700 af after the conversation with Caius and Joel. I need to reveal Joel with Mog but he is stuck at the entrace where all the ghost people are at. I can activate his reveal move there but he won't move so I cannot progress with the game. I cannot throw him at this point in the game and I don't have a previous save file to revert to because the game autosaves.

    I have tried cleaning the disk. Installing it to the hard drive (xbox 360). Going to a new world (Serendipity). However none of that has worked. If anyone knows a fix for this let me know. I planned on buying the next final fantasy game after xiii and xiii-2 but that will no longer be the case if they let a bug this serious slide.

  9. #34
    Join Date
    Mar 2008
    The Lifestream

    Submit a report of your issue to [FINAL FANTASY XIII-2 Customer Service]

  10. #35

    Bump. Any update on how to fix this? I would really like to finish the game before the next one comes out.

  11. #36
    Join Date
    Feb 2014
    Argh. I've just experienced this exact same bug, and after an hour of Googling and now coming to this thread, it seems there indeed remains no fix. Incredibly frustrating, because there's no way I'm going to start this game from the beginning. How could a bug that literally and irrevocably breaks the game go unaddressed by Square Enix for this long? Totally irresponsible, and also guarantees I won't be purchasing Lightning Returns.

  12. #37
    If I remember rightly, dying world is near the end, I don't think Mog is supposed to come with you, I have my reasons behind this but I don't want to say as they are spoilers possibly.

  13. #38
    Originally Posted by Captainshiny
    If I remember rightly, dying world is near the end, I don't think Mog is supposed to come with you, I have my reasons behind this but I don't want to say as they are spoilers possibly.
    Seeing as I haven't finished the game yet, thanks for keeping out spoilers!

    Anyway, the bug they're talking about takes place in the story before that (or possibly after depending on what you're talking about).It occurs after you leave Serah's dream version of New Bodhum following the conversation with Vanille and Fang. The only three places you can get to on the timeline at this point are Serendipity, The Coliseum, and A Dying World.

    After the cutscene in which Noel talks to Caius about not wanting to kill him and replace him, you enter a small village filled with red sillouetes of people. At this point Mog, who disappeared during the events of the dream New Bodhum, rejoins Serah, albeit in a shimmering spectral-esque form, and resumes following her around. At this point you need to use his bobble ability to change the sillouttes back to normal (or so I'm assuming; as of writing this I haven't finished this section of the story).

    The problem is, Mog will randomly stop following Serah and make like Star Fox 64 and start doing a non-stop barrel roll. You CANNOT throw him at this point, and his bobble may or may not work as well. At this point you NEED Mog to follow you to continue the story as he's the only way you can change the sillouettes. Entering Serendipity or The Coliseum won't fix this issue as the game basically saves whatever your last state was upon leaving any timeline location. This means Serah and Mog will both be exactly where they left off upon returning to A Dying World, still doing whatever they were doing before you left.

    As far as I can tell, the only way to revert this issue is to reload an older save...though many people likely don't have another save since the game autosaves. With no fix here in 2014, it's a safe bet there isn't one coming, so if this happens to someone who doesn't have an old save...they're out of luck...

    For anyone who's reading this before they get to this point in the game for whatever reason; CREATE A NEW SAVE BEFORE ENTERING A DYING WORLD! You can do this by pressing "X" (square on PS3) while on the timeline screen. This will bring up the save menu, and to the far left there will be the option to create New Save Data.

    What's ironic about this is that this isn't the first time a game breaking bug has occurred (Final Fantasy VIII spoilers incoming); in Final Fantasy VIII, which has a very similar futuristic style, it was possible to park the Garden on a certain island on the world map in such a way that it was impossible for the player to get back into it leaving them stranded on the island with no way to escape. Just like the case in XIII-2, if you saved while on the island and didn't keep an older save, you couldn't continue the story.

    I'm a huge Square fan, and Final Fantasy ranks as one of my most cherished series, but even I have to say this is absolutely disgusting. In FFVIII it was somewhat understandable since there was literally no way to address the issue back then short of re-releasin the game with the bug fixed. But now, when this problem could easily be fixed by a patch download? Poor form Square, very poor form...

  14. #39
    Join Date
    Apr 2014
    OMG .... this JUST happened to me ... and i im soooooooo mad right now... after reading this and finding out that theres no way to fix it and there isnt a update to fix it 65+ hours DOWN THE DRAIN Because SQUARE ENIX cant be bothered to fix it, thats beyond DISGUSTING ...
    and to top it off this topic was started in 2012 well its NOW 2014 AND YOU STILL HAVENT FIXED IT!!!!!

    158 Fragments out of 160 .... all i had to was finish the Bestiary and do The Dying World Parradox Ending ... then that happened .... so i think you can get the idea how F'ED OFF I Am Right Now ... there now way im starting a new game!

    this is the first glitch i had in final fantasy 13-2 ... and its a big one ... and sooo far into the game ive had no need to create another save file, so im now stuck.. Big Time.... as you need moogle to follow you so u can moogle hunt noel
    but moogle wont move from the entrance of the village, does bobble up and down and u can use moogle hunt, but it doesnt effect anything, because its not near anything!!!

    and also i dont think ive ever had a update for final fantasy 13-2 ive had this game since it came out i even payed £50 because i pre-ordered it for XBOX 360, but i stopped playing it and it start again until Jan 2014 because Lightning Returns was coming out ..... funny enough i only bought Lightning Returns a couple of week ago, but i wanted to finish everything in 13-2, which i dont think thats going to happen ....sooooooo first thing tomorrow im sending back Lighting Returns and getting my £40 back!!! So Basically You've Ruined A Game For Me ... And Any Future Games... And Possibly A Fan

    other games ive played by different companys (assissan's creed) have had big glitches and a simple update has fixed it....

    There's People Here With A Problem With The Game, That Can Be Fixed With An Update, But There's Isnt One .... so why isnt there an update for it???
    Last edited by Laurac21; 15th Apr 2014 at 23:09.

  15. #40
    Seems like those having this issue might have went too far ahead before fixing other pathways, From what I have digested, sounds like all you can do is start from scratch, venture other areas before hitting the C5 marker, And like some have said, be sure to make two game saves, one your main, and the second your backup,

Page 2 of 2 First First 12