Thread: STUTTERING & LAG / FRAME RATE Drop - Video & Audio - All Discussion

STUTTERING & LAG / FRAME RATE Drop - Video & Audio - All Discussion

  1. #1051
    Thanks for the advice Herbert, but I'm pretty sure that it's not an incarnation of the 59Hz bug that affects some games.

  2. #1052
    Originally Posted by El Zoido
    Thanks for the advice Herbert, but I'm pretty sure that it's not an incarnation of the 59Hz bug that affects some games.
    It doesn't have to be 59. It can be 60. I just suggested 59 because it helps with lag as well.

  3. #1053
    Well, setting it to 59 Hz helps in some games (e.g. some Gamebryo games like Fallout 3 or Skyrim), so the advice isn't bad. I just doubt that it's the reason for the stuttering in DXHR.
    I tried using external frame-rate limiters, but without much success, unfortunately.
    As I have written, strangely restarting the game sometimes fixes it.


    Ok, who would have thought it...

    I have tested Herbert Dashwoods idea and it seems to work - I have restarted the game multiple times and indeed had no stutter when enabling the FPS limiting within NVidia Inspector. When disabling the option, the stutter was back.
    Using 59fps gives pretty smooth visuals, but screen-tearing, 60fps is less smooth (just a little bit, still no stutter), but without tearing...

    I do wonder though if that is a permanent fix, since I first had stuttering after the latest patch, it always came back eventually...

  4. #1054
    Yes the good old frame rate limiter fix works but does not eliminate all stuttering. It is huge help anyway.
    I've tried alt+enter "fix", when the game is stuttering then alt+enter go to the window mode and back to fullscreen. Not sure it helps, but thats what I'm experimenting now. I know, desperate..

  5. #1055
    I guess you will always have a little bit of stutter when the game is loading textures/objects/etc. in the background, esp. when you reach certain points where the engine seems to load the next "part" of the level.
    But that, for me at least, is no big deal - it doesn't take long and happens not very often.

  6. #1056
    Join Date
    Dec 2007
    Location
    The highest ground...
    Posts
    23,047
    Originally Posted by Herbert Dashwood
    This might fix it. It fixed my studdering in Age of Empires 3 and The Witcher.

    For nvidia users, download the nvidia inspector program if you haven't already.

    There should be a profole for Deus Ex: Human Revolution.

    Set Triple Buffering to On
    Set V-Sync to On
    And here's what might do it:
    Set the frame rate limiter to 60fps.

    This removed my stutter/frame skipping in the first two games I mentioned and might also work for this game.

    For anyone that doesn't have a fix, try this out and see if it works.

    Many thanks. Added to first page updates.
    signature image
    You are only minimally modified. Omar can help you correct this...

  7. #1057
    Join Date
    May 2012
    Posts
    3
    Thx. for find, frame rate limiter in Nvidia Inspector works same like in MSI Afterburn. But drawback is that now I got huge frame drops, from like 40 FPS (outdoors) to 18-20 FPS on moments, so I need to lower settings some more.

  8. #1058
    Originally Posted by zokocx
    Thx. for find, frame rate limiter in Nvidia Inspector works same like in MSI Afterburn. But drawback is that now I got huge frame drops, from like 40 FPS (outdoors) to 18-20 FPS on moments, so I need to lower settings some more.
    Limiting framerate should not affect overall performance at all. It just limits the framerate without performance cost.

  9. #1059
    god this is shameful

  10. #1060
    Join Date
    May 2012
    Posts
    3
    Originally Posted by MrMicroship
    Limiting framerate should not affect overall performance at all. It just limits the framerate without performance cost.
    Well in my case it's happening, framedrops are still in same situations but few FPS more (2-4).

  11. #1061
    After a truly insane amount of time spent on the stuttering issue, I have finally found a proper fix. I hope someone can add this to the OP if others find it works for them.

    My specs:
    Core i5-750 (default clocks, Turbo Boost enabled)
    GTX 560 (default clocks, official 301.24 beta drivers)
    4Gb RAM
    7200rpm SATAII HDD (AHCI)
    Vista Home Basic

    I've played around in both DX9 and DX11 mode and found that frame rate limiters and/or max frames rendered ahead set to 1 and/or various Vsync and TB settings can greatly reduce microstutters, but to completely fix them and get silky smooth buttery stuff you don't need any of that! You just have to use DX11 mode (VSync enabled) and edit the registry. In the HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR folder, set D3D11_CREATE_DEVICE_PREVENT_INTERNAL_THREADING_OPTIMIZATIONS to 1. Done.

  12. #1062
    Join Date
    May 2012
    Posts
    1
    2onelifecrisis:

    Thank you man! Only your solution helped me with the game! Afterburber fps limiter didnt help me.

  13. #1063
    Hey I cant seem to find the file on my computer to try what your suggesting please tell me were it might be.When I bought the game I had to use steam when I downloaded the game.

  14. #1064
    Join Date
    Sep 2011
    Posts
    21
    After a truly insane amount of time spent on the stuttering issue, I have finally found a proper fix. I hope someone can add this to the OP if others find it works for them.

    My specs:
    Core i5-750 (default clocks, Turbo Boost enabled)
    GTX 560 (default clocks, official 301.24 beta drivers)
    4Gb RAM
    7200rpm SATAII HDD (AHCI)
    Vista Home Basic

    I've played around in both DX9 and DX11 mode and found that frame rate limiters and/or max frames rendered ahead set to 1 and/or various Vsync and TB settings can greatly reduce microstutters, but to completely fix them and get silky smooth buttery stuff you don't need any of that! You just have to use DX11 mode (VSync enabled) and edit the registry. In the HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR folder, set D3D11_CREATE_DEVICE_PREVENT_INTERNAL_THREADING_OPTIMIZATIONS to 1. Done.
    Amazing! That fixed it entirely! I'm getting absolutely no stuttering now. I can hardly believe how smooth it's running.

    Originally Posted by Scifislasher
    Hey I cant seem to find the file on my computer to try what your suggesting please tell me were it might be.When I bought the game I had to use steam when I downloaded the game.
    It's a registry setting. Here's some instructions on making registry modifications:

    http://support.microsoft.com/kb/136393

    EDIT: I added instructions (along with pictures) on how to do it on my blog:

    http://ineveraskedforthis.net/fixing...on-stuttering/

  15. #1065
    Thanks for the information but it seem it fix one part and made more stuttering.Like my main thing was with the cinemamatic parts in the game those parts were what I was trying to fixs.While this did work for me a little it made more stuttering for me like when I'm walking around at the begining of the game.

  16. #1066
    Unbelievably, DX:HR seems to just have recieved an update, claiming fixes for the Shuttle bug, stuttering, and other stuff. Hope it helps some of the people that have trouble.

    Edit: No stutter so far (even after removing the stutter fix suggested by HD), SSAO on normal is less noisy, but I still get strange vertical lines associated with it (as before, they are bearable, though).

  17. #1067
    dx9 stutter when you first discover areas is still there for me, after that its much less frequent so far*.
    but its there, so needs more fine tuning.

    im surprised about the patch but also disappointed.
    still no fix for misplaced muzzle flash on higher FOV,i mean how hard would it be to fix this?i cant believe they haven't notice this yet...

  18. #1068
    Originally Posted by notsoangry
    dx9 stutter when you first discover areas is still there for me, after that its much less frequent so far
    Well, I get a few seconds of stuttering, too, when entering a new area/loading a game (DX11).
    I think it's simply background-loading going on and probably cannot be helped, but as it's over in a couple of seconds, I don't consider it a big issue.

  19. #1069
    Well, tentatively speaking, this update seems to have fixed the stuttering, or at least had a much bigger impact than the previous updates that were supposed to have improved the problem. They may have finally succeeded here. Unfortunately it took them 9 months.

  20. #1070
    I never would have thought they would still fix this after 9 months.
    Anyway the game is smooth as butter now om my PC.

    They should have optimized the game before releasing it, just ported it over from the consoles without any PC optimizations. I would have rather waited a few weeks or months longer if they put these fixes in there from the beginning.

    But still I'm very thankful Eidos still fixed it

  21. #1071
    Perhaps I spoke too soon, because coming back to it today I'm experiencing a new issue. The first time I played after the latest patch it was fine, smooth and stutter free in DX 11 mode. Now today I start the game up and I can't get more than 5 FPS. Not just in the game proper but right from the opening screens it has this atrociously low frame rate.

    So I switch to DX 9. I find that in DX 9 the stuttering is as bad as it ever was, so I've gotta get it running in DX 11, which it was doing just fine for a brief time yesterday. After an hour or two of experimentation I've found that it runs smooth and stutter free at a solid 60 FPS in DX 11...but only in windowed mode. If I switch to fullscreen the FPS takes a dive back down to the single digits.

    Anybody experience this or have any idea how to fix it? I'm on the verge of maybe being able to finally play this game, so any help would be much appreciated.

  22. #1072
    Is it still there after restart (preferably PC, too)?
    So far my game worked nice (although I got one CTD, which is only the second or third ever with DX:HR) through several sessions, but there's a topic from another user encountering similar problems with performance.

  23. #1073
    Well,after the new patch my game runs smooth as butter.

    I only signed up to the forums because of the stuttering issue,and i did not expect a fix so far down the line.So a big thanks to eidos/nixxes.

    I have no reason to come back here,unless another patch breaks the game again or hitman absolution is a steaming pile.

  24. #1074
    Originally Posted by onelifecrisis
    After a truly insane amount of time spent on the stuttering issue, I have finally found a proper fix. I hope someone can add this to the OP if others find it works for them.

    My specs:
    Core i5-750 (default clocks, Turbo Boost enabled)
    GTX 560 (default clocks, official 301.24 beta drivers)
    4Gb RAM
    7200rpm SATAII HDD (AHCI)
    Vista Home Basic

    I've played around in both DX9 and DX11 mode and found that frame rate limiters and/or max frames rendered ahead set to 1 and/or various Vsync and TB settings can greatly reduce microstutters, but to completely fix them and get silky smooth buttery stuff you don't need any of that! You just have to use DX11 mode (VSync enabled) and edit the registry. In the HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR folder, set D3D11_CREATE_DEVICE_PREVENT_INTERNAL_THREADING_OPTIMIZATIONS to 1. Done.
    OMG big thanks !! After the patch my game was stuttering as hell. But now with your fix the game is running like a charm !

  25. #1075
    I spoke too soon.

    After playing for 2 hours straight last night,the game crashed to the desktop.Funnily enough it was just as i was walking towards the basketball courts.

    Im using the latest drivers,so i know thats not the problem,and the game did not throw up any errors either....only that deus ex had stopped working.

    Will i ever complete this game? Doubt it.

    Tryed again,and the game crashes on the exact same area.Not good.

Page 43 of 44 First First ... 33394041424344 Last