Page 3 of 3 First First 123

Thread: Game freezes after minutes or even seconds

Game freezes after minutes or even seconds

  1. #51
    same thing everytime on mission black gold but it froze up alot before that on my pc
    whats the deal eidos?
    every other game i own works fine besides this
    its a great game but needs to be fixed fast

    windows 7 64 bit
    evga x58 classified
    intel i7 920@3.25---corsair H50
    6gb corsair dominators
    bfg 1000 watt psu
    1tb western digital
    3 bfg gtx 260 max cores

    all drivers are current....

  2. #52
    Same deal here, happens after a couple of minutes with sound/game continuing in background before fully crashing.

    I tried Directx redistributables, vc++ runtimes, reinstalling videocard drivers, DirectX SDK redistributable, E V E R Y T H I N G, no dice on fixing it. Makes the game 100% unplayable... didn't happen with 1.0.0 demo but happens with 1.0.1 retail game installed/activated on Steam from newegg.

    I cannot revert drivers to play around since I am on a GTX 470 which only has one publicly released set (197.41).

    SYSTEM:

    Win7 HP 64-bit
    i7 920
    Asus X58 P6T motherboard
    eVGA GTX 470
    256GB SSD
    6GB DDR3
    2560x1600 resolution, 197.41 drivers

    Happens both stock-clocked and overclocked. Please forward this to the devs, it is not just an end-user issue, and needs to be fixed... I can't even enjoy the game now due to it.

  3. #53
    Join Date
    Apr 2010
    Posts
    2
    Help random slow downs then accelerations out of nowhere even at the lowest settings i will get smooth frames then slow down then accelerate back to smooth, the cycle never ends. HELP

  4. #54
    When I first got the game I had a similar issue ... randomly the game would freeze and drop back to desktop with the game sounds still running ... Task Manager saying the game wasn't responding.
    Here is what fixed it for me ... just in case it helps others.

    I noticed the Bokeh filter shows in the settings and works fine with SLi turned off but it doesn't show in the settings at all when SLi is is enabled (and doesn't work in the game either)
    So I wondered ... as I had it turned on even though I was now running SLi and so it wasn't showing in the game settings menu ... is this the cause of the crashing?

    I disabled SLi ... turned off the Bokeh filter in the game ... saved the settings.
    Enabled SLi ... ran the game ... no freezes or crashes and I'm now 80+ hours on from there and I've had zero freezes or crashes.

    I have everything set at MAX apart from Shadow Quality which is on medium (looks better than high ... ) and 4x AA.

    My system specs are in my sig.
    I am running with a few mods including my skin ... Ghost-Rico


    I know not everyone here is running SLi and so I'm not saying this is "THE" solution but I hope it helps some.

    -----------------------------------------------------------

    Awesome game ...
    Thank you ... Avalanche & Eidos !
    i7 • X58 • 2 480's • 12GB DDR 3 • 150GB VelociRaptor • 1TB • 1000W • X-Fi • FX5051 • TJ07B • TH2G-D • 3 x Dell 2405 FPW

  5. #55
    Originally Posted by Paddywak
    When I first got the game I had a similar issue ... randomly the game would freeze and drop back to desktop with the game sounds still running ... Task Manager saying the game wasn't responding.
    Here is what fixed it for me ... just in case it helps others.

    I noticed the Bokeh filter shows in the settings and works fine with SLi turned off but it doesn't show in the settings at all when SLi is is enabled (and doesn't work in the game either)
    So I wondered ... as I had it turned on even though I was now running SLi and so it wasn't showing in the game settings menu ... is this the cause of the crashing?

    I disabled SLi ... turned off the Bokeh filter in the game ... saved the settings.
    Enabled SLi ... ran the game ... no freezes or crashes and I'm now 80+ hours on from there and I've had zero freezes or crashes.

    I have everything set at MAX apart from Shadow Quality which is on medium (looks better than high ... ) and 4x AA.

    My system specs are in my sig.
    I am running with a few mods including my skin ... Ghost-Rico


    I know not everyone here is running SLi and so I'm not saying this is "THE" solution but I hope it helps some.

    -----------------------------------------------------------

    Awesome game ...
    Thank you ... Avalanche & Eidos !
    I disabled that filter (Bokeh) and it let me run for about 20 minutes before doing the same thing with the game-continues-with-sound-but-black-screen-to-desktop crash... .

  6. #56
    I kinda meant it maybe a fix for SLi users ... because of the Bokeh filter not showing in SLi for whatever reason.
    I didn't mean to suggest it was the Bokeh filter per se.

    Sorry it didn't help you.
    i7 • X58 • 2 480's • 12GB DDR 3 • 150GB VelociRaptor • 1TB • 1000W • X-Fi • FX5051 • TJ07B • TH2G-D • 3 x Dell 2405 FPW

  7. #57
    Oh yeah, I just was posting to say that it seemingly helped my non-SLI setup, too . Before I could only stay in for maybe 2-3 minutes.

  8. #58
    I have a similar problem, but the screen looks like its shattered and carries over to windows.


  9. #59
    Join Date
    Apr 2010
    Posts
    12
    Maybe your not using this at all, but on my pc Xfire caused the freezes. So i temporary turned it off.

  10. #60
    Howdy people. I have sidestepped the issue.
    I went and got a ati 5870 and while i get a little bit of performance loss when compared to my gtx285 i can now play this game for hours on end.


    looks like i had a defective card.

  11. #61
    Originally Posted by Fkabbz
    Help random slow downs then accelerations out of nowhere even at the lowest settings i will get smooth frames then slow down then accelerate back to smooth, the cycle never ends. HELP
    Gidday.

    This may be obvious, but do you have AV software running? I normally pause mine when gaming as it causes exactly that issue.


    Originally Posted by aZmoDen
    Howdy people. I have sidestepped the issue.
    I went and got a ati 5870 and while i get a little bit of performance loss when compared to my gtx285 i can now play this game for hours on end.


    looks like i had a defective card.
    Nice. Mine seems to have randomly sorted itself out - I noticed the game updated itself the other day, although the ver no is still 1.0.0.1

    Cheers.

  12. #62
    I'm not sure how useful this is, but I had the same issue here - perfect gameplay for days, then suddenly graphics freezing after several minutes, with the sound continuing in the background, every time I played. This happened after I changed the advanced graphics settings, and wasn't resolved by updating graphics drivers, rebooting or anything obvious.

    I *think* I may have fixed my problem though - I just had a couple of hours without any problem, and did last night too. I assumed that in changing the advanced settings I had corrupted the settings file, or enabled a setting which my card didn't like, although restoring the defaults didn't work.

    What seems like it might have worked is going into the folder: My Documents\Square Enix\Just Cause 2\Saves and renaming both files in there, JC2Settings and Settings, to JCSettings.bak and Settings.bak (i.e. deleting them). When I next ran the game, the JC2Settings file got recreated, but not the Settings file. Since then, fingers crossed, it has worked ok again. Doing this doesn't seem to have affected where I was up to in the game.

  13. #63
    You might wanna try these workarounds too;

    • Disable the Bokeh Filter in Options - Advanced Display Settings.
    • Disable the GPU Water Simulation in Options - Advanced Display Settings.
    • Set the CPU Affinity to 1 Core, using the Task Manager. (JC2 Process).

    Setting the Affinity to 1 Core may solve the freezing, but will drastically lower your Performance. Why it fixes the freezing for some people is currently unknown to me.

    Hope it helped,
    Dealman.

  14. #64
    This is a Big Problem everything is up to date on my system and it still crash i play Blur Race game for 20 Hrs and did not crash then today try to play justcause2 and crash 4 times with in 1hr the Game Crash not the PC the PC is fine play all other game with no problem .........This is s Good Game but the Bugs have to go............

  15. #65
    I smell a Class Action on this if they don't fix

  16. #66

    Unhappy Same error

    Same error for me... I used to be fine though... was up to 60 hours of gametime without a single issue and then upgraded from a Core2 duo to an i7 930 ... new Mobo and RAM but the same GTX480 video card (and driver) and now it crashes randomly.. sometimes it takes 30 seconds...sometimes 30 minutes. This was my favourite game prior to the upgrade and now its just too frustrating to play

    I have tried:

    1. Renaming the JKSettings file
    2. Latest BIOS update
    3. Remove/reinstall video card drivers
    4. Install the beastly 567mb DirectX SDK
    5. Monitored CPU and GPU temps - both normal

    Im considering deleting the local content and downloading the game in steam again but that seems like a huge waste of my monthly bandwidth if its not going to make a difference..

    Come on Eidos - throw me a bone... what else can I try?

    <<<UPDATE>>

    Problem has been fixed - Im not too sure exactly what fixed the issue as I tried a number of things at once but here are the steps I took to resolve my crashing issue

    1. Deleted the local client files in Steam and downloaded/installed again (potentially had corrupt files after installing the game from a steam backup after my hardware upgrade?)
    2. Turned off Vertical Sync (probably not the problem as I used to have this on before my upgrade)
    3. Slowed down the timings for my RAM in the bios - well... set them from what they are supposed to be to "Auto" - I think this was probably the culprit

    Not only am I running stable again but I am now able to turn on all the bells and whistles to full - it just looks freakin'amazing - my favourite game again.

    My apologies to Eidos for pointing fingers when it turns out it was my fault. Lets kiss and make up and if you throw Joystick/Rudder support into the game I'll have your babies....Sweet little grappling hook babies...Mmmmmm

  17. #67

    Exclamation BIOS update worked for me!

    Hey guys,
    I had similar problem. The game froze my whole PC just seconds after loading any save game. I updated every driver and stuff but nothing worked. Until I eventually updated my MSI BIOS (from 3.1 to 3.4) and the motherboard driver as well.
    The game works perfectly now, even on highest graphics.
    Give it a try, but you know... be carefully with your BIOS


  18. #68
    Join Date
    Aug 2010
    Posts
    2
    I have the same fcking problem, and its really anoying. So if anyone can help out.
    I have tried everything.

    These are the specs:
    Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7600) (7600.win7_gdr.100226-1909)
    Processor: Pentium(R) Dual-Core CPU E6300 @ 2.80GHz (2 CPUs), ~2.8GHz
    Memory: 2048MB RAM
    Available OS Memory: 2048MB RAM
    Page File: 1037MB used, 3056MB available

    DirectX Version: DirectX 11

    ---------------
    Display Devices
    ---------------
    Card name: NVIDIA GeForce 9800 GT
    Manufacturer: NVIDIA
    Chip type: GeForce 9800 GT
    DAC type: Integrated RAMDAC

    Display Memory: 1267 MB
    Dedicated Memory: 499 MB
    Shared Memory: 767 MB
    Current Mode: 1280 x 1024 (32 bit) (60Hz)
    Monitor Name: Generic PnP Monitor
    Monitor Model: Acer AL1716
    Monitor Id: ACRAD51
    Native Mode: 1280 x 1024(p) (60.020Hz)
    Output Type: HD15

    Driver File Version: 8.17.0012.5896 (English)
    Driver Version: 8.17.12.5896
    DDI Version: 10
    Driver Model: WDDM 1.1
    Driver Attributes: Final Retail
    Driver Date/Size: 7/10/2010 00:37:00, 9818728 bytes

  19. #69
    same problem is here..Eidos should fix this

  20. #70
    Originally Posted by GoldenTiger
    Same deal here, happens after a couple of minutes with sound/game continuing in background before fully crashing.

    I tried Directx redistributables, vc++ runtimes, reinstalling videocard drivers, DirectX SDK redistributable, E V E R Y T H I N G, no dice on fixing it. Makes the game 100% unplayable... didn't happen with 1.0.0 demo but happens with 1.0.1 retail game installed/activated on Steam from newegg.

    I cannot revert drivers to play around since I am on a GTX 470 which only has one publicly released set (197.41).

    SYSTEM:

    Win7 HP 64-bit
    i7 920
    Asus X58 P6T motherboard
    eVGA GTX 470
    256GB SSD
    6GB DDR3
    2560x1600 resolution, 197.41 drivers

    Happens both stock-clocked and overclocked. Please forward this to the devs, it is not just an end-user issue, and needs to be fixed... I can't even enjoy the game now due to it.
    I have the same problems with Steam. I can't even install the game. After a few seconds the game runs my laptop is getting freeze. Sorry for my bad english^^

  21. #71
    Apparently the cause of this issue is something to do with the hyperthreading, however most fixes I've found mean you have to edit some INF file (and if you get it from steam there is none) or setting affinity EVERY SINGLE TIME. However, You can EASILY fix this bug by simply going to the Nvidia Control Panel, and were it says "CUDA - GPUs" turn it off.

    *FOR THOSE OF YOU WITH ATI GRAPHICS CARDS*


    while my fix doesn't help you guys out much I will make it very clear

    THIS IS A HYPER THREADING ISSUE, NOT A DRIVER ISSUE (although I suppose they could set the driver to turn this off automatically.....)

    I don't have an ati graphics card to test on but I'm assuming you can turn this off somehow in catalyst control center

    however the only other way I know of to fix this (that actually works) is to set affinity in processes to only the even number processors (0, 2, 4, 6, etc)


    I find it odd Eidos Has not addressed this and yet an 18 year old with half an Associates Degree in Computer Information systems did............


    AHEM anyways for reference here is the picture



    So for those of you with an Nvidia Driver, That's how to fix it -_-

  22. #72
    Hey, why no more replies after Z3R0115 last message ? Is that the solution ?!? Tomorrow I'm trying this out ! Thanks !

  23. #73
    Originally Posted by Z3R0115
    Apparently the cause of this issue is something to do with the hyperthreading, however most fixes I've found mean you have to edit some INF file (and if you get it from steam there is none) or setting affinity EVERY SINGLE TIME. However, You can EASILY fix this bug by simply going to the Nvidia Control Panel, and were it says "CUDA - GPUs" turn it off.
    .........../cut/.......
    So yes ! That fixed it ! GREAT !!!
    I don't understand why nobody replied after you wrote this , very strange.
    I will paste the URL of this thread in steam community forums to tell other guys that are still facing the problem !
    Thanks very much !
    Alex

Page 3 of 3 First First 123