Page 3 of 3 First First 123

Thread: Not enough storage is available to complete this operation

Not enough storage is available to complete this operation

  1. #51
    A few months ago the game worked fine on my computer.
    I don't have 3 GB RAM but I had no problem with 2 GB.
    I played a few weeks and erased it.

    Today I tried to play it again.
    No matter what I do I receive the same message ("Not enough storage...")
    3 differences since last time it worked:
    1. 160 GB HDD changed with 500 GB.
    2. I just installed Windows 7 x86 with latest updates included (mine, not from internet).
    3. Newer drivers.

    DirectX log:

    Does anybody have a (good) solution..?

  2. #52

    Big Grin Fix

    sorry if this has already been fixed but i had this same issue with TF2, to fix it i used steam to make a backup of all my games and then uni-stall steam and then use a registry cleaner to remove all the rest of the reg keys and then re-install and restore the backup.

    Hope This Helps

  3. #53
    I found why is not not working well on my OS.
    Because System Restore is 100% removed (not just deactivated).

    I have 2 rhetorical questions:
    1. What do Just Cause 2 need from System Restore...? To make a backup..?
    2. Why not use a code that tries to get informations from System Restore and, if fails in any way, to continue normal running..?
    What the programmers did is like programming a robot to park the car but without "telling" it to check if my house HAS a garage, so it doesn't try to brake the walls in the place where it knows the garage suppose to be
    These days more and more computer users modify their OS's. In some cases it will be their fault that the game is not running but not all the time.
    But I guess always will be some programmers who will say: "just install normal OS, I don't have time and resources to make my code to check for everything, I'm not payed more for this...".

  4. #54

    how i sort've fixed the issue

    hey guys,
    i had the same error message, and then what i did to remove the problem was in steam i 'verified' the program.
    Then once it was finished, i realised that it updated another 18 or so meg, then when i opened it, it didnt show the same error..

    but the 'need a new version of windows'

    so its a game i have for my next pc...

    hope verifying works for you guys. (usually if the problem didnt get solved, it would be still saying the same error message, but it didnt. so my conclusion is that its fixed.)

  5. #55
    After dozens of tests, I found another 2 components which, if they are removed completely from Windows 7 DVD, make the game to show this error:
    Windows Sidebar
    Windows Games
    Again rhetorical: Why Just Cause 2 need them...?

  6. #56
    Join Date
    Jul 2011

    Got this Problem to. Any help from EIDOS?

  7. #57
    Join Date
    Jul 2011

  8. #58
    Join Date
    Jul 2011
    Originally Posted by Olaf16
    Ediods is not here at the moment, Please hang up and try again.

  9. #59
    I had this problem for a WHOLE year! I had tryed everything I knew and everything I found on Internet.And now after a year I finally found a SOLUTION! As you all know this is not a RAM/HDD problem.Anyway here is the solution:First of all this message is misleading.I have Windows 7 and I had removed some components to make windows lighter.As it seems I had removed Windows Game Explorer and Just Cause 2 for some odd reason can't run without it.Turn Windows Features On/Off doesn't work when you've completely removed the functionality of something from the windows install.So you have to install Windows Game Explorer in order to get the game working.I have found an installer but didn't woked for me.So if this doesn't work try this: or this it helps.

    (Sorry for the long and boring message and sorry for my bad english. I'm from Greece)

  10. #60
    This is what you get when games use that Games for Windows live nonsense.

    You'll get this problem if it's been disabled or removed from Windows, to re-enable it run this command

    For 32bit run
    regsvr32 c:\windows\system32\gameux.dll

    For 64bit run
    regsvr32 c:\windows\SysWOW64\gameux.dll

    If you've done something else to disable that crap undo it to play the game then just disable it again afterwards.

    Also make sure the gameux.dll is in the proper location.

  11. #61
    Join Date
    Mar 2013


    The resolution to this issue is located at:

    At least it fixed my Server 2008 R2 "there is not enough space..." issue.

  12. #62
    Join Date
    Aug 2013
    Originally Posted by SentientAtom
    The resolution to this issue is located at:
    At least it fixed my Server 2008 R2 "there is not enough space..." issue.
    Thanks. I've found this advice as very helpful to solve such a problem that I also faced.

  13. #63
    Join Date
    Nov 2013
    i have like 147gb more

Page 3 of 3 First First 123