Thread: Mini Ninja LAG! on powerful system!

Mini Ninja LAG! on powerful system!

  1. #1

    Mini Ninja LAG! on powerful system!

    First off, I would like to say that I have a
    Core i7 Processor, 12gb RAM, GTX 295 in quad sli with over 3 thousand GB of video memory, Solid state drives in Raid 0, Creative sound blaster X-fi sound card. Vista 64 bit os with latest service pack.

    I can play crysis at MAXED settings 1920x1200 res, 16x AA with over 40fps ........

    I just purchased MINI NINJAS via steam US. I never played the demo, but i just bought the Full retail release because the gameplay vids looked awesome....

    MY PROBLEM IS, the game every about 4 seconds does a Mini lag for like a half a second CONSTANTLY, it is VERY ANNOYING, i feel like im playing musical chairs.......

    ANYONE ELSE HAVING THIS PROBLEM? ?? ? ? ?

    Ive tried,
    1. Editing ALL the ingame graphical options, setting them on low, medium, and changed the resolution, even i disabled vertical sync and and altered subtitles, difficulty...EVERY INGAME SETTING i messed around with...NO LUCK
    2. I then tried running the game from the directory and NOT steam....NO LUCK
    3. I tried turning off and on Vista user account control.... NO LUCK
    4. I tried setting different comparability modes and RUN AS ADMINISTRATOR...NO LUCK
    5. Since i have a core i7 with 8 LOGICAL PROCESSORS, 4 cores...I tried altering the task managers "set core affinity" options.....to use core 0. and core 1 ....etc etc etc.....NO LUCK
    6. I tried Editing Nvidia settings...Disabled Physx, and Quad sli...and vice versa...NO LUCK!!!!!

    Anyone else having this problem? its really annoying like a little mosquito bug that keeps fly straight into your eye ball when trying to look at a beautiful scenery? small? yes......annoying? HELL YES................

    Anyone else got this hitch? if yes please post what system specs? and if not ...what kinda system you got? could it be a bad steam installation? PLEASE HELP...I want to be a ninja... lol
    Thanks

  2. #2
    This lag is unbearable.....

  3. #3
    Windows Vista x64
    Intel Pentium Dual Core E2220 2.4GHz / 4GB DDR2 / GForce 9600 GSO 768MB DDR3
    Bought through Steam.

    Tried re-installing directx, downgraded it, upgraded it again. Changed all the settings like you did, ran in compatibility mode/admin privileges/visual themes off etc. etc. Doesn't go away. I would like to see a fix to this problem as soon as possible >.>

  4. #4
    Ok i fixed " My problem " which may be a problem fixer for other people, or at least some sort of clue for people who want to get to the bottom of this problem.

    Well I remember seeing someone post something about the usb keyboard being a problem with another game which caused the same type of micro tiny lag I was experiencing with this game ( mini ninjas )...

    Well I have a G15 logitech keybaord, and a REGULAR logitech normal keyboard that came with my alienware PC..... i also have the 360 controller.

    What I tested and found was that when using the BASIC Keyboard from logitech ( NOT the G15 logitech keyboard ) The old basic keyboard while plugged in was the problem and was causing the lag!!!!.....

    The lag DID NOT occure when using the G15 keyboard, and did not occur when using the 360 controller.

    So the problem somehow was the basic keyboard from logitech. ( My hypothesis is that somehow I think the game is checking to see if a controller or a keyboard is plugged in and somehow it gets all messed up with some keyboards...i dunno lol )

    But anyway, removing the keyboard fixed the problem... I suggest people with the 360 controller who have this problem, take out of the computer all of your usb keyboards and use the controller only, or try using different keyboards....see of that helps...

    so to summarize,

    1. The problem was caused by a certain keyboard
    2. The problem was eliminated when taking out that keyboard
    3. the game worked fine using a different keyboard ( g15 keyboard, and 360 controller)


    Here is the specs and name of the keyboard that was causing the problem...maybe there is a certain chip or something inside it?

    LOGITECH DELUXE 250 KEYBOARD
    M/N: Y-UL76
    P/N: 867675-0403
    PID: BT843DFR351
    (ITS JUST A STRAIGHT FORWARD BASIC BLACK KEYBOARD that came with computer from alienware)


    sorry for the long post, but this is just one example why PC gaming can sometimes be very difficult..... ITS LIKE A NEEDLE IN A HAY STACK, I would have NEVER thought it was a keyboard problem if i didnt luckily come accross someone elses post........its sad for some people who end up going mad trying to fix BASIC pc issues when the problem can be something as so simple a keyboard plugged in! ! ! ! !! ! !

  5. #5
    Haha, I have a Logitech G9 Gaming Mouse... and when I unplugged it, it ran just fine, plugged it in while playing the game and it started lagging again...unplugged it and it ran smoothly once again. This sucks >.> I don't have another mouse...

  6. #6
    Originally Posted by utilael
    Haha, I have a Logitech G9 Gaming Mouse... and when I unplugged it, it ran just fine, plugged it in while playing the game and it started lagging again...unplugged it and it ran smoothly once again. This sucks >.> I don't have another mouse...
    im happy i led you in the right direction... Think on the brightside... at least now we know what the problem is ...and you now know how to fix it.... if you have the money man, get a 360 controller ..the game plays epic with it.

  7. #7
    Join Date
    Sep 2009
    Posts
    2
    Same prob here, when i unplug my keyboard(saitek eclipse 2) the lag goes away and plug it back in while the game is running and it starts lagging again

  8. #8
    Same problem for me when having a Logitech DiNovo Edge bluetooth adapter connected to USB. The keyboard does not have to be turned on.
    I would like to see this problem fixed as I intend to use the wireless keyboard to play the game on my TV...
    Let's hope for a patch soon.

  9. #9
    Okay, I registered and all just to tell you that I had the same problem and I remember having a similar problem on Prototype when it was first realesed. So I did what I did then, I went into the device manager, and disabled all HID devices that wasn't being used, in this case unnecessary ones for the keyboard and mouse. This fixed the lag in this game as well for me and I can now play with my logitech G15 keyboard.

    Hope this helps you all.

    Regards // Senatic.

  10. #10
    I had this similar problem with Kane and Lynch. I recommend you guys trying to install an older driver for your graphics card.
    Example.. 8.2 Catalyst Driver for ATI graphics card
    (note: Make sure you uninstall you current driver before installing the new one)
    Edit.. i meant the older one lol
    No siggie to display... move along...

  11. #11
    Join Date
    Sep 2009
    Posts
    2
    Originally Posted by Senatic
    Okay, I registered and all just to tell you that I had the same problem and I remember having a similar problem on Prototype when it was first realesed. So I did what I did then, I went into the device manager, and disabled all HID devices that wasn't being used, in this case unnecessary ones for the keyboard and mouse. This fixed the lag in this game as well for me and I can now play with my logitech G15 keyboard.

    Hope this helps you all.

    Regards // Senatic.
    Thank you so much, this worked for me hopefully it'll work for everyone aswell

  12. #12
    Originally Posted by Senatic
    Okay, I registered and all just to tell you that I had the same problem and I remember having a similar problem on Prototype when it was first realesed. So I did what I did then, I went into the device manager, and disabled all HID devices that wasn't being used, in this case unnecessary ones for the keyboard and mouse. This fixed the lag in this game as well for me and I can now play with my logitech G15 keyboard.

    Hope this helps you all.

    Regards // Senatic.
    unfortunately for me, my mouse is the HID device causing the problem, disabled all the other ones and I still get lag, disable the last one (my mouse) and goodbye communication ;P I found another mouse to play with for the time being, but I do think they need to get a fix for this asap because a lot of people use Logitech devices and it would be bad support just to leave it up to their customers to find a new keyboard/mouse.

  13. #13
    I have a Saitek Eclipse II keyboard and have this issue in the demo and I had the same issue in Kane & Lynch (which is why I didn't buy that game even though I liked it) so can anyone from Eidos confirm if anything will be done regarding this, it is ludicrous to expect people to go out and buy new hardware like Mice and Keyboards just to play a game.

    I for one will not be purchasing anything else from Eidos until they accept that there are issues here and they address them.

  14. #14
    I noticed in the options menu, where it says "Use Controller", it's says On (or Yes, I don't remember now), but it's greyed out and I can't turn controller Off. Someone on another post said they thought the game studdered because it was looking for connected controllers and couldn't find any and as a result it would do that lag thing. If I could turn the "Use Controller" Off, that might help? But it's greyed out so... I'm kind of lost now... Eidos, please solve this...
    Aphis

  15. #15
    Saitek Eclipse II keyboard here as well, same annoying lag. Hopefully this gets fixed/patched for PC, but until then it's really not playable (well, not enjoyable, anyway).

  16. #16
    Well they chose to ignore it with Kane and Lynch so I see them quietly ignoring it again. A quick FU to all who purchase their games, which is why I am not purchasing any Eidos games again.

  17. #17
    Yeah, Eidos have got a disgusting habit of not doing after release support for anything. It's really annyoning. Especially on seemingly small annoyances on otherwise great games. But this particular problem has to sit squarely on IO's shoulders since the issue was around for Kane & Lynch aswell.

  18. #18
    LOL what LAG ??? I have Phenom 9950 , Radeon 4870X2 , 4GB 800mhz , Win 7 64bit , Saitek Cyborg Keyboard and Logitech G3 and I see no LAG . All settings on max in game and in Catalyst

  19. #19
    Yeah and had no lag with catalyst 9.7 yesterday and no lag with 9.9 today ..

  20. #20
    Good for you ...

  21. #21
    yeah good for you, most of us still have the problem. Has anyone looked into my controller solution?

  22. #22
    Originally Posted by Winterdeayh
    LOL what LAG ??? I have Phenom 9950 , Radeon 4870X2 , 4GB 800mhz , Win 7 64bit , Saitek Cyborg Keyboard and Logitech G3 and I see no LAG . All settings on max in game and in Catalyst
    I guess you can kiss your Saitek Cyborg Keyboard, that other stuff doesn't seem to have anything to do with it. Mine is a Intel i7 950, Geforce GTX295, 6GB 1600mhz, Win 7 64bit (and Logitech G9 and Logitech UltraX / Logitech MX518 and Logitech Ultra-Flat).

  23. #23
    Yeah it's pretty lame Jim with the monster PC u have I don't understand what they possibly did to make a game react like that , it's sure the first time I see or hear a game lag because of keyboard , makes no sense.

  24. #24
    Great news, I got it fixed. While looking around the internet alot of people stated that you could just disable the devices that were giving conflict and all would be gone. Well, I use a wireless desktop system (mouse and keyboard) and that wasn't an option. But i found something kind of interesting. When turning off HID Non-User Input Data Filter (KB 911895), the problem disappeared. I did not have to turn off any other HID devices or disconnect anything. Just go to Device Manager -> Human Interface Devices and turn off the data filters.
    Apparently, this fix is intended to fix issues of multimedia keyboards and devices to keep the connection to the OS. It sort of keeps on establishing a connection in order to give full support for the keys in your keyboard and mouse. Mind you, turning these off means you'll not be able to actually use the "special" keys on your keyboard and specially assigned functions to either mouse and keyboard (assuming they are USB connected). Once you're done playing, just go back to the Device Manager and turn them back on. I realize this is not a solution, but until Eidos does something about it, it should work (and without having to go behind your PC and physically unplugging things).
    Not sure it will work for everyone, but I think this is the most probable culprit.
    Happy gaming,
    Aphis

  25. #25

    Exclamation

    I've got apple keyboard and the lag is so big I can't even start the game because there is no lag only every 20 secons. I don't want to mess with any HID controllers. I just want a fix or money return. Simple.

    By the way, I don't have any data filters so I can't turn it off.