Page 1 of 8 12345 ... Last

Thread: FFVII Launcher Problems

FFVII Launcher Problems

  1. #1

    FFVII Launcher Problems

    Do someone have the same problem as me ? I'm stuck at 10% in the launcher of FF7 after installing all of the updates and it says "connection error - You need a working internet connection to log to FF7". WTF !!! I'm on the internet -__- !!!

  2. #2

    I also have this problem. =(




  3. #3
    Join Date
    Feb 2014
    Posts
    2

    I am having this same issue and IDK what to do

  4. #4

    Having the same problem. I actually got all the way through once but it refused to take my SE account info, said it didn't exist (it does) and then locked up. Now it's stuck at 10%.

  5. #5

    Likely we're just bottlenecking the login servers. Finally finished the download and am stuck here.

  6. #6

    Yeah, I realized the same thing when I let it stay at 10% and got the connection error. We are unintentionally ddosing the servers, I'm sure it will figure itself out soon enough.

  7. #7
    Originally Posted by imported_Samuel
    Do someone have the same problem as me ? I'm stuck at 10% in the launcher of FF7 after installing all of the updates and it says "connection error - You need a working internet connection to log to FF7". WTF !!! I'm on the internet -__- !!!
    I am just stucked at launcher screen.





    Everytime when I press play, I go back again at launcher screen.





    I don't know why. I didn't touch anything in settings.





    I have a Windows 7 64 bit.

  8. #8

    Same here.

  9. #9

    Same problem with launcher stuck at 10% Network error


    Running Window 7 64-bit


    This launch for this game is really bad to be honest wish they just release it on Steam.







  10. #10

    I finally got in. What I did was after the connection error, I clicked network settings. I did this about three times, then on my third time I realized "No Proxy" was not checked. After checking it and hitting Okay, it loaded to the login. I clicked Square Enix North America and bam.

  11. #11

    glad to know I'm not the only one.


    10% for me also.

  12. #12

    Same 10 percent freeze

  13. #13

    Ya same here 10% saying no connection i want a refund!

  14. #14

    Originally Posted by imported_John


    Ya same here 10% saying no connection i want a refund!


    The server is bottlenecking, give it time. Keep Calm.

  15. #15

    I'm getting it also. I can usually by pass it after a couple tries but when I try to sign in the game doesn't recognize my account.

  16. #16

    Is there any update on this? Another lovely example of DRM keeping me locked out of a game I paid for. Thans Squeenix!

  17. #17

    got mine working made sure the firewall allowed the ff7_en.exe and it let me through!

  18. #18

    Neither email or nickname are working, facebook I did not link. Now I seriuosly doubt it will work offline (e.g. notebook).


    Why did I buy this? The original 4 disc PC version is right there in my shelf...^^

  19. #19

    having same error, tried messing with the network settings, its set to "no proxy" tried always running it in admin to bypass the firewalls, still not seeing the internet connection

  20. #20

    I just got past 10% myself.

  21. #21

    just hit connection settings, checked proxy and put in nothing, checked no proxy again, Loaded fine after that





    and then i get a server error on the activation code screen

  22. #22

    Originally Posted by Etnie


    just hit connection settings, checked proxy and put in nothing, checked no proxy again, Loaded fine after that





    and then i get a server error on the activation code screen

    I'm getting this error as well.

  23. #23
    Everytime I click the 'View Online Profile Button' The link comes up broken. Someone told me this is how you boost your characters.


    Anyone Know another way to boost?


    Anyone know how to fix the broken link problem?

  24. #24

    If you are having a hard time Logging in with your email and password, try this:





    Click on Square-Enix NA on the left side of the log in.


    Then enter your information, Thats how I got it to work

  25. #25
    I installed this game in Windows x64 and can't play this game because after clicking play button, the launcher close itself and open again.

    I try to run ff7_en.exe in the installation directory manually, and got an error dialog with this message:


    ff7_en.exe - Application Error
    The application was unable to start correctly (0xc000007b). Click OK to close the application.

    Who got this problem and already fixed it? How to do that? Thank you.

Page 1 of 8 12345 ... Last