I wondered about the 1.1-Steam-issue, too, and asked the Steamsupport. I got the following answer:



This is very strange in my eyes: running 1.2 "data" with an 1.1 "exe" seems to be not a good...