View Full Version : Commandos 2 ingame bug?

29th May 2009, 07:45
I played Commandos 2 for a long time with no problem at all but a few days ago I formatted my computer and from there on when I am playing Commandos 2 a screen pops up and says that comm2.exe has encountered an error and has to close.
I tried the 1.2 patch but still no luck.

This same problem is on my brothers computer as well, and even when we LAN that screen pop's up.

I have a GeForce 6100 graphic card with the latest drivers.
1GB mem.
1,8GHz AMD processor.
and Windows XP Professional.

PLZ help I love this game and can't wait for Commandos 3 Strike Force

31st May 2009, 23:23
Hard to say, maybe some files have been lost, so that the game won't run. Try to reinstall it.

You can't wait for Strike Force? Let me say that it sucks hard.
Commandos 3: Destination Berlin was still quite good (except for the last Normandy mission), but SF was really disappointing. Although it was quite fun, it had almost no replay value and it was dead easy even on hard.

1st Jun 2009, 04:02
Thanks for your reply Nzap. I will try to reinstall tonight.

Have a nice Day

3rd Jun 2009, 13:29

I reinstalled commandos 2 and still the game gives an error.(LOST ALL MY SAVED GAMES IN THE PROSSES)

The error says that comm2.exe has incountered an error and has to close so I clicked on view the report and it sayed that this file wil be included in the report.

and in this text file is the folowing.

<?xml version="1.0" encoding="UTF-16"?>
<MATCHING_FILE NAME="comm2.exe" SIZE="9024123" CHECKSUM="0x981CB806" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="09/07/2001 21:04:16" UPTO_LINK_DATE="09/07/2001 21:04:16" />

<MATCHING_FILE NAME="kernel32.dll" SIZE="983552" CHECKSUM="0x4CE79457" BIN_FILE_VERSION="5.1.2600.2180" BIN_PRODUCT_VERSION="5.1.2600.2180" PRODUCT_VERSION="5.1.2600.2180" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xFF848" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.2180" UPTO_BIN_PRODUCT_VERSION="5.1.2600.2180" LINK_DATE="08/04/2004 07:56:36" UPTO_LINK_DATE="08/04/2004 07:56:36" VER_LANGUAGE="English (United States) [0x409]" />


Please help.
I don't want to lose all my saved games for nothing.

3rd Jun 2009, 17:03
I'm not sure but you may have a dll error (can someone back me up here, I'm not sure at all), but it says that some error in kernel32.dll (which is quite strange as what I know kernel32.dll is only in versions 95, 98 and Me of Windows).
Here's more about kernel32: http://www.instant-registry-fixes.org/fixing-dll-issues-related-to-kernel32dll/

Look at these as well:


Looks like either kernel32.dll got lost during your formatting of your computer, or it was damaged.

All of this is of course a hypothesis, but I can't give any better advice, I'm sorry.

Of course, try to google your error messages and see if someone else has had the same problem.

Of course it might also have been caused by a virus. Also, try to use programs with registry repair, e.g. advanced systemcare 3 http://download.cnet.com/Advanced-SystemCare-Free/3000-2086_4-10407614.html as that might also help. (it's a good program to help keeping your PC as clean and fast as possible)

13th Jun 2009, 17:49
Are there still some problems?

Sorry about those saved games. For me it's obvious to backup them, but I didn't know it the first time I reinstalled a game either, so I should have mentioned it.

19th Oct 2009, 08:33
Does anyone have the same problem as me ?

I can not be the only one with this problem.

I have tried everything:confused::confused::confused: :
Reinstall game
reinstall windows
Advanced system care


5th Nov 2009, 19:31
This is a wild guess but it could be that the game is not re-installing correctly.

Try to remove it by making a clean uninstall, then use the setup.exe file (not the popup menu) of the 1st cd to directly install it on your hdd. Then proceed to the patch, then restart your computer and then try to access the game. Hopefully it will be installed properly.

Just my two cents,

6th Nov 2009, 08:33
Thanks iakovos, But can you please tell me how do I do a clean uninstall?

Thanks again

6th Nov 2009, 23:36
Follow the instructions in those two threads:




Make sure to BACK UP any data, as suggested, prior of making this.


7th Nov 2009, 05:56
Thanks iakovos, but those threads is for commandos 3.

Where can I find the commandos 2 folder names?

7th Nov 2009, 22:28
If you follow the threads through, you'll see that it is suggested that the same applies for Commandos 2.


PS. I haven't tried this personally, to be able to assist you more, since I haven't had any probs with C2 before.