View Full Version : Affinity problem - Can't set it

15th May 2009, 19:46
I've just replaced my old CD-Drive so I can start installing games again, I knew I'd bump into the affinity problem when I'd try to run this game on vista though.

So when trying to set it to run on only one processor I meet a problem because Vista (<3) tells me: "Access Denied". This occurs when I right click on the processor called Thief2 and click "Set Affinity".

So therefore I can't play my favourite game now...

I also get random popups now and then saying "Incorrect Thief2 disc inserted" blah blah. Doesn't seem to stop the game in any way though... Just Vista bugs I guess.
EDIT: It's odd, I most often get these popups when I click links that people send me, gotta admire the wonder that is Vista.

I guess this problem has something to do with me not having the correct administrator rights or something, but the question is then; How do I fix that?

15th May 2009, 20:20
Oh, and I've also updated it to 1.18 + that I've already tried with only running on a different compatability.

Mr. Perfect
17th May 2009, 21:15
I haven't tried this with Thief specifically, but Process Watch (http://smartconsultant.de/) has let me set the affinity on other old games.

Mr. Perfect
18th May 2009, 02:04
Looks like there's an easier method in this thread (http://forums.eidosgames.com/showthread.php?t=76504)

18th May 2009, 03:49
I think you are right about administrator rights. I suggest that you google Vista administrator privileges or Windows administrator privileges. If it works anything like XP, you can log into an administrator account and give the privileges to another account. I am not familiar with Vista, so I can't say for sure.

19th May 2009, 14:49
Managed to solve the problem the other night and I can finally play Thief again... :)

It was indeed administrator rights that had to be granted for the game, I could describe how I did closer if anybody experiences the same problem