PDA

View Full Version : Thief 2 - Crash on mission start



Kuririn7th
17th Mar 2009, 06:22
Hello all. Copy-pasting this post of mine from the Legacy Gaming Forum over at TTLG forums. Figured I might have a chance of my problem being fixed if I took more of a shotgun approach to my assistance requests. I've perused about a hundred different posts/fix sections on various boards to get Thief 2 running on my system, with no success thus far. Here's the previous post, any assistance would be greatly appreciated.



Hello all. So I got a primal urge this weekend to club some guards. I dug out my old Thief 2 cd's (pre-updated to 1.18, no idea which 'version' of the cd's this is). Installed without a hitch, started tracking down various patches I needed to get it running on my system (vista 64). Here are the steps I have gone through so far:

removed CD checks in install.cfg and darkinst.cfg
installed DDFix (had to do it manually, with hex edit due to gui crash despite me having .net 3.5)
Installed widescreen fix, changed resolution in that batch program, ddfix.ini, and cam.cfg, to 1650x1080 using the appropriate syntax
copied dromed.zip contents from game cd to base install folder
Video fix, multicore fix are done, safe_texture_manager fix is done.

Have tried various startup combinations including with cd, without, admin mode, compatability mode, darkloader, and even uninstalling the whole shabang and adding one item at a time. Initially, I was getting borked at initial game launch, I discovered that was caused by my 3d stereoscopic driver. Disabled in NVIDIA control panel and I could then get into the game. I can do whatever I please in the menus, but upon launching an actual game, it crashes after the briefing 'continue' button. Fully loads, it would seem, and I can almost head the sound of a cricket from the start of the first level, no visuals though, afterwards it's desktop city.

All movies work fine for the record.

Current rig:
Intel Quad 2400 (to re-iterate, CPU affinity set to core 0)
8800GTX with latest drivers
Asus Xonar D2X sound card
Vista 64 Ultimate

Any suggestions?



To add to it, I made another attempt to install yesterday, found that if I set the resolution to 640x480 in game, I can actually load the game engine for about half a second, with the whole kaleidoscope colors, and no actors, then there's a crash immediately afterwards. I did 'something' at some point through my troubleshooting that actually got the game to load, in full glory (though with slightly messed up coloration, bit too dark), with actors walking around and everything. Apparently I sneezed when exiting, or something, because after that it wouldn't successfully launch. Voodoo magic might help me out here as well, if anyone has any experience.

Kuririn7th
17th Mar 2009, 18:46
Yet another copy-paste. I fixed my problem, posted again, figured I'd toss it out here in the event anyone else had the same problem I did.


Victory! So here's the steps I took on this installation attempt. Installed my 1.18 version of T2. Made changes to the install.cfg and darkinstall.cfg, then backed up the whole directory just so I wouldn't have to reinstall again. Made a backup of thief2.exe. Threw in the prepatched thief2.exe that's located all over the place (default set to run in compatibility mode for 2000). Threw in ddfix.dll and .ini. Made changes to the user.cfg to take out the semicolon in front of the safe_texture_manager. Fiddled with various resolutions in-game and out, with no success. I then ran the imagecfg fix (not that this would do anything, as the cpu's were already disabled except for core 0) and fiddled with more resolutions, to no avail.

Finally, I said 'screw this', renamed my patched thief2.exe to something else, got my backup thief2.exe, changed it to compatibility mode for 2000, and it WORKED. As a note, at this point it has no widescreen support, no ddfix applied to it, and no single core fix applied. As I expected, it crashed after about 15 seconds. I bounced out, applied the darkwidescreen fix to bump it up to 1440x900, and then applied imagecfg fix to it to make the single core fix permanent, and now it runs beautifully. I've sinced applied a couple hi-res texture patches and some sound quality update.

Couple things I am curious about though. The colors are a bit off. Sky is a weird greenish color and the clouds don't blend well (same with most shadows). Looks sort of like it's running in 256 colors, or something. Also, resolution changes when I enter menus, maps, ect. Any way to fix these two issues WITHOUT using DDFix? I can live without them, it's just not 'optimal' (thanks OCD).

Psychomorph
19th Mar 2009, 23:28
I have a problem there too.

I put the "ddfixGUI" stuff in the thief2 directory, put the patched "thief2.exe" (the one that you don't need to hax). It works, but the widescreen resolutions aren't available that way, so I need to run the DarkWidescreen stuff, which doesn't work, because it says...

Patched thief2.exe <2662400 bytes>
ERROR: COPY ~thief2.exe~ ~thief2.exe~ FAILED: cannot open target
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

...so, no patch. When I edit the ddfix.ini and the cam.cfg manually, the game crashes when loaded (the menues have black bars at the sides).

XP Home SP3, GeForce5FX, etc...


Any suggestions?

anudedeus
22nd Jun 2009, 21:12
I'm trying to find the DarkWidescreen fix, where can I get it?
I'm trying for 1440x900.

-Update: got it at
http://files.filefront.com/DW+v6+Old+Get+v6r2+instead/;10450521;/fileinfo.html