PDA

View Full Version : No footstep sounds on certain surfaces



Moonraker0
5th Feb 2009, 21:45
When I or any other character walk on certain surfaces, including stones and wood in "Undercover", no sound is made, which is unrealistic for me and difficult, since I can't hear people coming. I can hear the sound fine on half of the places I walk on, like marble and brick. I'm on Vista 64-bit. Thief is always running as Admin (needed to see videos). Hardware sound is off, and I have no sound card. I tried the stickied "Sound Fix", but stopped when I realized there was no A3D.dll already. Here's INSTALL.cfg:

cd_path D:\
install_path C:\games\Thief
language english
resname_base .\fam+.\EP\Thief1+.\EP+.\+.\RES
load_path C:\games\Thief+D:\thief
script_module_path C:\games\Thief+D:\thief
movie_path .\MOVIES+D:\thief\movies

Windows 98 and XP compatibility modes change nothing (98 acted as if I didn't have DirectX 6, so I didn't use it).

Peter_Smith
6th Feb 2009, 02:41
The configuration file looks OK, but it would have nothing to do with it. It seems to me like a Vista-specific sound problem as you have surmised. Maybe specific to 64 bit. I have no knowledge of this problem or of Vista (as a user). I suggest that you do a search for Vista sound on Google and/or at TTLG. The place to look at TTLG is at the Legacy Gaming Technical Help forum.

I don't have time to do an in-depth study on this, but I did a little looking and found mention that Alchemy was needed and that EAX didn't work. If you have EAX on, try turning it off.

If you find the answer, please post back with the solution.

EDIT: on second thought, it is weird that some surfaces work and some don't, and I guess some missions work and some don't. Could there be different classes of sound that are processed differently? Another possibility is that you have a Thief software issue, such as some sounds are missing. I hate to say it, but have you tried reinstalling Thief?

Moonraker0
9th Feb 2009, 04:19
Once you said "reinstall", I got the idea of install.cfg. I took out "+.\fam", and now all sounds play fine! I did try moving it to second-to-last, before +.\RES, but the sounds were still messed up. I'll just keep it out now.

Peter_Smith
9th Feb 2009, 14:32
Glad you fixed it. Sorry, I hadn't noticed .\fam. What is that? I don't use it.

Moonraker0
13th Feb 2009, 14:52
It's for oRGy's texture patch.