View Full Version : No SWLego.bin File

17th Jan 2009, 03:44
I recently installed Lego Star Wars on a machine with Vista and experienced the exact problem described below:

Lego Star Wars - The game ran once, but now it crashes when I try to start it again

This is an issue we have not been able to determine the exact cause. Luckily there is a simple solution! The issue is a corrupt settings file. You will need to browse to the installation folder for Lego Star Wars, this is usually C:\Program Files\Giant\Lego Star Wars. You can get there easily by right clicking on the icon for Lego Star Wars, and choosing properties. Once the Properties window is up select the button that says,"Find Target." In the install folder, you will find a file named SWLego.bin. Delete this file. Run the game. This file will recreate itself. We have found that the newly create file is created correctly and you should not experience this issue again.

Source: http://support.eidosinteractive.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=553

The problem is that no SWLego.bin file appears in the install folder. I searched right through the folder in case it was somewhere-not-so-obvious or if it was a hidden file but it definitely is not there. Needless to say this is incredibly frustrating. Does anyone else have any other advice?

8th Feb 2009, 12:05
I installed this game a few days ago and got a few days play on it before experiencing the same drop out problem. I get as far as the nVidia logo and the opening title sequence before the program drops out. I also do not have an SWlego.bin file anyway. Did you find an answer to your problem? I'm quite computer illiterate, so if you did, could you keep it simple?

25th Apr 2009, 10:41
I'm having the same problem as both of you on my home computer running Vista. I can't find a file anywhere on the computer with a name of SWLEGO.bin, nor can I find where the saved games are located. Did either one of you figure out the answer to the problem?


25th Apr 2009, 12:21
I gave up in the end. After closer examination of the box, the game's not supported on VISTA. It just doesn't seem to make sense as the game worked perfectly for a while. I'm sorry I couldn't have been of any help.

25th Apr 2009, 18:59
I think I may have a solution to our Vista problem. I found this on an Eidos technical solution website regarding Vista.


Basically what it says is to play the games in Windows XP Compatibility mode.

BUT...After I did that the game worked and we were able to use the gamepad again, but we lost our saved game!

To get that back I searched the C: drive of the computer and found the saved game in this folder.

C:\User\[my computer's name]\AppData\Local\Virtual Storage\Program Files\Giant\Lego Star Wars Game

You would need to replace my computer's name with your's

...the folder with the saved game in it was called LSW_0

I copied this folder to this folder C:\Program Files\Giant\LEGO Star Wars Game and we had our saved game back. So far so good...

9th Jun 2009, 13:23
swlego.bin gets created on the first run of the game. It can also get deleted randomly. Best thing to do is install - run, quit. Find swlego.bin, right click it, go to properties, set to read only.
The first run sets it to your desktop resolution, which should be the best resolution anyway. If you set it to read only it will neither get deleted, nor the resolution changed. It also uses that to set whether you have an nvidia card so it can apply the light saber blur effect.
Default location is here: C:\Program Files\Giant\LEGO Star Wars Game