PDA

View Full Version : No movies/videos in Thief 1



Moonraker0
23rd Dec 2008, 01:40
I'm not getting any movies. I tried installing the codec from the disc, and it still did not play them. I set DDFix to re-register them every time I started Thief. Then I tried making a batch file with the appropriate commands (http://www.ttlg.com/forums/showthread.php?s=&threadid=75031#movies2) and then a command to launch Thief. I tried getting the updated drivers (http://www.thief-thecircle.com/download.asp?fid=876). I tried typing the right command (http://www.ttlg.com/forums/showthread.php?s=&threadid=75031#movies3) in the search box. Here is what it said:
http://picpanda.com/images/gbj9flkbhei7gj69m6e.bmp (http://picpanda.com/)
http://www.mediafire.com/file/ovudtimzitd/DxDiag.txt

Moonraker0
22nd Jan 2009, 23:45
I tried the new version from TTLG; still nothing. I tried, both separately and at once, DDFIX's "VideoFix" and also a batch file to regsvr32.exe the LGVID.AX file (both in the Thief directory [where I'm running the batch file from]). Opening the batch file manually with the Command Prompt doesn't say anything but echo the commands (it's CD'd in the right folder). If I try reinstalling the Indeo codec from the Thief CD, it says that some of the files (including the Indeo DirectShow filter) have newer versions installed and will not be installed. I have uninstalled the new Indeo codec(s) from Programs and Features.


regsvr32.exe /s LGVID.AX
thief.exe
EDIT: I searched for the error code (not sure why I didn't the first time) and it turned out to be a permissions problem. The error only appears when I exclude the /s flag. So I tried running Command Prompt as Administrator, and typing "regsvr32 C:\games\thief\lgvid.ax". It displayed a "Success" message. I loaded up Thief and picked up the book at the end of the Haunted Cathedral level, ending the mission. I reviewed the objectives for the finished mission, clicked "Continue" (isn't that where the video should play? There was a slight pause after clicking it), reviewed the new mission's objectives, clicked "Continue", bought new items, and clicked "Play mission" or whatever. Lost City started, but no movie ever played.

Peter_Smith
24th Jan 2009, 05:39
It sounds like you could be doing all the right things, but....

I thought the movie problem was only with Thief 2, yet you say you have it on Thief 1. As I understand it, none of that registration, etc., is necessary or desirable with Thief 1. TTLG is down now, so I can't check.

This is pure speculation, but I wonder if your Indeo codecs are being installed correctly. Maybe you are using an older version. It is possible to get another Indeo installation file from the internet here:
http://www.video-drivers.com/drivers/8/8552.htm

The name of your Indeo installation file should be iv5setup.exe. The last one I downloaded was on 11/25/07, and it works fine for T1 and T2 using the steps you describe, although I have not had to resort to the automatic registration in DDFIX.

You didn't say what version of Thief you were using, i.e, is it Eidos, Soldout, Steam, or ?? That could be a bug with the software reseller's distribution. Hopefully the revised Indeo install should fix it. I dunno.... maybe you have to register that file AV again after the install.

Let me know if anything works or you need more worthless information. :)

Moonraker0
24th Jan 2009, 22:29
I downloaded those drivers. They kept telling me there was a newer version of them, referencing a few DLLs in System32, which were non-existent and actually in SysWOW64. After much strife, I found out that I could delete these by logging on in Safe Mode and taking ownership of SysWOW64. I deleted those files, and the downloaded drivers installed without a hitch. I was dismayed to find that videos still didn't play, with "Intro" or "New game" just pausing at a black screen for a quarter of a second and then going back to the title or objectives screen. I had the idea of running Thief as Admin, and voilĂ*, videos! Now I went to Compatibility for All Users and set it to always run as admin. I haven't had to re-register the file after several restarts of Thief and Pause/Breaks. TY!

Peter_Smith
25th Jan 2009, 08:22
Well done.:) It looks like the Indeo codecs were not the issue at all.

I had not heard (or remembered) that you needed to be an administrator to run Thief. I just verified that. Running from a User account, neither Thief 1 nor Thief 2 would run using the DDFIX exe. On my system, I have to use DDFIX. It would start but not load a saved game or do any graphics. When I used the run as.... from an administrator account, both T1 and T2 worked.

Now my question to you is, how do you make the run-as setting permanent? I find that it resets itself every time I exit.

jtr7
25th Jan 2009, 08:31
Hopefully someone can point us in the right direction with this:
http://technet.microsoft.com/en-us/library/cc780931.aspx
http://technet.microsoft.com/en-us/library/cc772672.aspx

Hopefully. :)

Peter_Smith
25th Jan 2009, 17:40
I have done some digging about making "run as" permanent. According to Microsoft and every reference I can find, you can't. It is temporary, and you have to log on every time.

As admin, I gave gave User accounts full control of the Thief folder and, by inheritance, everything inside. That results in Thief (T1 and T2) playing correctly, able to load saves, etc., but the movies still did not play. You have to do the same thing to the T1, T2, and darkloader main folders.

When I set the access to the Darkloader 4.2 folder, it complained on startup that some file could not be found unless I ran it as admin. It still worked, though. I checked files in the folder such as darkloader.ini, and the User has full control of them, so I don't know what gives or what is the offending file.

EDIT I would guess that to make the movies play without using "run as" you might need to find the indeo codec files in the Windows folder and do some security thing with them. I couldn't find them, so I am giving up that. This seems like a potentially dangerous practice anyway. I'd suggest either log on as an admin or live with the temporary "run as".

One interesting thing I found is that even when playing Thief as an admin from a User account, it would not play Success.avi at the end of a mission. It played other movies fine, e.g, between missions. There is nothing unusual about the success.avi file that I can find. I am puzzled as to why I can play it but a User running as admin cannot.

Moonraker0
25th Jan 2009, 18:36
Well, I searched for "* modified:<1/1/2000 .. 1/31/2000" in the SysWOW64 folder, which returns any really old file in that folder. It appears that all of the files you may want to change are named "Ir*_*.*", such as Ir50_32.dll or Ir41_32.ax. Looks like pretty much anything in that time period starting with I and ending with .dll or .ax, usually in the above format. I'm not sure if XP can use that search term, but you can probably still enter the modified/created date (created when you installed the codec, if you want). You probably don't have a SysWOW64 folder, so I guess the files will be in System32.

Peter_Smith
28th Jan 2009, 07:21
Sorry, I am missing something. What is the point of the above post? Are you saying that those are the Indeo codec files and you want me to mess with their security settings? If so, can't you try that and let us know what happens?

Moonraker0
28th Jan 2009, 21:17
EDIT I would guess that to make the movies play without using "run as" you might need to find the indeo codec files in the Windows folder and do some security thing with them. I couldn't find them, so I am giving up that.
Nah, I just was giving you the file names so you could change them if you wanted, which you said you do.