View Full Version : Serious Graphics Problem with HD 4870

2nd Nov 2008, 14:51
When i try to play the Demo, i get this really strange looking graphics: Click (http://s4b.directupload.net/images/081102/on9in8f8.jpg)

My sys: PowerColor HD4870 1GB PCS+, 4GB DDR2-Ram & E8400

I have installed latest drivers and software and the problem is both under XP and Vista64 present. Other games work just fine.

Here is my dxdiag.txt for additional information: http://rapidshare.com/files/159972620/DxDiag.txt

2nd Nov 2008, 17:08
Looks like a display driver problem, are you sure you have the latest driver from ATI?

2nd Nov 2008, 17:37
Yes, its the ATI Catalyst 8.10.

2nd Nov 2008, 21:13
lol. You certainly have the specs to run it just fine.

I can only think to try reinstalling the drivers, because it certainly looks like a driver problem.

2nd Nov 2008, 23:46

System Information
Time of this report: 11/2/2008, 16:38:36
Machine name: RALLE
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.080814-1236)
Language: German (Regional Setting: German)
System Model: MS-7512
BIOS: Default System BIOS
Processor: Intel(R) Core(TM)2 CPU E8400 @ 3.00GHz (2 CPUs)
Memory: 3072MB RAM
Page File: 409MB used, 3524MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode

so far, so good...

Display Devices
Card name: ATI Radeon HD 4800 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x9440)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9440&SUBSYS_22671787&REV_00
Display Memory: 1024.0 MB
Current Mode: 1920 x 1200 (32 bit) (60Hz) are you playing on a not supported resolution for your monitor? please explain....
Monitor: Plug und Play-Monitor
Monitor Max Res: 1600,1200 is the max resolution for the monitor 1600x1200?
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6869 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail

3rd Nov 2008, 06:29
I'm playing on a Belinea 2485 S1W which supports 1920x1200 natively. I don't understand why dxdiag says it's max. resolution is 1600x1200.

In the meantime i reinstalled graphics driver, directx and the demo but nothing changed after all. The demo isn't corrupt either, it works great on the pc of my brother.

I guess it's all the drivers fault and hope that the next version will fix this problem.

3rd Nov 2008, 17:13
To DefBot: I kinda registered here to get you a possible solution. I had the same problem as you, looking at the screenshot. My specs are quite similar (a HD4870, E8500 and 4gig ram). I didn't find an answer to the problem anywhere. What I tried: set the game to maximum settings everywhere (As much AA and FSAA as you possibly can). It suddenly worked for me. I tried putting the settings back to a 'normal' level and the problems were back again.
Let me know if this helps you, if not, I might give you some details about how my HD4870 is configured...
Kindest regards

3rd Nov 2008, 17:42
Ty, Timon. Now it works. :thumbsup:

I experimented with the settings a bit and found out that antialiasing must be activated to avoid this problem. It doesn't matter, if it's 2x, 4x or 8x as long as it's turned on.