PDA

View Full Version : USER INTERFACE Unlocking 60fps cap



jestdoit
11th Jan 2014, 08:47
120hz and 144hz monitors are common these days - can we get an in-game option to raise/remove the 60 fps cap?

The typical UE3 ini option to remove the cap isn't having any effect.
[Engine.Engine]
bSmoothFrameRate=FALSE

Oroibahazopi
11th Jan 2014, 12:33
Consoles etc

Kuro1n
11th Jan 2014, 16:46
My game is running at 60+ FPS without any changes... Are you sure there is a cap? Maybe you didn't turn v-sync off?

Razaiim
11th Jan 2014, 17:41
I never understood the need for something much higher than 60 fps. In video gaming specifically, the human eye typically doesn't process information any faster than the equivalent of 60 fps, so anything higher is just showing off, to me at least.

jestdoit
11th Jan 2014, 17:52
V-sync shouldn't matter since I'm running at 144hz.

Just how are you getting 60+ fps without changes? The default cap for UE3 games is 62 fps. You can see your framerate by hitting esc then video settings during a match. Video capture software like FRAPS will also show it.

In UE3 games like Super MNC and Red Orchestra 2, you can lock the cap at 300+ fps. So smoothness. Much input response.

Kuro1n
11th Jan 2014, 18:11
V-sync shouldn't matter since I'm running at 144hz.

Just how are you getting 60+ fps without changes? The default cap for UE3 games is 62 fps. You can see your framerate by hitting esc then video settings during a match. Video capture software like FRAPS will also show it.

In UE3 games like Super MNC and Red Orchestra 2, you can lock the cap at 300+ fps. So smoothness. Much input response.

No idea, but yesterday I was 65-70 fps. Haven't touched any of Nosgoths files.


I never understood the need for something much higher than 60 fps. In video gaming specifically, the human eye typically doesn't process information any faster than the equivalent of 60 fps, so anything higher is just showing off, to me at least.
If you played FPS games competitively you would notice, I think it is just input lag you notice but not sure. Either way you are wrong if you think it is just showing off. Try playing 60 and then 120FPS and you will see.

jestdoit
11th Jan 2014, 18:54
I never understood the need for something much higher than 60 fps. In video gaming specifically, the human eye typically doesn't process information any faster than the equivalent of 60 fps, so anything higher is just showing off, to me at least.

That's a common myth. Old monitors are limited to 60hz. It's not your eyes that are limited, it's your viewing device.

The human brain perceive motion well beyond 60 fps. USAF pilots detect image changes 220 times per second.

http://us.battle.net/wow/en/forum/topic/7199031187
http://amo.net/NT/02-21-01FPS.html
http://amo.net/nt/05-24-01FPS.html
http://www.ualberta.ca/~chrisw/howfast.html

Framerate also affects input response. Low fps will make your mouse lag in UE3.
I'm using a triple-screen setup - a 60hz for art/image calibration/video editing, a 110hz G2400w (fighting games), and a 144hz. Doing a side-by-side motion comparison in uncapped FPS games looks like this http://boallen.com/fps-compare.html


No idea, but yesterday I was 65-70 fps. Haven't touched any of Nosgoths files.

Ah, I'm shooting for 144 fps anyway - I'd like to lock it there to match my monitor's native 144hz refresh. And there's no way it's my computer performance since I'm locked at 62fps@1080p in Nosgoth, while pulling 300-450fps in all other UE3 games when unlocked.

Kuro1n
11th Jan 2014, 19:04
Look into framrate smoothing. It was a thing in tribes ascend. Might affect Nosgoth as well.

Psyonix_Corey
11th Jan 2014, 19:22
With bSmoothFrameRate=FALSE in BCMPEngine.ini and VSync OFF in-game I get 80-100 FPS on a GTX 480 at 1920x1080 on a Development build.

If you have VSync ON, Unreal will typically clamp your framerate around 60 whether that's "correct" behavior or not.

Your problem may be that the setting only takes correctly when set in the Engine INI File, not SystemSettings. We may need to expose the option manually for you to be able to turn off Unreal's framerate smoothing with how we're doing INI security.

jestdoit
11th Jan 2014, 20:11
Yea, VSync adds input lag, so it's always been the first option to go.



With bSmoothFrameRate=FALSE in BCMPEngine.ini and VSync OFF in-game I get 80-100 FPS on a GTX 480 at 1920x1080 on a Development build.

Sweet.



Your problem may be that the setting only takes correctly when set in the Engine INI File, not SystemSettings. We may need to expose the option manually for you to be able to turn off Unreal's framerate smoothing with how we're doing INI security.

On behalf of all players with >60hz monitors, many thanks.

blincoln
11th Jan 2014, 22:19
Dumb question: I don't have a file called BCMPEngine.ini either in the directory under my profile where the other INI files are, or in the installation directory. Do I need to make one, or is that a typo?

Psyonix_Corey
11th Jan 2014, 22:57
Dumb question: I don't have a file called BCMPEngine.ini either in the directory under my profile where the other INI files are, or in the installation directory. Do I need to make one, or is that a typo?

It's not, the Engine INI is not exposed on release builds for a few reasons. What I was trying to say was that since the Engine INI is private for Nosgoth, we'll have to expose a setting in SystemSettings that toggles it in a later patch.

Kuro1n
11th Jan 2014, 23:06
I agree it is good you keep the INIs as hidden as possible Corey. In tribes people messed with the INI files so much and it gave distinct advantages.

Strike5150
14th Jan 2014, 16:19
I just wanted to add that some people can't perceive higher framerates. Not everyone is equal in this department, some of us are astounded at the quality of movies in the theatre and some of us get sick because of the awful shuttering effect when the camera moves. I can tell the difference up as high as about 120Hz, then I can't really detect much more than that unless its a big jump like doubling it to 240Hz. Its very irritating when it yoyos around, and you do notice the input lag.