PDA

View Full Version : D:\setup.exe is not a valid win32 application.



m87
10th May 2008, 01:39
System:

Microsoft Windows XP Home Ed. Version 2002 Service Pack 2

AMD Athlon(tm) 64 X2 Dual Core Prodessor 3800+ 2.01 GHz, 2.00 GB of RAM

So, according to the box I more than meet any requirements.

I own Hitman Blood Money, and Kayne & Lynch: Dead Men, both of which installed and worked without any problems whatsoever. So I doubt that it is some problem my hardware has with Eidos games.

However I just got Just Cause, and when I try to install it, it gives me the message "D:\setup.exe is not a valid win32 application." It also does this if I try to use the autorun just switch setup.exe to autorun.exe. I do have a DVD drive and have NEVER had this problem with ANY OTHER game either older or newer from this company or others.

I have seen a few topics about this on these forums, but most of them end with 1 or 2 replies saying to check the system requirements. As far as I can see this IS NOT my issue... But if it is and I don't see it please let me know.

Any suggestions on what I can do to get around this problem (the disc is absolutely new out of the box, but yes I did try to clean it anyway :mad2: )?

I would appreciate any help very much.

joeelove
23rd May 2008, 04:01
I'm having the exact same issue. I'm running XP pro SP2 and just installed SP3 and am having the same issue. So this is definately something with the game.

joeelove
23rd May 2008, 18:51
I read in another post for DX that a resolution for this was to uninstall, delete any directory still remaining. That somehow resolved the issue.

So, I initially thought, well maybe this is happening because I have the demo installed, so i tested on my second PC (No Edios games installed) and I get the same error there.

So, next I tried on my third computer (laptop) and didn't get the error on that machine, so it's not the disk so everyone is clear
:mad2:

m87
23rd May 2008, 19:33
I actually just now tried to install the game again and it worked. I have no real explanation why, other than I did disable a thing called "In CD Helper" that was some part of Nero (same place as the system startup stuff... ) I would probably try getting rid of any part of anything Nero that runs automatically and or trying to see about other programs that might be screwing with your DVD drive since this appears to be what the problem was for me.

joeelove
30th May 2008, 20:51
AHHHH, that's good to know. I have Nero on my home PC but not my laptop. So, that makes sense as to what I've seen.

Now, did you just disable to service or actually uninstall it? or did you stop the service from task manager, if so what service name did you stop?

m87
31st May 2008, 00:24
Start, Run, type msconfig, in the Services tab I disabled (unchecked) InCD Helper, Manufacturer Nero AG. I also got rid of NeroCheck in the Startup tab. Try those and/or things like them.

joeelove
2nd Jun 2008, 01:08
Resolved, used msconfig, unchecked both Nero services, rebooted and was able to sucessfully install the game.

Thanks m87 for all your help.