PDA

View Full Version : TDP Help - Driver Downgrade



[clan]Payne
23rd Apr 2008, 13:37
Well after spending the last couple of hours of getting the game NOT to crash it finally worked. I got through the intro, selected the training (for old time sake :) ), objectives went in, clicked start > arrows started spinning and well the obvious happened. The black screen of doom was upon me. After reading through all the guides I noticed that the only way to play is to downgrade my drivers to the 8.xx.xx versions.


Finally the question, how do I downgrade the drivers to the 8.xx.xx?

theBlackman
23rd Apr 2008, 21:45
Uninstall the current drivers. Use the uninstall in your ADD REMOVE PROGRAMS if it shows there.

Run a "Driver cleaner" if you have or can find one to clean out all traces of the old one. Download from the manufacturers site the driver you want to install.

Then just "Install" it or EXE it from the RUN MENU.

mattmanr
23rd Apr 2008, 23:46
you might want to try turning your hardware "off" ingame, especially if you have Nvidea drivers. i've had the exact same problem, did all they tell you to do (i do suggest getting the thieffixedpatch for 1.33 or 1.14 (whichever version you have) from the FAQ. read my topic Thief compatible with XP?

Peter_Smith
24th Apr 2008, 05:17
You should not have to downgrade your drivers or use software rendering. That is old news. Check my sticky thread for all the current things that might help.

http://forums.eidosgames.com/showthread.php?t=76532

If these things don't work, then post your system stats and the version and publisher of the game you are playing. Also describe in detail what you did to make it work up to this point.

Some re-releases like sold-out may never work with a modern computer.

There is a remote chance that a Russian modified version of 84.56 may work when others don't, but I have never heard about that happening, so I won't go into detail about it.

Software rendering looks terrible and should be a last resort after trying everything else.

mattmanr
24th Apr 2008, 19:27
yes but if you have the released versions (like mine says it's Compatible with XP) then you will HAVE to shut off your hardware, nothing else will work (unless someone finds something out)

Peter_Smith
25th Apr 2008, 07:11
Yes, so it seems. I think you mean the re-released versions. Payne needs to say what he's got, or it is only speculation.

I think that if you have one of those versions you ought to raise a stink with the publisher and try to get your money back. Software rendering is unacceptable, and you should not have to deal with it. Who is the publisher of your version?

[clan]Payne
25th Apr 2008, 17:58
Well I got this game as a present back in ... 2000? Maybe late 1999 so it can't be a re-released version.

I did try everything in your post but nothing seems to work, keeps on going to the black screen, both for TDP and T2.

Specs: IntelDualCore 6600 @ 2.4GHz, 2 gigs of ram, GeForce 8600GTS, Windows XP SP2.

I think that's all the important stuff, tell me if im missing something.

Peter_Smith
25th Apr 2008, 19:28
Just for grins, tell us the version of your Nvidia video card driver.

The 8600 GTS is a recent Nvidia card. I don't know for sure, but the chances are good you cannot use an 8600 GTS to play Thief without first installing the DDFIX patch. This is the case for my 8800 GT, a G92 card. This applies to both T1 and T2. Two EXE's need to be modified, but they use the same DLL and INI file. Have you tried that?

Check the TTLG thread on DDFIX (it's very long) for details. I gave a link to both DDFIX and the TTLG thread in my sticky thread. Some pre-patched EXE's are posted there which may help you, but you still need the DLL and INI files from Timeslip's site.

[clan]Payne
26th Apr 2008, 00:32
169.21 are the drivers.

I tried the DDFIX but I might have screwed up somewhere along the way, will try again.

Peter_Smith
26th Apr 2008, 15:55
In T2, if you have the original EXE's with one small EXE and one larger ICD file, it will not work. You can download the fixed EXE from that TTLG thread I linked to. It may be easier to get T2 to work first, but you do need an EXE that is compatible with your version.

Another thing I forgot to mention. You need to patch T2 to the 1.18 version before everything will be compatible with the EXE's posted at TTLG. You can do that patch first without having to start the game.

Also, without DDFIX, you should be able to start both T1 and T2 versions and look at the main menu. Can you do that? DDFIX may cause a crash before you get to the main menu if the resolutions are not set right (see below).

One thing that is easy to forget is that you have to set the screen resolution to be exactly the same, to some permissible standard value, in two places: in the game (at the main menu / options / video) and in DDFIX.INI. If you can't get to the main game menu because it crashes before you get there, then the game resolution is set in CAM.CFG. I suggest 1024 x 768 to start. Thief 1 will not normally go higher than that. Then set DDFIX.INI to be the same. After you get it running in 4:3 aspect ratio, DDFIX will support some wide screen resolutions, but I wouldn't try that first.