PDA

View Full Version : Same old problem with TDP/T2



Bob
8th Apr 2008, 18:38
I'm new to the forums, so I should say hello to all of you :)

First of all, my specs :
Processor: Intel Pentium 4 HT 3.00GHz
RAM: 3GB
HDD: WD 2500JS 250GB
GPU: XFX GeForce 8800GT 512MB
Sound card: Creative SB X-Fi Xtreme Music
Operating system: MS Windows XP

So, I've encountered the same problem about which I read a whole lot of topics and at this point have tried almost all of the possible solutions. The thing is that when I attempt to start a mission after the first intro cinematics (when I have to press the "Start mission" button) the game crashes (goes to black screen). It happens in both Thief 1&2.

Things I've tried:
1)Set compatibility mode to Win 98/Me
2)Set core affinity to 1 core
3)Set graphics rendering to software
4)some other stuff (running it on as low settings/resolution as possible etc.)

Things I will try tomorrow include Orgy's texture fix and, if that doesn't work, I will downgrade my video drivers to 163.71

I just wanted to know if you guys have any other tips of what I should do because if these last two things won't work, then I'm all out of ideas :confused:

Also, if it helps I have the Sold - out value pack which includes both of these games. Both are at their latest versions (TDP - 1.33;T2 - 1.18).

Bob

mattmanr
8th Apr 2008, 19:49
well i did downgrade to 163.75 and turned Hardware OFF and I am used the thief1.33patch to fix the texture error that shows up and it works for me. I still can't have the Hardware on at the same time though, so the graphics with hardware off are going to be worse, but at least you will be able to play it

Peter_Smith
9th Apr 2008, 03:12
If you have one of the original releases, all you have to do to play Thief 1 in hardware rendering is:
set affinity to 1 processor;
use driver 163.71, 163.75, or 169.21 WHQL;
get the appropriate EXE to solve the texture problem.
Look here for the last one:
http://www.ttlg.com/forums/showthread.php?t=75031#texturememory

The above links contain other FAQs that may help.

If you have one of the re-releases such as sold out, then I think the texture manager EXEs will not work. I am not sure if texture manager bug is a problem or not with those new releases.

I think you do not have to use compatibility mode, slow settings, etc. You may have to set vsync=on for right AI speed, but that is cosmetic.

That said, you haven't really described your problem.

There are so many problems with these re-releases. They are rip-offs. If I were you I would try to get my money back. The game doesn't work, period. Software rendering looks terrible. Nobody should have to pay money and put up with that.

Or you could just go to e-bay and try to find an original release.

One long shot would be to back up your EXE and install the DDFIX patch and see if the improved 32 bit rendering helps any.
http://timeslip.chorrol.com/ddfix.html

Please describe your problem exactly, when it occurs and symptoms. Let us know if you find a fix.

Bob
9th Apr 2008, 12:52
Thanks for the replies.

To describe my problem - when I press "Start game" everything is ok and I can watch the starting cinematic. When it ends I am able to press the button "Start training". Afterwards, in the objective screen for the training mission, when I press "Continue" the game starts loading the level (the arrow is spinning) and after a few seconds the screen goes black and the only way to exit Thief is to end the unresponsive program with task manager. The same thing happens with Thief 2.

For the video card, I'm running 169.21 WHQL drivers.

I tried Orgy's texture fix - when I attempted to start the game with the thieffixed.exe I recieved a Send/Don't send error report. Fail.

I've still to try the DDFIX, but I'm not really sure that it will help.

Also, a strange thing - I tried to play Thief on my other computer (a really old one) who should be able to run Thief, but I encountered the same problem. This computers specs are the following:
Processor: Intel Pentium 2 350MHz
RAM: 512MB
HDD: 60GB
GPU: MX440 64MB
Operating system: MS Windows XP Professional SP2

Bob

P.s. -> I'm not yet willing to let go of this copy of Thief - it was a great deal (2 great games in one box) and I couldn't find this game in any other release (actually it's impossible to find good old games here in Latvia - and when it's possible, like with Fallout 2, it's in russian - a language with which I'm not very familiar).

mattmanr
9th Apr 2008, 19:03
the one i bought is a re-release, so the only way im getting it to work (along with the 163.75 driver and texture fix) is by putting the hardware off, but i do have the original disc as well that still works

Peter_Smith
10th Apr 2008, 04:22
Bob,

The thieffixed.exe is probably incompatible with the sold out version, and other re-releases for that matter. It is a modified EXE of an original Eidos released version. That EXE is designed only to solve a texture manager error. What happens if you do the affinity fix and use the correct driver but use the unfixed EXE provided by sold out? If you get a texture manager error in hardware mode, you have probably had it.