PDA

View Full Version : Thief TDP Crash after intro



K!netic
31st Mar 2008, 22:33
I've searched the web a million times, and can't find an answer.

Bear with me, i've tried every simple fix anyone can come up with.

1. Tried 3 different processor affinity programs, all of which get me to the intro (which i can watch all the way through) but crash afterward
2. Installed the indeo codec again
3. Registered the thief's LGVID.AX
4. Tried every compatibility option, and every combination thereof
5. Ran as administrator
6. Ran as a 32bit program
7. Tried to use the 1.33 patch, but every time i run it it gives me an error box saying "Couldn't find installation directory, please reinstall", no matter how many times i reinstall.
8. Updated drivers

I doubt it's a video problem, since the intro runs. It's not an affinity problem, since i can watch the intro as long as i want with the affinity on, but if it's off then it crashes immdiately.

I should also note i tried this on two totally separate computers.

1:
Intel e6600 2.4ghz (dual core)
Nvidia 8800gtx 768mb
4gb DDR2 RAM
Creative X-Fi
Vista Home Premium 64bit SP1

2:
AMD Sempron 3100+ at 1.8ghz
Nvidia 6600gt 256mb
1gb DDR2 RAM
XP SP2 32bit


I have Thief 3, and loved the idea of it, but i've always been told it's the black sheep of the series, so i'm hoping to try the original and see what the fuss is about.

I'm thinking the patch is what i want to get working, because i've heard it fixes a LOT of issues, but it won't run.

Any help?

theBlackman
1st Apr 2008, 02:14
What version do you have? If it is the UK Premier, or the Soldout, then you need a special patch.

If it is the USA EIDOS version then the Eidos patch to 1.33 version.

I am presuming that you did get the game installed, and your HDD shows a THIEF folder for TMA.

K!netic
1st Apr 2008, 05:27
I have the SoldOut version, and yes, both a Start Menu icon folder and a "add/remove programs" entry are present.

What patch should i be searching for?

theBlackman
1st Apr 2008, 06:43
Go here and download the patch.


http://www.thief-thecircle.com/media/patches/



There are a couple for TDP, so read the list and if you have a question about which one, you can ask one of the mods there.

This may be the one:Official Patches - Thief 1
Some versions of Thief, such as Thief Platinum, may come already patches, or have the patch file on your game disc.

Thief v1.33 (EAX & Bug Fixes Patch) - 9.9 Meg - readme.txt
Adds EAX (Creative Labs' "Environmental Audio Extensions") support, joystick support, cheats, and several bug fixes.



Sorry, I don't remember exactly which one. If you bought the NEW copy (the one released in the last year or so), then it should already be the 1.33 version.

Be sure to read the whole page. There is information about TDP and the rest that may point you in the right direction. You may need the CONVICT.OSM and the other mentioned.

K!netic
1st Apr 2008, 10:00
I tried reinstalling, apparently it already is on the 1.33 patch; so that explains the patch not working.

However i resolved the issue; by reinstalling without picking my directory (reinstalling to C:\Games\Thief instead of D:\Program Files\Thief\Dark Project), it suddenly works. For reasons beyond me, installing on a partition that isn't the boot partition is a big no-no for Thief 1, and causes it to do exactly what it was doing to me.

As long as it's installed on the same drive as Windows, it's fine with itself.

Note; this is only for Vista. It still refuses to work entirely on XP.


Thanks for the help anyway.

Peter_Smith
2nd Apr 2008, 05:49
Could it be the space in the name "Dark Project"? Sometimes software is peculiar that way.